Post by KDSLABY » Thu Sep 12, 2019 7:29 am

My website is done and works great on my home computer.
default template - Ver 3.0.3.2

I helped my web service provider get a new database installed on the server, uploaded my files and the .sql file - OpenCart is working too.
The issue I have is that none of the images are showing up on the website except the logo on the front page.

Here's what the root config.php file looked like before it was uploaded to the server:
// DIR
define('DIR_APPLICATION', 'C:/xampp/htdocs/baseline/catalog/');
define('DIR_SYSTEM', 'C:/xampp/htdocs/baseline/system/');
define('DIR_IMAGE', 'C:/xampp/htdocs/baseline/image/');
define('DIR_STORAGE', DIR_SYSTEM . 'storage/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/theme/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');

The file structure on the server looks like this:
Root>baseline19>all my OC files are in this baseline19 folder.

The config.php files were changed by my webhost to be able to see the website at all and the below is what the config.php files looks like now:

baseline19> config.php
// DIR
define('DIR_APPLICATION', '/home/users/web/b2973/ipg.kdslaby/baseline19/catalog/');
define('DIR_SYSTEM', '/home/users/web/b2973/ipg.kdslaby/baseline19/system/');
define('DIR_IMAGE', '/home/users/web/b2973/ipg.kdslaby/baseline19/image/');
define('DIR_STORAGE', DIR_SYSTEM . 'storage/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/theme/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');

baseline19> admin> config.php
// DIR
define('DIR_APPLICATION', '/home/users/web/b2973/ipg.kdslaby/baseline19/admin/');
define('DIR_SYSTEM', '/home/users/web/b2973/ipg.kdslaby/baseline19/system/');
define('DIR_IMAGE', '/hermes/bosnaweb18a/b2973/ipg.kdslaby/baseline19/image/');
define('DIR_STORAGE', DIR_SYSTEM . 'storage/');
define('DIR_CATALOG', '/home/users/web/b2973/ipg.kdslaby/baseline19/catalog/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/template/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');

If I go into OC I can see the images in the OC folder so it seems to me that there is a path that is not correct for the catalog and product images but I'm not sure where it is or how to correct it. The logo shows up on the main page but that's all for images and it shows up with a path:
http://baselinesuspensions.com/baseline ... /BSNEW.jpg

I did go into OC and reconnect an image on the front page but it still never showed up.
From all the vids I watched the only paths that were changed were the ones in the two config.php files listed above.

What can I try to get the images to show up?
Kevin

New member

Posts

Joined
Tue Aug 27, 2019 10:40 am

Post by by mona » Thu Sep 12, 2019 7:49 am

You slider is looking for the images
http://baselinesuspensions.com/baseline19/expl.jpg

and it should be looking for them
http://baselinesuspensions.com/baseline ... g/expl.jpg

Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by KDSLABY » Thu Sep 12, 2019 8:29 am

by mona wrote:
Thu Sep 12, 2019 7:49 am
You slider is looking for the images
http://baselinesuspensions.com/baseline19/expl.jpg

and it should be looking for them
http://baselinesuspensions.com/baseline ... g/expl.jpg
Even the product pages don't show the images.

I agree, the location of the images are here: /baseline19/image/catalog/
Where is this incorrect path(s) located at?

ks

New member

Posts

Joined
Tue Aug 27, 2019 10:40 am

Post by by mona » Thu Sep 12, 2019 8:41 am

they are supposed to be taking the cached files, but I have not managed to get to any product pages ..
could you post a webpage please

and is this right?
define('DIR_IMAGE', '/hermes/bosnaweb18a/b2973/ipg.kdslaby/baseline19/image/');

Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by KDSLABY » Thu Sep 12, 2019 9:07 am

by mona wrote:
Thu Sep 12, 2019 8:41 am
they are supposed to be taking the cached files, but I have not managed to get to any product pages ..
could you post a webpage please

and is this right?
define('DIR_IMAGE', '/hermes/bosnaweb18a/b2973/ipg.kdslaby/baseline19/image/');
Sent you a PM..

Kevin

New member

Posts

Joined
Tue Aug 27, 2019 10:40 am

Post by KDSLABY » Thu Sep 12, 2019 10:40 am

Update:
While Mona was reviewing the issues and sending me some things to read the website all of a sudden started working. Neither one of us did anything so it must be my website provider fixing it.

But here's the changes they did and I'll let you experts figure out why they did it.
But First I have TWO websites to compare files too.
Site #1) BAD because the UPS shipping didn't work so I started a brand new one. However, the images did load fine because my web host figured out how to make them load.
Site #2) GOOD - everything worked on my computer but the images won't load after being uploaded to the server.

*****
I was comparing the good/bad config.php files and I noticed that the one that would load the images (#1) had a line added to the root config.php called:
define('DIR_STORAGE', DIR_SYSTEM . 'storage/');
and there was an additional folder called storage added to the root directory.

When I was looking at the #2 web directory the storage folder was not present and the config.php did not have the above line.

NOW IT DOES... For some reason my web host created a new folder and put the images in there then rerouted everything to this folder..but why?

Here's the root config.php..obviously not all of it:
// DIR
define('DIR_APPLICATION', '/home/users/web/b2973/ipg.kdslaby/baseline19/catalog/');
define('DIR_SYSTEM', '/home/users/web/b2973/ipg.kdslaby/baseline19/system/');
define('DIR_IMAGE', '/hermes/bosnaweb18a/b2973/ipg.kdslaby/baseline19/image/');
define('DIR_STORAGE', DIR_SYSTEM . 'storage/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/theme/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');

Here's the admin config.php

// DIR
define('DIR_APPLICATION', '/home/users/web/b2973/ipg.kdslaby/baseline19/admin/');
define('DIR_SYSTEM', '/home/users/web/b2973/ipg.kdslaby/baseline19/system/');
define('DIR_IMAGE', '/hermes/bosnaweb18a/b2973/ipg.kdslaby/baseline19/image/');
define('DIR_STORAGE', DIR_SYSTEM . 'storage/');
define('DIR_CATALOG', '/home/users/web/b2973/ipg.kdslaby/baseline19/catalog/');
define('DIR_LANGUAGE', DIR_APPLICATION . 'language/');
define('DIR_TEMPLATE', DIR_APPLICATION . 'view/template/');
define('DIR_CONFIG', DIR_SYSTEM . 'config/');
define('DIR_CACHE', DIR_STORAGE . 'cache/');
define('DIR_DOWNLOAD', DIR_STORAGE . 'download/');
define('DIR_LOGS', DIR_STORAGE . 'logs/');
define('DIR_MODIFICATION', DIR_STORAGE . 'modification/');
define('DIR_SESSION', DIR_STORAGE . 'session/');
define('DIR_UPLOAD', DIR_STORAGE . 'upload/');

ks

New member

Posts

Joined
Tue Aug 27, 2019 10:40 am
Who is online

Users browsing this forum: Evilonion and 20 guests