Page 1 of 1

Site issues detected by Sucuri scan

Posted: Mon Jul 15, 2019 7:37 pm
by lukeketchum1
Hi guys

I use OC 3.0.2.0 and run a live site. Although I didn't have any reason to believe there was anything wrong with my opencart setup in terms of hacking etc I have run a sucuri scan that has rendered the following results:


Scan Failed http://www. titancards.co.uk/ Unable to scan your site. Page has a redirect loop
Site Issue Detected http://www. titancards.co.uk/404javascript.js Unable to scan the page. Page has a redirect loop
Site Issue Detected http://www. titancards.co.uk/404testpage4525d2fdc Unable to scan the page. Page has a redirect loop

Having googled it this seems to be something that usually comes up on Joomla and Wordpress, so not 100% sure what to make of this, also some people say its not a hack etc its just some sort of error somewhere.
Any idea what it is and how I can correct it?
The site loads/works fine etc but I'd still like to know whats up just incase.
Best regards
Luke

Re: Site issues detected by Sucuri scan

Posted: Mon Jul 15, 2019 8:30 pm
by letxobnav
sucuri is trying to find those pages in the expectation that they will receive a 404 as those pages do not exist, apparently your site goes into a loop instead if returning a simple 404 header?

Re: Site issues detected by Sucuri scan

Posted: Mon Jul 15, 2019 9:15 pm
by lukeketchum1
Why would it do this? Something to do with HTACCESS maybe?

Re: Site issues detected by Sucuri scan

Posted: Mon Jul 15, 2019 10:37 pm
by letxobnav
forget sucuri, it's the dumbest security scanner I have ever encountered.

Re: Site issues detected by Sucuri scan

Posted: Tue Jul 16, 2019 7:52 am
by agatha65
- You are trying to scan the http version which redirects(not well done) to the https version.
- You are using the old Journal version which has security issues, update to the v3. Or better choose another theme that follows the Opencart standards.

Re: Site issues detected by Sucuri scan

Posted: Tue Jul 16, 2019 5:09 pm
by letxobnav
that is not the issue, his site works fine, that sucuri site is just spitting out bogus nonsense messages.

(don't know why you do a 302 redirect after a 301 from http to https but I guess that is done by your nitro cache setup)