Post by kennethpoon » Wed Jun 26, 2019 2:15 pm

Hi,

I just migrated my site from A.com to B.com
I followed the instruction to do the migration
copy all files from source to destination
backup db from source and restore at destination
amend the both config.php and admin/config.php

I can login to the admin panel, but when I click on the left menu, everytime push me out and need to login again.
The error message is "Invalid token session. Please login again.", when I login again, the dashboard comes out, and same again when I click the left menu.

Please advise,

Thanks,

Kenneth

Newbie

Posts

Joined
Sun May 21, 2017 7:40 am

Post by kennethpoon » Wed Jun 26, 2019 6:24 pm

I also got the following msg when I login to the dashboard.

Uncaught SyntaxError: Invalid or unexpected token jquery-2.1.1.min.js:3
Uncaught Error: Bootstrap's JavaScript requires jQuery
at bootstrap.min.js:6
(anonymous) @ bootstrap.min.js:6

blahblahblah....

Thanks,

Newbie

Posts

Joined
Sun May 21, 2017 7:40 am

Post by paulfeakins » Wed Jun 26, 2019 6:33 pm

Are you using SSL on both sites?
What version of OpenCart is it?

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by kennethpoon » Wed Jun 26, 2019 6:35 pm

YES, both sites SSL.

Version is 3.0.3.2

Newbie

Posts

Joined
Sun May 21, 2017 7:40 am

Post by Fabienlolo » Wed Sep 25, 2019 2:53 pm

Hi,
i believe i had the same issue, from javascript.
As i duplicated my OC 3.0.2 in another subfolder, i was kicked out every click on my admin panel. I then checked my admin panel page with my browser developper tools and Firefox Console indicated "Illegal Character" in 3 different files, jquery-2.1.1-min.js, bootstrap.min.js, moment.min.js.
So I compared codes in those 3 files between the ones in original folder and ans the ones in new folder, to find out which character might have been changed when pasting. All look identical using string comparison tools.
Then i went to read about Firefox illegal character mention, and last but not least, i learned about ZWSP, zero width space, that can be added when copying/pasting text. And files i guess, as it happened to me.
So i went to copy/paste those 3 files from the OC genuine files, not my original folder of my own OC, and everything came back running smoothly.
Hope that could help
And about help, thanks to ravikumar22 for his contribution after i saw his post in this topic viewtopic.php?f=202&t=204674 as i wrote to him for help and got the right little push in the right direction .

New member

Posts

Joined
Fri Jun 29, 2018 7:24 am
Location - Q.Roo, Mexico
Who is online

Users browsing this forum: No registered users and 18 guests