Post by judyatech » Sat Apr 27, 2019 8:44 am

Longtime lurker, 1st time poster I think? I read the rules and I hope my post complies.
I'm having trouble with the cart showing after adding a custom product.
Here's my config and some things I've tried:

Store URL:
Theme: None
Export/Import Tool (V3.20) for OpenCart 3.x
Ajax Live Options Denise V3.0 Disabled

When adding a certain custom product(s) to the lineup, when that product is added to cart, that product doesn't show IN the cart, only item count and dollar amount is shown by the icon in the header. If it is the -only- thing that was added, clicking on the cart icon results in the message 'your cart is empty' and it seems to break everything for that user's session. In order to even view any part of the store again, browser cache & cookies must be cleared. Refreshing browser page is no help, if that is done it's the same result as attempting to view the cart: the error message will be:
This page isn’t working is currently unable to handle this request.

If other items were added to the cart, they'll show, but clicking to view the cart page will result same as above.

I don't think it is anything to do with Export/Import as I am able use that function to clear store of all product/options/categories, then import categories, options and products that were exported from the default store. I am also able to import custom categories, options and products the same way.

Using a browser as a customer, when adding only default products from the original set up, every thing works fine and clicking on the cart icon shows the quicklist of products and then we can click into the actual cart. (I haven't gone so far as to try to complete a sale with this configuration, due to the issues here.)

I have viewed and compared the category and product parameters (there are no options for this product) using the export function into spreadsheets. I can see no reason for any issue with this product.

I have read much of these forums looking for a solution. From reading I realize I should probably say that the storage is outside my public_html. I have cleared storage/cache except index.html after each change. I have cleared the caches listed on the Dashboard accessed by *. I've had no trouble following the instructions regarding setup of database etc. or using rudimentary myphpadmin.

I have tried several fixes mentioned in these forums that I tought might have been related, but nothing has helped, and I'm not finding anything that's quite as odd as only certain products causing trouble in the cart.

I had been configuring products on a different store and noticed this trouble so I installed to this location in order to attempt isolation of the issue.

Just for the heck of it, I added a sucker to the store. IT works, LOL

To see this, click on Bags, Surveyor Bags

A link to your site:

Is it a single or multistore setup?
Single store setup

No error logs I can find regarding this.
Usually I'm able to determine from the log what is the problem, if not on my own, then by visiting the forums etc.

This has me well and truly stumped although I've NO doubt it's going to be something really simple. I'd be so grateful for help!

If desirable, I can upload the product export in spreadsheet or text etc.




Sat Apr 27, 2019 8:24 am

Post by IP_CAM » Sat Apr 27, 2019 10:01 pm

Make sure, that the .htaccess RewriteBase is linked as shown below.

Code: Select all

## If your opencart installation does not run on the main web folder,
## make sure you folder it does run in ie. / becomes /cart/ or /shop/ 
RewriteBase /shopper/

I am no longer active at this Forum.
Please don't send Personal Messages, contact:
Github OC Downloads:
2'000+ FREE OC Extensions from the World's largest Github OC Archive.

User avatar
Legendary Member


Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by judyatech » Sun Apr 28, 2019 2:42 am

Hmm well I HADN'T done that, and I needed to have, so thanks for the reminder! But, doing so has had no effect on this issue.




Sat Apr 27, 2019 8:24 am

Post by judyatech » Sun Apr 28, 2019 3:38 pm

Well, I figured it out finally! Thanks to a previous thread in these forums :) Did a bit of file by file comparisons with a sample store that was working (different products) and noticed a different error log file. It referenced "PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 15532 bytes)", so I googled that, and found a thread :
that mentioned image sizes and the word 'mahoosive' LOL (thanks to uksitebuilder and IP_CAM)
Well, yes, my images do seem to be uh...kinda large. I'd used ftp to upload them, and at no point did I get any 'complaint' until the shopping cart wouldn't show it. I still got no error message from within 'system/maintenance/error logs'. BUT, the product profiles load MUCH faster (imagine that huh?). And we're not showcasing works by Rembrandt, so I'll be reducing the file sizes asap!

I still owe a debt of gratitude to you for your past work, without which, I'd still be stuck!




Sat Apr 27, 2019 8:24 am

Post by cyclops12 » Sun Apr 28, 2019 4:16 pm

Glad you got it working and well done on posting the solution.
May help others in the future

Expert Member


Sun Sep 27, 2015 1:10 am
Who is online

Users browsing this forum: No registered users and 16 guests