Post by lastbadguy » Thu Mar 28, 2019 9:35 pm

ok so i was working on my site yesterday and i must have clicked something wrong because i am now getting this if i try to access the site

Warning: fopen(/hermes/walnaweb12a/b429/storage/logs/openbay.log): failed to open stream: No such file or directory in /hermes/walnaweb12a/b429/as.deviouspleasure/system/library/log.php on line 22Warning: fopen(/hermes/walnaweb12a/b429/storage/logs/openbay.log): failed to open stream: No such file or directory in /hermes/walnaweb12a/b429/as.deviouspleasure/system/library/log.php on line 22Warning: fclose() expects parameter 1 to be resource, boolean given in /hermes/walnaweb12a/b429/as.deviouspleasure/system/library/log.php on line 39

i was getting a longer error message before but i managed to find the file that was different from the installation file and 2/3 of the error message went away


any insight would be greatly appreciated

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by uksitebuilder » Fri Mar 29, 2019 1:41 am

Hi,

Just create a blank file named 'openbay.log' and put it in your storage/logs/ folder

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by lastbadguy » Fri Mar 29, 2019 2:44 am

that file is currently there and i have changed the permissions to 777 just to be sure

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by paulfeakins » Fri Mar 29, 2019 8:28 pm

lastbadguy wrote:
Fri Mar 29, 2019 2:44 am
that file is currently there and i have changed the permissions to 777 just to be sure
Don't do that.

Files should be 644, folders should be 755.

If you set it to 777, it may get blocked as well as being a security risk.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by lastbadguy » Fri Mar 29, 2019 9:10 pm

ok i put it back to the original permissions

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by mondersky » Fri Oct 16, 2020 11:01 pm

I had the same issue, it happened after I clicked on the "Important security Notification" popup's button on my admin panel
I fixed it by changing one line of code in my config file (admin & root folders), you just need to make sure the link of the storage folder is correct- just follow the screenshot
Image
source: link

Newbie

Posts

Joined
Thu Mar 02, 2017 2:38 am
Who is online

Users browsing this forum: No registered users and 33 guests