Post by vvinyl » Thu Mar 21, 2019 5:22 am

Hello everyone,

I am on OC 3.0.2.1.

I have a problem with the resetting of the passwords for customers. When a customer want's to reset their password they press forgot password. Once clicked, they receive an email and reset their password. Once on the page, they receive an error stating: "Password reset code is invalid or was used previously"

I'm not sure where to begin to diagnose this. I was wondering if I can get some guidance or if anyone has experienced this?

Thanks in advance.

Newbie

Posts

Joined
Tue Aug 07, 2018 2:25 am

Post by paulfeakins » Thu Mar 21, 2019 6:12 pm

vvinyl wrote:
Thu Mar 21, 2019 5:22 am
I'm not sure where to begin to diagnose this. I was wondering if I can get some guidance or if anyone has experienced this?
First step is usually to rule out any extensions or custom code - do you have either?

Second step is usually to work out exactly how that feature works in the code, so how is a reset code generated? Where is it stored? When is it then compared to the one in the link a customer clicks?

When a value is not what you expect (such as the code matching), tracing the value of the variable at each step is my standard debug procedure to see where it changes from the value you expect to the wrong one and why.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 8 guests