Post by Mentor-kh » Sat Mar 16, 2019 9:57 pm

Hi mates!
I am trying to deploy my default v3.0.3.1 of the CMS here - http://opencart-default.is-best.net and facing 2 issues:
1 login to admin not works at all. It just refresh my page without any error and changing log files. (This could be fixed with updating framework.php file with adding time() + (some number here) to setcookie function. The question is like, this is a bug? Or I need do something else?
2 when I am trying to add any product to cart, it just refreshing 1 item and when I go to other page, or directly at cart page it shows me - Your shopping cart is empty! I am facing such issue just at my real hosting account and can't see it when I use my local server. So the question is? Where I should dig? Maybe if this is my hosting provider issue, what I should ask him?
Thank you beforehand!

Newbie

Posts

Joined
Tue Jul 18, 2017 12:35 am

Post by chongshengdz » Sat Mar 16, 2019 10:47 pm

this is your hosting provider's issue.
you can try to install opencart step by step to see if there is any issue?
don't use auto install script.

https://www.transistorfet.com/
https://www.transistormosfet.com/


New member

Posts

Joined
Sat Apr 12, 2014 10:18 pm


Post by chongshengdz » Sat Mar 16, 2019 10:50 pm

and opencart 3.0+ using twig theme, you need to log in to your admin and clear your cache after installing.

https://www.transistorfet.com/
https://www.transistormosfet.com/


New member

Posts

Joined
Sat Apr 12, 2014 10:18 pm


Post by Mentor-kh » Mon Mar 18, 2019 5:47 pm

chongshengdz wrote:
Sat Mar 16, 2019 10:47 pm
this is your hosting provider's issue.
you can try to install opencart step by step to see if there is any issue?
don't use auto install script.
Not installation issue, and not cache issue. I've tried clear, disable cache and installation move smoothly without any errors. What I see cart function uses js ajax and as url route checkout/cart/add but always return success json with latest added product. And quantity always 1. Also when moving throw pages quantity become zero. What is responsible for the answers? I am not so strong at backend but you've write something about hosting provider issue. What it could be? Its blocking something? Session, cookies, or data base updating by ajax? Sorry if this has no sence

Newbie

Posts

Joined
Tue Jul 18, 2017 12:35 am

Post by Mentor-kh » Fri Mar 22, 2019 10:00 pm

Somehow I've realized that when I am posting products to cart and checking phpmyadmin oc_cart table, each product has new session_id. I've begun to dig this issue and found solution here - https://github.com/opencart/opencart/issues/3482
Maybe this will be usefull for somebody, just left it here

Newbie

Posts

Joined
Tue Jul 18, 2017 12:35 am
Who is online

Users browsing this forum: No registered users and 12 guests