Post by wickedstangs » Sun Feb 17, 2019 4:33 am

Worked for me on 3.0.3.1
GOTO
Design > Theme Editor > common > header.twig

LIne 46 removed
li><a href="{{ contact }}"><i class="fa fa-phone"></i></a> <span class="hidden-xs hidden-sm hidden-md">{{ telephone }}</span></li>

Running Opencart v3.0.3.1 http://www.wickedstangsperformanceshop.com
http://www.slpgear.com


New member

Posts

Joined
Sat Oct 22, 2011 12:16 pm

Post by IP_CAM » Sun Feb 17, 2019 5:06 am

Well, better change your Footer Information too, to match your Version,
you no longer use v.1.5.1.3, as it looks !
But removing Code from such a major File could eventually lead to malfunction
of an OcMod/VqMod, using some of that Code, to 'add' something else
before or after that Top Header Variable, if it does not exist anymore.

Still, my solution wold most likely keep such a Mod from displaying something also,
by eventually so beeing part of that 'hidden' Section to. But since such 'Anchor-Code'
would still exist, in unchanged form, just 'marked hidden', it would so at least not
create another error_log line, with every single pageload made .... :-( :-)
Just to make sure, if one frequently add's new Mods to an Installation, in general ...
Ernie

Code: Select all

<span class="hidden"><li><a href="{{ contact }}"><i class="fa fa-phone"></i></a> <span class="hidden-xs hidden-sm hidden-md">{{ telephone }}</span></li></span>
Image

Attachments

hide_phone_number_in_header.jpg

hide_phone_number_in_header.jpg (16.67 KiB) Viewed 202 times


I am no longer active around here, to reach me, contact: jti@jacob.ch
My latest Freeware Opencart LIGHT Testsite, available on demand: http://www.ebikes.li/shop/
My 888 FREE OC Extension-Repositories - from OC v.1.5.x up,
on the largest OC Extension Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by wickedstangs » Mon Feb 18, 2019 12:35 am

IP_CAM wrote:
Sun Feb 17, 2019 5:06 am
Well, better change your Footer Information too, to match your Version,
you no longer use v.1.5.1.3, as it looks !
But removing Code from such a major File could eventually lead to malfunction
of an OcMod/VqMod, using some of that Code, to 'add' something else
before or after that Top Header Variable, if it does not exist anymore.

Still, my solution wold most likely keep such a Mod from displaying something also,
by eventually so beeing part of that 'hidden' Section to. But since such 'Anchor-Code'
would still exist, in unchanged form, just 'marked hidden', it would so at least not
create another error_log line, with every single pageload made .... :-( :-)
Just to make sure, if one frequently add's new Mods to an Installation, in general ...
Ernie

Code: Select all

<span class="hidden"><li><a href="{{ contact }}"><i class="fa fa-phone"></i></a> <span class="hidden-xs hidden-sm hidden-md">{{ telephone }}</span></li></span>
Image
The site I'm messing with is located at https://slpgear.com/ where would you recommend I do edits at? Also, thanks for the code that works too without removing code nice...

Running Opencart v3.0.3.1 http://www.wickedstangsperformanceshop.com
http://www.slpgear.com


New member

Posts

Joined
Sat Oct 22, 2011 12:16 pm

Post by straightlight » Mon Feb 18, 2019 2:34 am

wickedstangs wrote:
Sun Feb 17, 2019 4:33 am
Worked for me on 3.0.3.1
GOTO
Design > Theme Editor > common > header.twig

LIne 46 removed
li><a href="{{ contact }}"><i class="fa fa-phone"></i></a> <span class="hidden-xs hidden-sm hidden-md">{{ telephone }}</span></li>
You are going in the right direction. By removing these lines from the editor is a positive way to do it. However, ensure to clear the OC cache once done: viewtopic.php?f=176&p=739789#p718325 in case you don't see any changes afterwards.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by wickedstangs » Mon Feb 18, 2019 5:45 am

straightlight wrote:
Mon Feb 18, 2019 2:34 am
wickedstangs wrote:
Sun Feb 17, 2019 4:33 am
Worked for me on 3.0.3.1
GOTO
Design > Theme Editor > common > header.twig

LIne 46 removed
li><a href="{{ contact }}"><i class="fa fa-phone"></i></a> <span class="hidden-xs hidden-sm hidden-md">{{ telephone }}</span></li>
You are going in the right direction. By removing these lines from the editor is a positive way to do it. However, ensure to clear the OC cache once done: viewtopic.php?f=176&p=739789#p718325 in case you don't see any changes afterwards.
Awesome and thank you that worked....

Running Opencart v3.0.3.1 http://www.wickedstangsperformanceshop.com
http://www.slpgear.com


New member

Posts

Joined
Sat Oct 22, 2011 12:16 pm
Who is online

Users browsing this forum: thekrotek and 16 guests