Post by nongetjie » Wed Oct 31, 2018 8:05 pm

I can add related products in OC 3.0.2.0 and save them. They then will display correctly on the frontend.
However when I edit a product with related products again, the related products do not get saved. I see them in the related products field, but they do not get saved. When reopening that producht they are gone.

Anyone any clue as to why this is happening?

Reproduce:
1. Edit product
2. Add related products
3. Save product
4. Observe that the products display on the frontend and are thus saved
5. Edit product
6. Observe that related products are visible in related products field
7. Save product
8. Observe that products are gone on the fronted
9. Edit product
10. Observe that there are no related products any more in related products field

Attachments

Screenshot 2018-10-31 at 13.00.28.png

Screenshot 2018-10-31 at 13.00.28.png (10.78 KiB) Viewed 160 times

Screenshot 2018-10-31 at 13.00.12.png

Screenshot 2018-10-31 at 13.00.12.png (19.94 KiB) Viewed 160 times


New member

Posts

Joined
Wed Nov 07, 2012 8:28 pm

Post by oc-extensions » Mon Nov 05, 2018 12:16 am

Hi,

Probably you have some OCMOD extension which overwrite some areas of controller or model, because by default opencart doesn't have this bug;
Have you checked log to see if there's any error(s) reported?

Ask a developer to take a look.

Wish you many sales!

Image | Extensions and Custom Development


User avatar
Active Member

Posts

Joined
Fri Jan 06, 2012 11:31 pm
Who is online

Users browsing this forum: No registered users and 15 guests