Post by FCWC » Sat Oct 06, 2018 3:34 am

SOLVED!

OG Question:
Test install of OC 3.02

The demo page(s) work correctly but then I removed the demo data (SQL - Truncate) and imported my own test products (a few hundred)
The import file contains Product Info and SEO Info. Imports succeeds and all products show individually and by sub-category but will not show when clicking on Show All ** (main category) . Page loads the the Main category Text including picture and description along with the Refine Search text and link listing of the subcategories. Just no products. All blank.

Resolution
So I have Export/Import Tool (V3.20) for OpenCart 3.x by mhccorp.com extension installed.
It turns out that when using this to import products it does not create an entry within "oc_product_to_category" DB table for the main category. IE every product that is within a sub category should have 2 entries - 1 for sub cat ID and the other for its main cat ID. (or more dependent on# of sub-sub cats)
I am about to contact them about this but for now I will export that table in the DB - use Calc to amend. And update table (via phpmyadmin)

This is a tale of - you shouldn't do 2 different apps at same time. It was simple as putting both MAIN and Sub Cat ID within the CAT ID import column seperated by a comma.
Last edited by FCWC on Fri Oct 19, 2018 3:06 am, edited 2 times in total.

New member

Posts

Joined
Tue Jul 31, 2012 3:17 am

Post by straightlight » Sat Oct 06, 2018 8:10 pm

Imported hundreds of products from where? Partial information posted, more information needed.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: AndreyPopov and 23 guests