Page 1 of 1

OpenCart storage modifications are not applied

Posted: Fri Jun 15, 2018 1:43 am
by shocker
Hello,
I'm using some extensions via ocmod and the files are being correctly applied on storage/modification/ but they are ignored by opencart.
Even that I'm altering manually the files in modification folder nothing happens, it's only working if I'm applying to core files.

Any idea what can trigger this?

I'm using OpenCart 3.0.2.0

Thanks

Re: OpenCart storage modifications are not applied

Posted: Fri Jun 15, 2018 1:56 am
by IP_CAM
Well, you could check your OcMod Log, to then find
some ERROR messages, I assume...
Ernie

Re: OpenCart storage modifications are not applied

Posted: Fri Jun 15, 2018 2:04 am
by shocker
The log is error free, and in the log I can see that everything is applied. Checked manually the file and it's ok.

Seems that the issue is only happening with admin side, for the catalog everything works ok.
For example everything I'm altering in /storage/modification/admin/view/template/sale/order_list.twig is not applied, for for catalog everything works ok.

Re: OpenCart storage modifications are not applied

Posted: Fri Jun 15, 2018 2:49 am
by yodapt
Check if the location of that storage folder is the same in config files.

Re: OpenCart storage modifications are not applied

Posted: Fri Jun 15, 2018 12:35 pm
by shocker
The location is correct. The modifications are applied (it's writing the file) and I can see them, the only problem is that they are not displayed. Only works if I'm editing directly the core file