Post by maverik » Wed May 16, 2018 7:43 pm

Hi,

My website is http://www.fishing2u.co.uk/

It is running incredibly slow, hosting is not the issue.

Running Opencart 3.0.2.0 and not sure what to do in regards to the speed.

Can anyone help?

Newbie

Posts

Joined
Tue Nov 21, 2017 11:28 pm

Post by yodapt » Wed May 16, 2018 8:10 pm

You should minify the output, compress it and optimize those images. Some cache control headers for the assets couldn't hurt either.
Last edited by yodapt on Thu May 17, 2018 6:58 pm, edited 1 time in total.

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by maverik » Wed May 16, 2018 8:20 pm

Thanks for the post.

That didn't really mean much to me I'm afraid. In laymen terms? :)

Newbie

Posts

Joined
Tue Nov 21, 2017 11:28 pm

Post by maverik » Wed May 16, 2018 8:27 pm

Just to update I have added this code in to the htaccess file

<IfModule mod_deflate.c>
# Compress HTML, CSS, JavaScript, Text, XML and fonts
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
AddOutputFilterByType DEFLATE application/x-font
AddOutputFilterByType DEFLATE application/x-font-opentype
AddOutputFilterByType DEFLATE application/x-font-otf
AddOutputFilterByType DEFLATE application/x-font-truetype
AddOutputFilterByType DEFLATE application/x-font-ttf
AddOutputFilterByType DEFLATE application/x-javascript
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE font/opentype
AddOutputFilterByType DEFLATE font/otf
AddOutputFilterByType DEFLATE font/ttf
AddOutputFilterByType DEFLATE image/svg+xml
AddOutputFilterByType DEFLATE image/x-icon
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/xml

# Remove browser bugs (only needed for really old browsers)
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
Header append Vary User-Agent
</IfModule>

Newbie

Posts

Joined
Tue Nov 21, 2017 11:28 pm

Post by IP_CAM » Wed May 16, 2018 8:39 pm

Well, if you check on your Site, there is no </BODY> </HTML> anywhere ..... :'(
Ernie

I'm no longer active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in Action here: http://www.jti.li/shop/
---
940+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by maverik » Wed May 16, 2018 9:00 pm

Only using standard Opencart theme, not modified so wouldn't that be a flaw with opencart?

Newbie

Posts

Joined
Tue Nov 21, 2017 11:28 pm

Post by yodapt » Wed May 16, 2018 9:12 pm

This is not someone without experience can fix, you need an extension or someone doing it for you. If you search the marketplace there are several options available, but besides the most expensive one I dont know any that does all you need to speed up your website.

This is not a flaw on Opencart, there are several things wrong with your store that do not come with a clean install, so something got messed up.

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by IP_CAM » Thu May 17, 2018 1:23 am

Well, by looking at your Site, I am absolutely sure, that you are NOT just
using a fully default Theme, and added no extensions... 8)
Ernie

Code: Select all

<link href="catalog/view/javascript/supermenu/supermenu.css?v=30" type="text/css" rel="stylesheet" media="screen" />
<link href="catalog/view/javascript/vie_visual_theme_editor/css/animate.css" type="text/css" rel="stylesheet" media="screen" />
<script src="catalog/view/javascript/jquery/swiper/js/swiper.jquery.js" type="text/javascript"></script>
<script src="catalog/view/javascript/supermenu/supermenu-responsive.js?v=30" type="text/javascript"></script>
<script src="catalog/view/javascript/supermenu/jquery.hoverIntent.minified.js" type="text/javascript"></script>
<script src="catalog/view/javascript/vie_visual_theme_editor/jquery.waypoints.min.js" type="text/javascript"></script>
<script src="catalog/view/theme/extension_liveopencart/related_options/js/liveopencart.select_option_toggle.js?v=1516190469" type="text/javascript"></script>
<script src="catalog/view/theme/extension_liveopencart/related_options/js/liveopencart.related_options.js?v=1516190469" type="text/javascript"></

I'm no longer active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in Action here: http://www.jti.li/shop/
---
940+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by paulfeakins » Thu May 17, 2018 6:45 pm

maverik wrote:
Wed May 16, 2018 9:00 pm
Only using standard Opencart theme, not modified so wouldn't that be a flaw with opencart?
Lol, as above, this isn't true.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by maverik » Mon May 21, 2018 3:15 pm

paulfeakins wrote:
Thu May 17, 2018 6:45 pm
maverik wrote:
Wed May 16, 2018 9:00 pm
Only using standard Opencart theme, not modified so wouldn't that be a flaw with opencart?
Lol, as above, this isn't true.

Glad you find it funny, very helpful thank you.

When I say it isn't modified I mean I am not using a theme so don't understand why there are so many faults. Like it has no body ect.

If you don't want to help that's fine. But if you do want to post at least please be helpful.

Thank you Paul for showing me antropy.co.uk isn't the company to turn to for help.
Last edited by maverik on Mon May 21, 2018 3:22 pm, edited 1 time in total.

Newbie

Posts

Joined
Tue Nov 21, 2017 11:28 pm

Post by maverik » Mon May 21, 2018 3:20 pm

IP_CAM wrote:
Thu May 17, 2018 1:23 am
Well, by looking at your Site, I am absolutely sure, that you are NOT just
using a fully default Theme, and added no extensions... 8)
Ernie
The theme is default, yes extensions have been added. When I say not modified I was meaning the theme, wouldn't have thought extensions being none theme would effect the html in like it has no body ect?

Newbie

Posts

Joined
Tue Nov 21, 2017 11:28 pm

Post by maverik » Mon May 21, 2018 3:21 pm

yodapt wrote:
Wed May 16, 2018 9:12 pm
This is not someone without experience can fix, you need an extension or someone doing it for you. If you search the marketplace there are several options available, but besides the most expensive one I dont know any that does all you need to speed up your website.

This is not a flaw on Opencart, there are several things wrong with your store that do not come with a clean install, so something got messed up.
My experience is very limited, hence why I have a broken website and no hair! :)

Thank you, we are looking to employ a professional developer to help out,

Newbie

Posts

Joined
Tue Nov 21, 2017 11:28 pm

Post by IP_CAM » Tue May 22, 2018 7:19 am

Well, If one is unfamiliar with this kind of Software, in order to
eventually succeed at last, either get smart about OC:
https://isenselabs.com/books/allbooks
Or then, get the Job done by a Pro, just like in real Life too.
And that's, what you plan.
But just be careful, the OC Air is full of Black Flies too, and
one can get bitten, if counting on one, not able (or willing)
to at least 'show' something in 'real' ... :choke:
Good Luck!
Ernie

I'm no longer active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in Action here: http://www.jti.li/shop/
---
940+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by uksitebuilder » Tue May 22, 2018 2:28 pm

The first thing to do is make sure that all theme files are default unedited. If you are using the default theme, then simply re-upload the default theme files from the OpenCart download matching your version of OC.

Next step is to find the culprit extension

Disable all modifications via admin - extensions - modifications.

Refresh the modifications after disabling.

Visit the admin Dashboard, click the 'cog' top-right and refresh or disable the caches

Check the website and clear your browser cache too as a precaution.

If the html is not back to how it should be, start the process of finding the bad egg (extension)

1. enable one of the modifications
2. refresh the modifications cache and any other caches
3. check the website

Rinse and repeat until the problem occurs again.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by maverik » Wed May 23, 2018 3:30 pm

Thank you all! :)

Newbie

Posts

Joined
Tue Nov 21, 2017 11:28 pm

Post by ocguru » Wed May 23, 2018 7:46 pm

Hi, your site is on Maintenance mode currently. As far as I see, its Default opencart theme. There are so many categories so you must have many products on website. To proper optimize you need to work on Database, Cache, Compression, Images, HTML, JS, CSS, etc.
I can help you to optimize your site.

Regards,
OCGURU
Opencart Developer - View All Extensions
Contact Me - outputwebtech@gmail.com


User avatar
New member

Posts

Joined
Sat Jan 03, 2015 5:09 pm
Location - India
Who is online

Users browsing this forum: No registered users and 23 guests