Post by BlueWhale » Fri Dec 29, 2017 6:51 pm

Good morning,

I tried upgrading my Opencart store from 1.5.4.2 (I believe) to 3.0.2.0. It worked out ok, but the admin pages were despirately slow to load (10-15 seconds). Although the store front was almost instantaneous. Thinking it was due to a hangup with a previous installation, I backed up the database and files and removed the installation. I then removed all the databases and files and started with a fresh installation. All worked fine with just the Demo stuff installed. I then re-imported the database which again caused the admin site to slow right down again.

The database very small ). Just 100 products. around 7000 entries spanning the last 4 years. Largest few tables here:

oc_order_total, 7712 rows, 549 KiB
oc_order_option, 4013 rows, 288.7 KiB
oc_order_history, 3974 rows, 498 KiB
oc_zone, 3726 rows, 161.2 KiB
oc_order_product, 3229 rows, 452.2 KiB
oc_customer_ip, 2415 rows, 151.9 KiB
oc_order, 1918 rows, 1.2 MiB

Grateful if anyone could shed any light on where I might start looking for the issue that's causing only the admin system to be so slow!

My web-hosting settings state that there is 128Mb ram allocated to this application. I would have thought this was more than sufficient for such a small database.

Thanks in advance for your assistance.

Newbie

Posts

Joined
Fri Dec 29, 2017 6:38 pm

Post by straightlight » Fri Dec 29, 2017 10:52 pm

The database very small ). Just 100 products. around 7000 entries spanning the last 4 years. Largest few tables here:
Hi,

I did recently mentioned on the forum that the orders should be restricted by year to optimize the queries, especially for users using the lowest web host qualities. In your admin reports, see if you can filter by the same year range and notice if the speed gets normal afterwards. If so, then this issue is likely to be with the indexes of your database or the host package you're currently using.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by BlueWhale » Sat Dec 30, 2017 6:35 am

straightlight wrote:
Fri Dec 29, 2017 10:52 pm

Hi,

I did recently mentioned on the forum that the orders should be restricted by year to optimize the queries, especially for users using the lowest web host qualities. In your admin reports, see if you can filter by the same year range and notice if the speed gets normal afterwards. If so, then this issue is likely to be with the indexes of your database or the host package you're currently using.
Thanks for your reply straightlight. What's the best way to remove all of those orders? Clearly there are a lot of additional linked tables. I removed all but the last few orders manually from the MySQL database, but it makes no difference.

How do I index the database properly?

Thanks.

Newbie

Posts

Joined
Fri Dec 29, 2017 6:38 pm

Post by straightlight » Sat Dec 30, 2017 9:18 am

The instructions are ... right above:
In your admin reports, see if you can filter by the same year range and notice if the speed gets normal afterwards.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by BlueWhale » Sat Dec 30, 2017 5:47 pm

Many thanks. After spending hours going through the databases and trying to find where the errors lay, I decided it's easier to delete the store and start again.

Thanks.

Newbie

Posts

Joined
Fri Dec 29, 2017 6:38 pm

Post by straightlight » Sat Dec 30, 2017 10:52 pm

Not the best suggested course of action regarding the orders of the same year that have been completed and for the order IDs that would no longer match the previous completed orders with the payment providers.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by rgbrewer » Thu Feb 14, 2019 9:29 am

Bumping for new information --

My admin section was taking ~25 second for page load on local development.

Found solution here --
https://github.com/opencart/opencart/issues/5559

Issue is due to SASS recompiling at every page load.

in system/config/admin, comment out line 26 'startup/sass'

Page load for admin side went from 25 seconds to 2 seconds. Obviously there are drawbacks to not compiling your sass -- if youve changed it, your changes will not be reflected.

New member

Posts

Joined
Sat Apr 22, 2017 9:30 am

Post by exit15 » Fri Apr 26, 2019 10:11 am

If only on the admin login page takes forever to load, it probably has something to do with currency update service failing in the background. Problem solved by installing this free extension curreencyupdatepatch30XX.ocmod

New member

Posts

Joined
Sun Mar 03, 2013 2:05 am


Post by straightlight » Sat Apr 27, 2019 2:52 am

exit15 wrote:
Fri Apr 26, 2019 10:11 am
If only on the admin login page takes forever to load, it probably has something to do with currency update service failing in the background. Problem solved by installing this free extension curreencyupdatepatch30XX.ocmod
Location?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 19 guests