Post by dogart » Tue Aug 29, 2017 9:51 am

hello.

2 issues for me.
I am having trouble with SEO URL setup
I have two htaccess files in my root directory
htaccess and .htaccess.txt
What do I do here, delete htaccess which is the original file and amend the .htaccess.txt by removing the .txt extension?
I have tried to amend by doing a few trials of re-namimg/deleteing but when I do I get 404 error on certain pages.

Next one is API setup.

I have done all the steps added my API user name and secret, hit save
But I still get the red triangle in top right corner which says the following when I click on it
Signature hash does not match!
I have also tried with a new secret but still doesn't work!

Any suggestions?

Thanks in advance.

New member

Posts

Joined
Tue Aug 15, 2017 9:58 pm

Post by nic731 » Tue Aug 29, 2017 3:27 pm

Is that a fresh install?
Keep the original file and rename it as .htaccess

Newbie

Posts

Joined
Wed Mar 22, 2017 12:25 pm

Post by dogart » Tue Aug 29, 2017 3:35 pm

Yes it was a new install from Hostpapa.

OK i just did that deleted the hatches.txt and I get the SEO URL's showing up in some products.
But others it comes up with 404 not found
and for the offending page a line saying...
The server can not find the requested page:
coolstuff4u.com.au/Pet-treat-dispenser (port 443)

New member

Posts

Joined
Tue Aug 15, 2017 9:58 pm

Post by dogart » Tue Aug 29, 2017 3:50 pm

OK I seem to be losing all pages now!

New member

Posts

Joined
Tue Aug 15, 2017 9:58 pm

Post by dogart » Tue Aug 29, 2017 4:03 pm

my current hatches file

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php56” package as the default “PHP” programming language.
<IfModule mime_module>
AddType application/x-httpd-ea-php56 .php .php5 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit

New member

Posts

Joined
Tue Aug 15, 2017 9:58 pm

Post by dogart » Tue Aug 29, 2017 4:11 pm

Have just tried replacing that file with this one and still no joy!

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

New member

Posts

Joined
Tue Aug 15, 2017 9:58 pm

Post by dogart » Thu Aug 31, 2017 2:21 pm

Anyone able to help me out with this please?

New member

Posts

Joined
Tue Aug 15, 2017 9:58 pm
Who is online

Users browsing this forum: paulfeakins and 32 guests