Page 1 of 1

Slideshow speed

Posted: Thu Aug 03, 2017 11:43 pm
by Landmaster
I have changed the 'autoplay' value in catalog\view\theme\default\template\extension\module\slideshow.twig in Version 3.0.2.0 but it does not appear to make any difference to the speed of the slider. Any ideas please?

Re: Slideshow speed

Posted: Tue Aug 08, 2017 2:40 am
by cyclops12
Well i just changed the autoplay value in theme editor in admin and the changes work fine
Are you clearing your cache and refreshing your browser?

Re: Slideshow speed

Posted: Tue Aug 08, 2017 4:02 pm
by Landmaster
Hi cyclops12

Thanks for your reply. I had done that but although the length of time a slide shows varies according to the value I input I cannot get it to make a difference to the speed of the transition between slides which I want to slow down. I am guessing there may be another setting for this but whatever I change it does not appear to have an effect.

Re: Slideshow speed

Posted: Wed Aug 09, 2017 1:03 am
by cyclops12
Aha i see.......
well after a bit of searching i found it.
In catalog/view/javascript/jquery/swiper/js/swiper.jquery.js around line 30 you should find

Code: Select all

speed: 300,
This is the transition speed (default 300ms)

hope this helps

Re: Slideshow speed

Posted: Wed Aug 09, 2017 3:49 pm
by Landmaster
Perfect, thank you!

Re: Slideshow speed

Posted: Wed Sep 06, 2017 9:04 am
by lora
Using 3.0 and just cannot get the speed to slow down - will not let us change on line 30 of the code. Any suggestions other than adding more slides with less info on each slide?

Re: Slideshow speed

Posted: Wed Oct 11, 2017 10:46 pm
by StormDesigner
Hi, my question is nearly identical and I was hoping the same slider.jquery.js would have an obvious spot for this but I'm currently blind to it if it's in there. Using the suggestion above it was easy to slow down the "transition". It appears to then hold on a slide for about 4 seconds before the next slide. That doesn't allow time for reading the slide so I want to now adjust the delay between transitions similarly.

I did adjust the transition from 300ms (zooming by in .3 seconds) to a slow and easy full 3000ms (3 seconds) now if I can get it to hold on each slide for 10 seconds instead of 4 my work is done. Well, not all of it. ... I'd imagine the same file holds the clue to that. If I find it I'll update my post but if I haven't and you know it, please tell.
I was able to find this in the file and on the site allegedly of the authors of swiper but it isn't helping.
In swiper.jquery.js:

Code: Select all

 
32. autoplay: false,
33. autoplayDisableOnInteraction: true,
34. autoplayStopOnLast: false,
I replaced the default "False" with numbers 10000 to try and freeze on each slide for 10 seconds but that didn't seem to make a difference.
I scanned through the rest of the file but didn't see clues. Must be getting that parameter from somewhere right? It appears to have something set to 4000, but what? and where?

Re: Slideshow speed

Posted: Thu Feb 01, 2018 1:58 pm
by rebeccag
In V3 to change swiper speed
Transition time ( time it takes to slide to next slide)
in /catalog/view/javascript/jquery/swiper/js
change speed on line 30 (in ms)

Delay time ( time the slide is still)
in /catalog/view/theme/default/template/extension/module/slideshow.twig
change autoplay on line 22 (in ms)

Re: Slideshow speed

Posted: Mon Feb 12, 2018 3:55 pm
by raedial
my website is raedial.ro

I change that thing in java and is work. And i modify line from twig but no modification. And on mobile, that javascript is really fast .

Re: Slideshow speed

Posted: Fri Mar 23, 2018 5:43 pm
by cmsingh9872
Working for 2.1.0.2 & similar version.

1. Find the below file
catalog/view/theme/default/template/module/slideshow.tpl

2. And Change the value of autoPlay: 6000,

Re: Slideshow speed

Posted: Tue Jun 12, 2018 6:06 pm
by open_user
Hi,

does anybody know how to change the time a slide stays on, in the home slideshow for an Opencart installation version 3.0.2.0? I have tried to change the line 22 of the file slideshow.twig in the folder catalog\view\theme\default\template\extension\module, but it doesn't do the trick. In fact, any changes done to this file is not taken into account. You can change the number of slides per view, the autoplay value... I don't know from where these values are taken in the application, but not from this file.

Any help is welcome.

Re: Slideshow speed

Posted: Wed Jun 13, 2018 1:03 am
by cyclops12
open_user wrote:
Tue Jun 12, 2018 6:06 pm
Hi,

does anybody know how to change the time a slide stays on, in the home slideshow for an Opencart installation version 3.0.2.0? I have tried to change the line 22 of the file slideshow.twig in the folder catalog\view\theme\default\template\extension\module, but it doesn't do the trick. In fact, any changes done to this file is not taken into account. You can change the number of slides per view, the autoplay value... I don't know from where these values are taken in the application, but not from this file.

Any help is welcome.
Line 22 is exactly the line to change.
Make sure you clear all caches afterwards to see changes

Re: Slideshow speed

Posted: Fri Aug 24, 2018 9:26 pm
by open_user
cyclops12 wrote:
Wed Jun 13, 2018 1:03 am
open_user wrote:
Tue Jun 12, 2018 6:06 pm
Hi,

does anybody know how to change the time a slide stays on, in the home slideshow for an Opencart installation version 3.0.2.0? I have tried to change the line 22 of the file slideshow.twig in the folder catalog\view\theme\default\template\extension\module, but it doesn't do the trick. In fact, any changes done to this file is not taken into account. You can change the number of slides per view, the autoplay value... I don't know from where these values are taken in the application, but not from this file.

Any help is welcome.
Line 22 is exactly the line to change.
Make sure you clear all caches afterwards to see changes
Hi,

No, it didn't work, even when I cleared the cache. I finally got a solution, it is not the best solution, but force brute works:

The time the slide stays on can be modified in catalog/view/javascript/jquery/swiper/js/swiper.jquery.js:
In line 614, replace the value of var autoplayDelay with 10000 (ms).
var autoplayDelay= 10000; //s.params.autoplay;

Re: Slideshow speed

Posted: Sat Sep 08, 2018 12:05 pm
by GaryJames
Thank you! Line 22 worked perfect for me in 3.0.2.0.

Re: Slideshow speed

Posted: Fri Dec 21, 2018 7:01 pm
by Ackis
Hi,

No, it didn't work, even when I cleared the cache. I finally got a solution, it is not the best solution, but force brute works:

The time the slide stays on can be modified in catalog/view/javascript/jquery/swiper/js/swiper.jquery.js:
In line 614, replace the value of var autoplayDelay with 10000 (ms).
var autoplayDelay= 10000; //s.params.autoplay;
This helped me! Thank you!! :)

(I also use Open Cart 3.0.2.0)

Re: Slideshow speed

Posted: Mon Mar 25, 2019 7:31 pm
by Pyrocrafter
I think you need to change the autoplay settings in Design>Theme Editor>Extension/module/slideshow rather than going into your server files and folders.

I set mine to autoplay 3000 and gives plenty of time for reading before zooming on to the next slide. Wish I could have a nicer transition choice between slides.