Post by vladloz » Sat Aug 29, 2020 3:03 am

I'm newbie in OpenCart.
I have installed OpenCart 3.0.3.6 on my LAMP server successfully.
But I can't run OpenCart because it write about server 500 error.
When I looked apache2 error.log, I have seen the following message:
Uncaught Error: Class 'Twig\\Loader\\ArrayLoader' not found in /var/www/html/.../system/library/template/twig.php:31
I tried to fix this error with replacing modification.xml to new modification.xml from GitHub, but no results.
Please give me a good idea to fix this error.

Newbie

Posts

Joined
Sat Aug 29, 2020 2:24 am

Post by IP_CAM » Sat Aug 29, 2020 9:07 pm

Well, you probably better use this (fixed) Version, because the Original still
seems to contain some unfixed misses, according to Github/OpenCart.
https://github.com/condor2/Opencart_3036
Ernie

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Sat Aug 29, 2020 9:25 pm

Since this week, there's a mass change involved on the master branch version where the OC Engine has been massively modified in order to use auto-loaders and different types of loads to handle the controllers by namespaces. I would not suggest to make simple replacements from the master branch into the opencart.com OC versions especially at this time.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by sw!tch » Sun Aug 30, 2020 4:08 am

vladloz wrote:
Sat Aug 29, 2020 3:03 am
I'm newbie in OpenCart.
I have installed OpenCart 3.0.3.6 on my LAMP server successfully.
But I can't run OpenCart because it write about server 500 error.
When I looked apache2 error.log, I have seen the following message:
Uncaught Error: Class 'Twig\\Loader\\ArrayLoader' not found in /var/www/html/.../system/library/template/twig.php:31
I tried to fix this error with replacing modification.xml to new modification.xml from GitHub, but no results.
Please give me a good idea to fix this error.
You downloaded the zip from the opencart website or did you clone from Github/Composer?

Backup and learn how to recover before you make any changes!
Full Stack Web Developer :: Contact via PM for custom work.


Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm
Location - USA

Post by DutchRider » Sun Nov 22, 2020 5:13 am

Getting exactly the same error message here, after trying upgrading from 3.0.2.0 to 3.0.3.6, using the .zip I picked up from the download page today. Unable to upgrade.

Newbie

Posts

Joined
Sun Oct 08, 2017 4:59 am

Post by sw!tch » Sun Nov 22, 2020 6:40 am

After the upgrade is complete backup your current storage folder (e.g follow the path to it as listed in your config.php).

Then COPY the system/storage folder in replace of that folder.

The Vendor packages have changed in 3.0.3.6.

Backup and learn how to recover before you make any changes!
Full Stack Web Developer :: Contact via PM for custom work.


Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm
Location - USA

Post by pm-netti » Tue Nov 24, 2020 10:36 pm

As of version 3.0.3.5, Twig sticks are in the storage /vendor directory. It looks like the storage directory is not recognized.

This can help:

Code: Select all

require_once(DIR_STORAGE . "vendor/autoload.php");

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by straightlight » Tue Nov 24, 2020 10:42 pm

pm-netti wrote:
Tue Nov 24, 2020 10:36 pm
As of version 3.0.3.5, Twig sticks are in the storage /vendor directory. It looks like the storage directory is not recognized.

This can help:

Code: Select all

require_once(DIR_STORAGE . "vendor/autoload.php");
This issue has been fixed on the v3.0.3.6 which contains a new version of the vendor.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by pm-netti » Wed Nov 25, 2020 3:28 am

straightlight wrote:
Tue Nov 24, 2020 10:42 pm
This issue has been fixed on the v3.0.3.6 which contains a new version of the vendor.
Description of this event: :)
Image

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by straightlight » Wed Nov 25, 2020 3:40 am

What is this non-English screenshot about?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by pm-netti » Wed Nov 25, 2020 4:07 pm

straightlight wrote:
Wed Nov 25, 2020 3:40 am
What is this non-English screenshot about?
From my computer.

Translate:
20. heinäkuuta = 20th July
24. marraskuuta = 24th November
Koko = Size

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by straightlight » Wed Nov 25, 2020 6:35 pm

pm-netti wrote:
Wed Nov 25, 2020 4:07 pm
straightlight wrote:
Wed Nov 25, 2020 3:40 am
What is this non-English screenshot about?
From my computer.

Translate:
20. heinäkuuta = 20th July
24. marraskuuta = 24th November
Koko = Size
v3.0.3.6 uses a new vendor's package as opposed to previous releases which is why the date may differ.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: masteryoda and 36 guests