Post by PatrickG » Tue Apr 16, 2019 4:37 am

I have been setting up a new site at https://personalised-occasions.co.uk. Everything seemed to working fine until I upgraded from 3.0.3.1 to 3.0.3.2 - after this, when I tried to register a new customer I got this:

Fatal error: Uncaught Exception: Error: E-Mail from required! in /home/beerinab/public_html/shop/system/library/mail.php:123 Stack trace: #0 /home/beerinab/public_html/shop/catalog/controller/mail/register.php(44): Mail->send() #1 /home/beerinab/ocartdata/storage/modification/system/engine/action.php(79): ControllerMailRegister->index('account/custome...', Array, 15) #2 /home/beerinab/public_html/shop/system/engine/event.php(62): Action->execute(Object(Registry), Array) #3 /home/beerinab/ocartdata/storage/modification/system/engine/loader.php(255): Event->trigger('model/account/c...', Array) #4 /home/beerinab/public_html/shop/system/engine/proxy.php(47): Loader->{closure}(Array, Array) #5 /home/beerinab/public_html/shop/catalog/controller/account/register.php(22): Proxy->__call('addCustomer', Array) #6 /home/beerinab/ocartdata/storage/modification/system/engine/action.php(79): ControllerAccountRegister->index() #7 /home/beerinab/public_html/shop/catalog/controller/startup/router.php(25): Action->execute(Object(Registry)) in /home/beerinab/public_html/shop/system/library/mail.php on line 123

I have rolled back to 3.0.3.1 but the problem remains.

I have 2 mods installed:
Export/Import Tool (V3.20) for OpenCart 3.x
Text Limit For Product Option Text-Textarea

Personalised Gift Shop


New member

Posts

Joined
Wed Mar 18, 2015 10:32 pm


Post by D3MO » Tue Apr 16, 2019 4:52 am

Have you cleared all cashed files under modification and dashboard? once restored files? because if you get the same error that means 3.0.3.2 files loading (from moved storage folder) or vqcashe if vqmod installed

Opencart Expert | voldemaras@gmail.com
Skype - programanija | Gtalk - voldemaras@gmail.com
Extensions for Opencart @ https://www.opencartextensions.eu / or Opencart Marketplace

Need Custom Module? debug third party module or simply have any question related to Opencart? feel free to contact directly for a live chat session:) - INSTANT LIVE CHAT


User avatar
Active Member

Posts

Joined
Mon Apr 04, 2011 6:57 am

Post by straightlight » Tue Apr 16, 2019 5:08 am

Fatal error: Uncaught Exception: Error: E-Mail from required! in
The parameter in setFrom of the register.php from the controller/mail folder may contain an invalid value in order to be sent. Ensure the email being sent from is properly configured from your admin - > systems - > settings - > mail.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by thekrotek » Tue Apr 16, 2019 6:39 am

Seriously? Does anybody use search these days? Absolutely the same question was asked on this forum YESTERDAY!

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by straightlight » Tue Apr 16, 2019 7:51 am

thekrotek wrote:
Tue Apr 16, 2019 6:39 am
Seriously? Does anybody use search these days? Absolutely the same question was asked on this forum YESTERDAY!
It's not because they don't use the search, it's rather because they are unaware of its existence as the same type of ignorance when the libraries were popular back in the days. Which is why, those places were always empty and they still are empty today unfortunately.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by thekrotek » Tue Apr 16, 2019 2:04 pm

straightlight wrote:
Tue Apr 16, 2019 7:51 am
It's not because they don't use the search, it's rather because they are unaware of its existence as the same type of ignorance when the libraries were popular back in the days. Which is why, those places were always empty and they still are empty today unfortunately.
Search functionality nowadays exists on EVERY forum or social network. It's nothing, but laziness: post a question, get a quick reply, leave. I manage community for over 15 years, I saw with my own eyes how things evolved. Very sad.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by PatrickG » Tue Apr 16, 2019 2:14 pm

thekrotek wrote:
Tue Apr 16, 2019 6:39 am
Seriously? Does anybody use search these days? Absolutely the same question was asked on this forum YESTERDAY!
I did use search, but when I entered 'Fatal error: Uncaught Exception: Error: E-Mail from required!' It unhelpfully returned:

'You specified too many words to search for. Please do not enter more than 5 words.'

On other occasions when I try search it tells me the words I have used are 'too common', when I can get it to give me any results, similar problems have been caused at other locations within Opencart rather than my own specific problem, or the suggested solution did not work. I'm afraid you are not being very helpful, as I found out when I contacted you about one of your own extensions which I was using, in fact your replies were bordering on sarcastic. You have to remember that many people on here might be new to this, and if you do not have the patience and understanding to be tolerant then perhaps you are not in the right place?
Last edited by PatrickG on Tue Apr 16, 2019 2:19 pm, edited 1 time in total.

Personalised Gift Shop


New member

Posts

Joined
Wed Mar 18, 2015 10:32 pm


Post by PatrickG » Tue Apr 16, 2019 2:15 pm

D3MO wrote:
Tue Apr 16, 2019 4:52 am
Have you cleared all cashed files under modification and dashboard? once restored files? because if you get the same error that means 3.0.3.2 files loading (from moved storage folder) or vqcashe if vqmod installed
Thanks for the suggestion, but yes, this was the first thing I did.

Personalised Gift Shop


New member

Posts

Joined
Wed Mar 18, 2015 10:32 pm


Post by PatrickG » Tue Apr 16, 2019 2:17 pm

straightlight wrote:
Tue Apr 16, 2019 5:08 am
Fatal error: Uncaught Exception: Error: E-Mail from required! in
The parameter in setFrom of the register.php from the controller/mail folder may contain an invalid value in order to be sent. Ensure the email being sent from is properly configured from your admin - > systems - > settings - > mail.
The settings in admin are as they should be. When the site was first set up I checked to make sure that messsags were received from 'contact', customer registering etc, and there were no problems, and nothing has been changed there.

Personalised Gift Shop


New member

Posts

Joined
Wed Mar 18, 2015 10:32 pm


Post by thekrotek » Tue Apr 16, 2019 3:00 pm

PatrickG wrote:
Tue Apr 16, 2019 2:14 pm
I did use search, but when I entered 'Fatal error: Uncaught Exception: Error: E-Mail from required!' It unhelpfully returned:
'You specified too many words to search for. Please do not enter more than 5 words.'
Really? And you didn't even try to decrease the number of words and search by part of the string? These are the basics of ANY search procedure.

Why it gives me a bunch of results, when I enter "E-Mail from required", huh? I'm sorry, but you really should learn how to use search and don't lecture others instead. You may be new to OpenCart, but you obviously not new to internet.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by thekrotek » Tue Apr 16, 2019 3:01 pm

PatrickG wrote:
Tue Apr 16, 2019 2:17 pm
The settings in admin are as they should be. When the site was first set up I checked to make sure that messsags were received from 'contact', customer registering etc, and there were no problems, and nothing has been changed there.
Use the search string I gave you above and get the solution instead of posting replies here and complaining on how others not helpful. Gosh!

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by paulfeakins » Tue Apr 16, 2019 5:24 pm

thekrotek wrote:
Tue Apr 16, 2019 6:39 am
Seriously? Does anybody use search these days? Absolutely the same question was asked on this forum YESTERDAY!
Please provide link.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 8 guests