Post by s3eed » Sun Mar 24, 2019 12:41 am

hi
when go to catalog then press product this error apper

Warning: Missing argument 2 for Template::__construct(), called in /home/retalcenter/public_html/admin/controller/extension/product_extra.php on line 1212 and defined in /home/retalcenter/storage1/modification/system/library/template.php on line 24

line 1212
$template = new Template('template');
so line 24 it is
$file = DIR_TEMPLATE . $template . '.tpl';

how resolver this problem

New member

Posts

Joined
Thu Apr 19, 2018 5:21 pm

Post by ocmta » Sun Mar 24, 2019 4:48 am

admin/controller/extension/product_extra.php belongs to some extension that you have, it's not openCart's core file. You should ask for support from that extension's developers.

Extensions for affiliates (openCart 1, 2, 3):
Advanced Multi Level Affiliate System
Customer and Affiliate Accounts Combined into one Account
Affiliate Tracking with Coupons
Discount for Referred Customers - Order Total
Type Tracking Code
Mass Pay
Affiliate Transactions for openCart 3
Affiliate Pack X - all modules with 40% discount


Active Member

Posts

Joined
Mon Mar 12, 2012 11:21 am


Post by s3eed » Sun Mar 24, 2019 6:55 pm

how know any extension for this error ??

New member

Posts

Joined
Thu Apr 19, 2018 5:21 pm

Post by xxvirusxx » Sun Mar 24, 2019 7:24 pm

You don't know what extension you have installed?

Possbile this??
https://www.opencart.com/index.php?rout ... n_id=36261

My Extensions | OC 3.0.3.1, 3.0.2.0, 2.3.0.2 with bugs fixed | 2.3.0.2 Custom version | Buy me a beer or coffee


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by s3eed » Mon Mar 25, 2019 2:33 pm

I don't install this extension

New member

Posts

Joined
Thu Apr 19, 2018 5:21 pm

Post by xxvirusxx » Mon Mar 25, 2019 3:52 pm

Maybe is another.....we can't tell you.

Check on Extensions-->Modules, or ocmod, or vqmod.

My Extensions | OC 3.0.3.1, 3.0.2.0, 2.3.0.2 with bugs fixed | 2.3.0.2 Custom version | Buy me a beer or coffee


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by s3eed » Thu Mar 28, 2019 2:28 am

yes you are right that is extension deleted form installing but in modification not deleted so I deledt it form modification and refresh error are resolved
but error http 500 when add pruducts and click save then it saved and show error http 500 in page
I need help me for this error http 500



thanks

New member

Posts

Joined
Thu Apr 19, 2018 5:21 pm
Who is online

Users browsing this forum: No registered users and 7 guests