Post by markus22mb » Thu May 09, 2019 9:20 pm

That mean if journal is installed paypal checkout still doesnt work? Please correct me if im wrong. Thank you!

Newbie

Posts

Joined
Wed Dec 30, 2015 6:17 am

Post by straightlight » Thu May 09, 2019 9:24 pm

markus22mb wrote:
Thu May 09, 2019 9:20 pm
That mean if journal is installed paypal checkout still doesnt work? Please correct me if im wrong. Thank you!
Nowhere to be said. However, you can try the suggested tweak from the mentioned post on my previous reply.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by JNeuhoff » Thu May 09, 2019 11:57 pm

markus22mb wrote:
Thu May 09, 2019 9:20 pm
That mean if journal is installed paypal checkout still doesnt work? Please correct me if im wrong. Thank you!
Please be aware that, if you use Journal2, it can break multiple 3rd party extensions, because Journal2 is not implemented by OpenCart standards.
The best thing to do is to try out this modified PayPal Express, and then take it from there. Most OpenCart extensions are tested for standard OpenCart releases only. If an extension clashes with Journal2 then you may have to get in touch with the Journal2 authors on this.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by straightlight » Fri May 10, 2019 5:28 am

From now on, the ZIP package will now be available on my GitHub namespace. The first post contains the link. If you have any issues that specifically can be reproduced from the core and NOT from an extension, such as Journal, please post the issues on the issues tab on GitHub where I provided the link from the first post.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cebl » Sun May 12, 2019 11:24 am

Hi Straightlight,

You have done a lot of great work on the Paypal issues from my reading on the forums this morning. I just wondered if these changes were part of the current release of Opencart and if not will your changes be in the next version.

I'm not worried about making the changes you discuss more worried if there will be another issue later when I install opencart updates. I keep to the latest version all the time.

I just want to make sure I'm making minimal changes and keeping track of them all.

Cheers

Newbie

Posts

Joined
Wed Jun 27, 2018 11:11 am

Post by straightlight » Sun May 12, 2019 8:26 pm

I just want to make sure I'm making minimal changes and keeping track of them all.
Keeping track of them all is unlikely possible. Otherwise, there would be of no utility on releasing updates. Daniel confirmed last month that PayPal will be updated to ease cURL reliability. However, my updated files for PP Express Checkout will remain on my namespace for the next OC release knowing what needs to be merged and if needed once the time will come.

However, it is safe to replace the files, by following the instructions on the first post, as per the previous posts on the topic.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Tue Jun 11, 2019 11:53 pm

The Business Account has been tested during a custom job today as I can confirm it is properly pulling the results from the AddressVerify method. However, users encountering PayPal Token error messages are due to either invalid API credentials, API Signature / Other (API Signature available only by default with OC) or restricted countries with selected currencies . Since the bolded statement is about a political restriction, however, this is restricted by PayPal and has nothing to do with the extension itself and cannot be prevented when that happens politically.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Wed Jun 12, 2019 9:42 pm

I have just received words that the country with currency code error can be resolved by converting the currency to its default setting; also by using this extension for those who have to deal with this: https://www.opencart.com/index.php?rout ... n_id=30174 .

For those considering the use of PayPal Standard rather than PayPal Express Checkout, ensure to add the IPN URL to your merchant's account to capture PayPal's activities during each checkout in case future troubleshooting might be required.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Thu Jun 13, 2019 9:09 am

After further and successful testing with the SDK, it would seem the checkout.js from paypalobjects.com is encountering major problems during checkout when creating the EC tokens despite if it originates from my modifications or from the core. I will see what I can do to integrate an alternate solution so that, in the future, troubleshooting could remain minimal with change requests.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Thu Jun 13, 2019 10:25 am

Before I proceed to the new integration, I have modified the catalog/controller/extension/payment/pp_express.php file. To those interested to test this regarding the PayPal token error message to see if that solves this particular issue, see on the first post to access my Github namespace and to download that file. As usual, not to forget to follow the FAQ from the forum rules to clear out your cache.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Thu Jun 13, 2019 10:15 pm

Final notes resolution until PayPal releases a new API version: https://github.com/opencart/opencart/is ... -501719697 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Wed Jun 19, 2019 2:40 am

The PP Express files have been updated as they will also be compatible with the Master Branch of Opencart from now on.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by MasterCATZ » Fri Jun 21, 2019 7:49 am

using
https://github.com/straightlight/openca ... xpress.php
with opencart Version 3.0.3.2

Parse error: syntax error, unexpected '' . $this->config->get('' (T_CONSTANT_ENCAPSED_STRING), expecting ',' or ')' in /var/www/html/admin/controller/extension/payment/pp_express.php on line 29

Newbie

Posts

Joined
Mon May 13, 2019 4:58 pm

Post by straightlight » Fri Jun 21, 2019 9:26 am

MasterCATZ wrote:
Fri Jun 21, 2019 7:49 am
using
https://github.com/straightlight/openca ... xpress.php
with opencart Version 3.0.3.2

Parse error: syntax error, unexpected '' . $this->config->get('' (T_CONSTANT_ENCAPSED_STRING), expecting ',' or ')' in /var/www/html/admin/controller/extension/payment/pp_express.php on line 29
Confirmed. Issue fixed on my namespace. Thanks.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ThuNderGr » Thu Jul 11, 2019 12:59 am

straightlight wrote:
Fri Jun 21, 2019 9:26 am
MasterCATZ wrote:
Fri Jun 21, 2019 7:49 am
using
https://github.com/straightlight/openca ... xpress.php
with opencart Version 3.0.3.2

Parse error: syntax error, unexpected '' . $this->config->get('' (T_CONSTANT_ENCAPSED_STRING), expecting ',' or ')' in /var/www/html/admin/controller/extension/payment/pp_express.php on line 29
Confirmed. Issue fixed on my namespace. Thanks.
This issue still isn't fixed in your repo. Are you sure you commited the fix?

Εστιατορια Αθηνα http://www.athensmenu.gr


Newbie

Posts

Joined
Fri Feb 03, 2012 5:08 pm

Post by straightlight » Thu Jul 11, 2019 1:23 am

That's because there's no language defined for extension type pages in the core. Fixed line 29. Should be good now.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ThuNderGr » Thu Jul 11, 2019 1:49 am

straightlight wrote:
Thu Jul 11, 2019 1:23 am
That's because there's no language defined for extension type pages in the core. Fixed line 29. Should be good now.
yes... but still...

Parse error: syntax error, unexpected ''&language='' (T_CONSTANT_ENCAPSED_STRING), expecting ')' in /home/velvet1/public_html/catalog/controller/extension/payment/pp_express.php on line 667

Εστιατορια Αθηνα http://www.athensmenu.gr


Newbie

Posts

Joined
Fri Feb 03, 2012 5:08 pm

Post by straightlight » Thu Jul 11, 2019 9:31 am

Fixed. Thanks. Missing a dot before the '&language string.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ThuNderGr » Thu Jul 11, 2019 2:53 pm

straightlight wrote:
Thu Jul 11, 2019 9:31 am
Fixed. Thanks. Missing a dot before the '&language string.
Hope i am not being a pain in the ass.. but logged in users get this notice

Notice: Undefined index: ip in /home/velvet1/public_html/system/library/cart/cart.php on line 265

Also a Fatal error on that ip column does not exist when trying to add to card

Εστιατορια Αθηνα http://www.athensmenu.gr


Newbie

Posts

Joined
Fri Feb 03, 2012 5:08 pm

Post by straightlight » Thu Jul 11, 2019 5:44 pm

You did not followed the instructions from the first post. It is instructed to replace all PP express files while you downloaded the entire package and uploaded all files from my namespace and was not what's been said.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 2 guests