Page 1 of 4

3.0.3.x Issues and Bugs

Posted: Mon Jan 07, 2019 5:14 pm
by OSWorX
Summary for the 3.0.3.x release

Please use this thread for all issues related to the 3.0.3.x release.

First of all, if you think that you have found a bug, please check before posting here the issue tracker at GitHub (maybe a report exist already): OpenCart Guthub Issues
Second, when you post, write always the exact OpenCart Version you are using (e.g. 3.0.3.0 or 3.0.3.1) - that makes a bug difference.
Third, do not forget to write if any additional extensions are used, modifications made and which template.

Re: 3.0.3.x Issues and Bugs

Posted: Mon Jan 07, 2019 11:04 pm
by ADD Creative
From the comments on https://github.com/opencart/opencart/issues/7130 It seems that 3.0.3.x will still have most of the bugs that 3.0.2.0 had. Although there are some worthwhile fixes included.

Re: 3.0.3.x Issues and Bugs

Posted: Wed Jan 09, 2019 11:57 pm
by Johnathan
Some of us vastly prefer how vQmod works. My extensions use ocMod, but for my own installations I still use vQmod, it's way easier to use.

Re: 3.0.3.x Issues and Bugs

Posted: Thu Jan 10, 2019 12:38 am
by kestas
Johnathan wrote:
Wed Jan 09, 2019 11:57 pm
Some of us vastly prefer how vQmod works. My extensions use ocMod, but for my own installations I still use vQmod, it's way easier to use.
yes more easier... I agree.

Re: 3.0.3.x Issues and Bugs

Posted: Thu Jan 10, 2019 10:27 am
by trueliar
we use intensively vqmod since it's faster for the development. OCmode (no offense) is a boring headache for several reason (A big waste of time during development)

3.0.3.1 Error related to Google Shopping Advertising module when copying product

Posted: Thu Jan 10, 2019 2:37 pm
by glolar
Hello all,

I don't know if this bug has been fixed after 3.0.3.1 (I didn't see it mentioned anywhere in the forum), so I am posting about it here. Curious to know if anyone else can replicate this error. It doesn't occur in 3.0.2.0.

Go to Catalog > Products, then select a product (checkbox), then click the Copy button at the upper right of the page. I get the following error:

"Fatal error: Uncaught Exception: Error: Duplicate entry '0' for key 'PRIMARY'<br />Error No: 1062<br />INSERT INTO `oc_product_advertise_google` (`product_id`, `store_id`, `google_product_category`) SELECT p.product_id, p2s.store_id, (SELECT c2gpc.google_product_category FROM `oc_product_to_category` p2c LEFT JOIN `oc_category_path` cp ON (p2c.category_id = cp.category_id) LEFT JOIN `oc_category_to_google_product_category` c2gpc ON (c2gpc.category_id = cp.path_id AND c2gpc.store_id = 0) WHERE p2c.product_id = p.product_id AND c2gpc.google_product_category IS NOT NULL ORDER BY cp.level DESC LIMIT 0,1) as `google_product_category` FROM `oc_product` p LEFT JOIN `oc_product_to_store` p2s ON (p2s.product_id = p.product_id AND p2s.store_id = 0) LEFT JOIN `oc_product_advertise_google` pag ON (pag.product_id = p.product_id AND pag.store_id=p2s.store_id) WHERE pag.product_id IS NULL AND p2s.store_id IS NOT NULL AND p.product_id IN (63) in /home/glolarco/public_html/artstore/system/library/db/mysqli.php:40 Stack trace: #0 /home/glo in /home/glolarco/public_html/artstore/system/library/db/mysqli.php on line 40"

The rest of the page is white screen. If you click your browser's Back button, then refresh your browser, you will see that the selected product actually did get copied (thankfully), and you can proceed normally from there (edit the new product, then save it, etc.).

It sure looks like, from the error message anyway, that the issue has something to do with the new Google Shopping module added in 3.0.3.x

By the way, I have not enabled the Google Shopping module (under Advertising), so not sure why I would even get this error.

Curious to know if anyone else is having this issue.

Regards!

Re: 3.0.3.x Issues and Bugs

Posted: Thu Jan 10, 2019 7:01 pm
by ADD Creative

Re: 3.0.3.1 Error related to Google Shopping Advertising module when copying product

Posted: Thu Jan 10, 2019 8:34 pm
by OSWorX
glolar wrote:
Thu Jan 10, 2019 2:37 pm
Hello all,

I don't know if this bug has been fixed after 3.0.3.1 (I didn't see it mentioned anywhere in the forum), so I am posting about it here. Curious to know if anyone else can replicate this error. It doesn't occur in 3.0.2.0.
Bug already reported, see: https://github.com/opencart/opencart/issues/7133

Re: 3.0.3.x Issues and Bugs

Posted: Thu Jan 10, 2019 8:36 pm
by OSWorX
Sad to say, but as it seems, OpenCart 3.0.3.1 should not be used for production mode.
Because of a few bugs introduced (beside that, a few old bugs are not already solved).
Hopefully a new release with fixes will be released soon!

Re: 3.0.3.x Issues and Bugs

Posted: Fri Jan 11, 2019 9:38 am
by delalibera
In Opencart 3.0 in Extensions a text is appearing "coming soon!"

According to the image.

Re: 3.0.3.x Issues and Bugs

Posted: Sun Jan 13, 2019 12:31 am
by JNeuhoff
OSWorX wrote:
Wed Jan 09, 2019 4:09 pm
since 2.x some similiar like VQMod is already included in the core: OCMod

So there is really no need to install an additoinal tool which does primary the same!
And if an extension relies on VQMod only, forget is.
There are many reasons why extensions still use VQmod.
Anyway, our Integrated VQMod works just fine for OpenCart 3.0.3.x, in case anybody still needs to use VQmod.
In general I'd say at some stage 3rd party extension developers should seriously think about rewriting their extensions with the goal of getting away from XML-based modification systems like OCmod or VQmod. It's much better to use event handlers where possible for modifying the OpenCart core.

Re: 3.0.3.x Issues and Bugs

Posted: Sat Feb 16, 2019 10:05 pm
by paulfeakins
Johnathan wrote:
Wed Jan 09, 2019 11:57 pm
Some of us vastly prefer how vQmod works, so getting it fixed would be nice. My extensions use ocMod, but for my own installations I still use vQmod, it's way easier to use.
We also find vQmod fast and easy.

Re: 3.0.3.x Issues and Bugs

Posted: Sat Feb 16, 2019 10:24 pm
by straightlight
The OC v3.0.3.1 ain't helping much to see past reported issues being fixed unfortunately. Even the startup folder from the catalog-end is a total mess. I have mostly finished reporting the actual issues found on GitHub for this version. I must add that this is a total disappointment. Granted, OC v3.0.2.0 did had its flaws as also for previous versions. At least, the startup folder was still running without issues (or very lease).

The OC v3.0.3.1 will not be accredited on my behalf until all the latest reported issues will be resolved. Lots of roads to cross from the team to code like that.

This version can probably be used for decoration purposes and, even there, it becomes at the point on knowing ... 'what can be decorated' on a website if the startup folder itself won't even let you without fully troubleshooting the issues. Better to simply leave it aside on this one.

Re: 3.0.3.x Issues and Bugs

Posted: Mon Feb 18, 2019 5:44 pm
by JNeuhoff
@Straightlight: What issues are there with the startup folder? Rather than flooding github with all sorts of 'issues' you should only report genuine bugs there!

Re: 3.0.3.x Issues and Bugs

Posted: Mon Feb 18, 2019 9:44 pm
by straightlight
They are genuine. All the addressed issues on this past week do need to be changed.

Re: 3.0.3.x Issues and Bugs

Posted: Sun Mar 03, 2019 5:14 pm
by xxvirusxx
And that people who upload opencart package on website should delete 3.0.3.1, or to change Release notes from 3.0.3.1:

Code: Select all

Updated version number from 3.0.3.1_rc to 3.0.3.1
to

Code: Select all

This version is more unstable than 3.0.2.0
But nobody give a shit about users opinions.

Re: 3.0.3.x Issues and Bugs

Posted: Sun Mar 03, 2019 8:39 pm
by straightlight
It's a sleepy hollow team. Just yesterday. I spent about two hours on posting on-going bug reports on the forum for OC v3.0.3.1 and minimal bug found on GitHub which I also addressed. The question is not about the opinion of the users; it is rather considering how can the noticeable variables be more fixed on GitHub itself than the so called stable releases while countless on-going issues were addressed prior on those (un)stable releases and that includes declaring configuration keys in the platform that don't even exist in the first place? !

Re: 3.0.3.x Issues and Bugs

Posted: Sun Mar 03, 2019 11:37 pm
by IP_CAM
Well, better don't blame OC for not fixing misses, after telling the folks, to
move up, whenever another 'latest' Version arrives at the Scene. It's only
an endless game this way, but only based on Dev's Comments, not by OC.

So, better don't complain about it, but stop, to tell new or existing Users,
that older OC Versions are only full of misses, and should be replaced.
I never understud this strange behaviour, but I am not a DEV, waiting to
create additional income, one possible reason, that it keeps on this way.

Nasty Ernie

Re: 3.0.3.x Issues and Bugs

Posted: Mon Mar 04, 2019 12:03 am
by xxvirusxx
For me is much better 2.3.0.2 with SEO code from 3.0.2.0 than 3.0.2.0, 30.3.1 and not all time what is new is good.

Re: 3.0.3.x Issues and Bugs

Posted: Mon Mar 04, 2019 12:45 am
by straightlight
IP_CAM wrote:
Sun Mar 03, 2019 11:37 pm
Well, better don't blame OC for not fixing misses, after telling the folks, to
move up, whenever another 'latest' Version arrives at the Scene. It's only
an endless game this way, but only based on Dev's Comments, not by OC.

So, better don't complain about it, but stop, to tell new or existing Users,
that older OC Versions are only full of misses, and should be replaced.
I never understud this strange behaviour, but I am not a DEV, waiting to
create additional income, one possible reason, that it keeps on this way.

Nasty Ernie
Tell that to the people who wants to make the difference by fixing the most of encountered issues in the past and then realizes that despite if the version is new or old - both ways ends up with the same problems due to unpatched variables noticing what they'll tell you afterwards. I think I've been long enough on the forum to realize what stalls and what moves ahead. As you said, you're not a DEV so you may not expect how frustrating for people that are DEVs whether it comes from the OC forum or on GitHub to resolve those on-going issues. Don't blame OC you say? Tell me otherwise after each (un)stable distributions who else do the integration and puts them on Opencart.com indicating that it's stable and ending up on the same level as last time on previous features and aside from the new features added in after waiting a year an a half having to spend several hours to track in the issues because you know that no one else will report them before you do most of the time.

Glady to say, however, some of the bugfixes were already found on GitHub and from this topic which brought my previous conclusion regarding on v3.0.3.1 that this very was barely useable (testing purposes?). With that being said, that makes me the right to complain about it since DEVs should not have to spend so much time on fixing bugs that a team should already handle. Granted, we can't expect to have 100% of the bugs to be fixed. However, after the team took 1.5 years to publish a new version on Opencart.com, they certainly don't meet the demands from their users aside from the new features.