Page 1 of 1

Marketplace not showing any extensions

Posted: Wed Oct 11, 2017 9:20 pm
by TBFdirect
Installed fresh copy of 3.0.2.0
marketplace looks like the attached, nothing showing. i've entered api details and this makes no difference.
Is this the same for everyone? it it not launched yet or something?

Re: Marketplace not showing any extensions

Posted: Tue Nov 14, 2017 5:20 am
by straightlight
This issue has been addressed before as it seem to be an issue which the Opencart team are currently looking into. As soon as a definite fix will be provided and visible, an accurate solution will be provided. Thank you for your patience.

Re: Marketplace not showing any extensions

Posted: Fri Dec 01, 2017 1:23 am
by FXGuy
Same issue...

Extension Marketplace -> enter API credentials -> No results!

Re: Marketplace not showing any extensions

Posted: Thu Jan 18, 2018 1:31 pm
by jeffm2000
I also am not seeing any Extensions in the Marketplace. I tried to reinstall 3.0.2.0 (twice) the same issue. I went back and also tried version 3.0.1.1 and this version did the same thing.

Wouldn't a clean install have been one of the most basic tests after a new build. Was this ever tested??? ??? ??? ???

It is great to say wait and be patient for the team to fix this, but It looks like the problem has been there for more than 6 months. What do you want us to do wait another 6 months? We cannot install a payment gateway to make the store even usable. No new user who downloads this product can use it. Do you understand. :( :( :( :( :( :( :( :( :( :( :( :( :(

Good luck people I hope this product works for you.

Re: Marketplace not showing any extensions

Posted: Thu Jan 18, 2018 5:30 pm
by AlexChanHK
I afraid it is the hosting setting issue,
as the system is used curl to get the extension message from Opencart.com's API,
therefore no result mostly due to hosting blocked the to get information from other website.
Please double confirm with the hosting that you are using.

Re: Marketplace not showing any extensions

Posted: Thu Mar 08, 2018 11:21 pm
by ocmod.com.br
Automatic fixer Installer
fix_marketplace_not_showing_any_extensions.3.0.x.ocmod.zip

Manual fixer
In:
admin/controller/marketplace/marketplace.php

Find two occurrences:
curl_setopt($curl, CURLOPT_POST, 1);

Change for:
curl_setopt($curl, CURLOPT_POST, 0);

Re: Marketplace not showing any extensions

Posted: Mon May 28, 2018 11:25 pm
by ian_jia
Excellent! Manual fixer was perfect.
Now I can see the result in the marketing place.
But it shows nothing when I click on of the extensions:

"Page Not Found!
The page you are looking for could not be found! Please contact your administrator if the problem persists."

ocmod.com.br wrote:
Thu Mar 08, 2018 11:21 pm
Automatic fixer Installer
fix_marketplace_not_showing_any_extensions.3.0.x.ocmod.zip

Manual fixer
In:
admin/controller/marketplace/marketplace.php

Find two occurrences:
curl_setopt($curl, CURLOPT_POST, 1);

Change for:
curl_setopt($curl, CURLOPT_POST, 0);

Re: Marketplace not showing any extensions

Posted: Tue May 29, 2018 2:54 am
by straightlight
See the error logs regarding the page not found error page you are getting after applying those modifications above.