Post by bradnickel » Sat Sep 30, 2017 11:48 am

I've setup all the seller settings for Amazon Payments per the instructions provided by Amazon. When I get to the step to install Login with and Pay with Amazon modules, I am able to install Login with, but when I install Pay With, I get the error below. After that, the modules both show up as installed, but when I try to enable, neither will enable after I save. I've tried uninstalling them both and then resintalling and I get the same error on install and I have the same problem with enabling the modules.

Neither module is available in Layouts in columns either.

Fatal error: Uncaught Exception: Error: Could not load model marketplace/event! in /home/clickbr3/public_html/mark5strategies.com/oc/system/engine/loader.php:89 Stack trace: #0 /home/clickbr3/public_html/mark5strategies.com/oc/admin/controller/extension/module/amazon_pay.php(100): Loader->model('marketplace/eve...') #1 /home/clickbr3/public_html/mark5strategies.com/oc/system/engine/action.php(79): ControllerExtensionModuleAmazonPay->install(Array) #2 /home/clickbr3/public_html/mark5strategies.com/oc/system/engine/loader.php(48): Action->execute(Object(Registry), Array) #3 /home/clickbr3/public_html/mark5strategies.com/oc/admin/controller/extension/extension/module.php(31): Loader->controller('extension/modul...') #4 /home/clickbr3/public_html/mark5strategies.com/oc/system/engine/action.php(79): ControllerExtensionExtensionModule->install() #5 /home/clickbr3/public_html/mark5strategies.com/oc/admin/controller/startup/router.php(26): Action->execute(Object(Registry), Array) #6 /home/clickbr3/public_html/mark5strategies.com/ in /home/clickbr3/public_html/mark5strategies.com/oc/system/engine/loader.php on line 89

Newbie

Posts

Joined
Sat Sep 30, 2017 11:21 am

Post by straightlight » Sun Oct 01, 2017 1:01 am

Steps removed.
Last edited by straightlight on Thu Oct 05, 2017 6:11 pm, edited 1 time in total.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Sun Oct 01, 2017 1:06 am

Double posted ...
Last edited by straightlight on Tue Oct 03, 2017 7:06 am, edited 1 time in total.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by bradnickel » Tue Oct 03, 2017 6:40 am

Thank you so much for your help on this. I will give it a try.

Newbie

Posts

Joined
Sat Sep 30, 2017 11:21 am

Post by straightlight » Thu Oct 05, 2017 6:12 pm

The steps have been removed since these fixes won't work.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by LaZa1403 » Tue Jan 23, 2018 12:00 pm

Good morning!

I got the same error messages in my log files and it was not possible to install the payment modul.
Has anyone an idea what to do or found a possibility how to solve the problem?

Thanks and best regards,
LaZa

Newbie

Posts

Joined
Tue Jan 23, 2018 11:56 am

Post by ckeilitz » Fri Feb 02, 2018 11:48 am

Same problem here, throws error and won't enable. Fatal error: Uncaught Exception: Error: Could not load model marketplace/event! in /home/xa5/public_html/store/vqmod/vqcache/vq2-_home_xa5_ocartdata_storage_modification_system_engine_loader.php:89

Newbie

Posts

Joined
Thu Jan 25, 2018 2:21 am

Post by straightlight » Sat Feb 03, 2018 11:49 pm

Caused by an installed extension. Using Textcrawler, find:

Code: Select all

$this->load->model('marketplace/event');
replace all with:

Code: Select all

$this->load->model('setting/event');
This used to be an error found in the core as well in the past. Although, this issue has already been reported.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 8 guests