Post by OSWorX » Mon Jan 07, 2019 5:14 pm

Summary for the 3.0.3.x release

Please use this thread for all issues related to the 3.0.3.x release.

First of all, if you think that you have found a bug, please check before posting here the issue tracker at GitHub (maybe a report exist already): OpenCart Guthub Issues
Second, when you post, write always the exact OpenCart Version you are using (e.g. 3.0.3.0 or 3.0.3.1) - that makes a bug difference.
Third, do not forget to write if any additional extensions are used, modifications made and which template.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by ADD Creative » Mon Jan 07, 2019 11:04 pm

From the comments on https://github.com/opencart/opencart/issues/7130 It seems that 3.0.3.x will still have most of the bugs that 3.0.2.0 had. Although there are some worthwhile fixes included.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by OSWorX » Wed Jan 09, 2019 4:09 pm

As reported here, VQMod does not work with the latest version: viewtopic.php?f=10&p=743780#p743780
Beside this: since 2.x some similiar like VQMod is already included in the core: OCMod

So there is really no need to install an additoinal tool which does primary the same!
And if an extension relies on VQMod only, forget is.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Johnathan » Wed Jan 09, 2019 11:57 pm

Some of us vastly prefer how vQmod works, so getting it fixed would be nice. My extensions use ocMod, but for my own installations I still use vQmod, it's way easier to use.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by kestas » Thu Jan 10, 2019 12:38 am

Johnathan wrote:
Wed Jan 09, 2019 11:57 pm
Some of us vastly prefer how vQmod works, so getting it fixed would be nice. My extensions use ocMod, but for my own installations I still use vQmod, it's way easier to use.
yes more easier... I agree.

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by trueliar » Thu Jan 10, 2019 10:27 am

we use intensively vqmod since it's faster for the development. OCmode (no offense) is a boring headache for several reason (A big waste of time during development)

New member

Posts

Joined
Sat Jan 11, 2014 12:09 am

Post by glolar » Thu Jan 10, 2019 2:37 pm

Hello all,

I don't know if this bug has been fixed after 3.0.3.1 (I didn't see it mentioned anywhere in the forum), so I am posting about it here. Curious to know if anyone else can replicate this error. It doesn't occur in 3.0.2.0.

Go to Catalog > Products, then select a product (checkbox), then click the Copy button at the upper right of the page. I get the following error:

"Fatal error: Uncaught Exception: Error: Duplicate entry '0' for key 'PRIMARY'<br />Error No: 1062<br />INSERT INTO `oc_product_advertise_google` (`product_id`, `store_id`, `google_product_category`) SELECT p.product_id, p2s.store_id, (SELECT c2gpc.google_product_category FROM `oc_product_to_category` p2c LEFT JOIN `oc_category_path` cp ON (p2c.category_id = cp.category_id) LEFT JOIN `oc_category_to_google_product_category` c2gpc ON (c2gpc.category_id = cp.path_id AND c2gpc.store_id = 0) WHERE p2c.product_id = p.product_id AND c2gpc.google_product_category IS NOT NULL ORDER BY cp.level DESC LIMIT 0,1) as `google_product_category` FROM `oc_product` p LEFT JOIN `oc_product_to_store` p2s ON (p2s.product_id = p.product_id AND p2s.store_id = 0) LEFT JOIN `oc_product_advertise_google` pag ON (pag.product_id = p.product_id AND pag.store_id=p2s.store_id) WHERE pag.product_id IS NULL AND p2s.store_id IS NOT NULL AND p.product_id IN (63) in /home/glolarco/public_html/artstore/system/library/db/mysqli.php:40 Stack trace: #0 /home/glo in /home/glolarco/public_html/artstore/system/library/db/mysqli.php on line 40"

The rest of the page is white screen. If you click your browser's Back button, then refresh your browser, you will see that the selected product actually did get copied (thankfully), and you can proceed normally from there (edit the new product, then save it, etc.).

It sure looks like, from the error message anyway, that the issue has something to do with the new Google Shopping module added in 3.0.3.x

By the way, I have not enabled the Google Shopping module (under Advertising), so not sure why I would even get this error.

Curious to know if anyone else is having this issue.

Regards!

User avatar
Active Member

Posts

Joined
Thu Jul 29, 2010 12:35 pm
Location - San Diego, CA

Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by OSWorX » Thu Jan 10, 2019 8:34 pm

glolar wrote:
Thu Jan 10, 2019 2:37 pm
Hello all,

I don't know if this bug has been fixed after 3.0.3.1 (I didn't see it mentioned anywhere in the forum), so I am posting about it here. Curious to know if anyone else can replicate this error. It doesn't occur in 3.0.2.0.
Bug already reported, see: https://github.com/opencart/opencart/issues/7133

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by OSWorX » Thu Jan 10, 2019 8:36 pm

Sad to say, but as it seems, OpenCart 3.0.3.1 should not be used for production mode.
Because of a few bugs introduced (beside that, a few old bugs are not already solved).
Hopefully a new release with fixes will be released soon!

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by delalibera » Fri Jan 11, 2019 9:38 am

In Opencart 3.0 in Extensions a text is appearing "coming soon!"

According to the image.

Attachments

download.png

download.png (127.96 KiB) Viewed 2320 times


Newbie

Posts

Joined
Tue Feb 07, 2017 12:35 am

Post by JNeuhoff » Sun Jan 13, 2019 12:31 am

OSWorX wrote:
Wed Jan 09, 2019 4:09 pm
As reported here, VQMod does not work with the latest version: viewtopic.php?f=10&p=743780#p743780
Beside this: since 2.x some similiar like VQMod is already included in the core: OCMod

So there is really no need to install an additoinal tool which does primary the same!
And if an extension relies on VQMod only, forget is.
There are many reasons why extensions still use VQmod.
Anyway, our Integrated VQMod works just fine for OpenCart 3.0.3.x, in case anybody still needs to use VQmod.
In general I'd say at some stage 3rd party extension developers should seriously think about rewriting their extensions with the goal of getting away from XML-based modification systems like OCmod or VQmod. It's much better to use event handlers where possible for modifying the OpenCart core.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by paulfeakins » Sat Feb 16, 2019 10:05 pm

Johnathan wrote:
Wed Jan 09, 2019 11:57 pm
Some of us vastly prefer how vQmod works, so getting it fixed would be nice. My extensions use ocMod, but for my own installations I still use vQmod, it's way easier to use.
We also find vQmod fast and easy.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by straightlight » Sat Feb 16, 2019 10:24 pm

The OC v3.0.3.1 ain't helping much to see past reported issues being fixed unfortunately. Even the startup folder from the catalog-end is a total mess. I have mostly finished reporting the actual issues found on GitHub for this version. I must add that this is a total disappointment. Granted, OC v3.0.2.0 did had its flaws as also for previous versions. At least, the startup folder was still running without issues (or very lease).

The OC v3.0.3.1 will not be accredited on my behalf until all the latest reported issues will be resolved. Lots of roads to cross from the team to code like that.

This version can probably be used for decoration purposes and, even there, it becomes at the point on knowing ... 'what can be decorated' on a website if the startup folder itself won't even let you without fully troubleshooting the issues. Better to simply leave it aside on this one.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by JNeuhoff » Mon Feb 18, 2019 5:44 pm

@Straightlight: What issues are there with the startup folder? Rather than flooding github with all sorts of 'issues' you should only report genuine bugs there!

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by straightlight » Mon Feb 18, 2019 9:44 pm

They are genuine. All the addressed issues on this past week do need to be changed.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by xxvirusxx » Sun Mar 03, 2019 5:14 pm

And that people who upload opencart package on website should delete 3.0.3.1, or to change Release notes from 3.0.3.1:

Code: Select all

Updated version number from 3.0.3.1_rc to 3.0.3.1
to

Code: Select all

This version is more unstable than 3.0.2.0
But nobody give a shit about users opinions.

My Extensions


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by straightlight » Sun Mar 03, 2019 8:39 pm

It's a sleepy hollow team. Just yesterday. I spent about two hours on posting on-going bug reports on the forum for OC v3.0.3.1 and minimal bug found on GitHub which I also addressed. The question is not about the opinion of the users; it is rather considering how can the noticeable variables be more fixed on GitHub itself than the so called stable releases while countless on-going issues were addressed prior on those (un)stable releases and that includes declaring configuration keys in the platform that don't even exist in the first place? !

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Sun Mar 03, 2019 11:37 pm

Well, better don't blame OC for not fixing misses, after telling the folks, to
move up, whenever another 'latest' Version arrives at the Scene. It's only
an endless game this way, but only based on Dev's Comments, not by OC.

So, better don't complain about it, but stop, to tell new or existing Users,
that older OC Versions are only full of misses, and should be replaced.
I never understud this strange behaviour, but I am not a DEV, waiting to
create additional income, one possible reason, that it keeps on this way.

Nasty Ernie

For Sale: Turnkey URLs with Opencart installed!
Ernie's present Opencart Testsite: http://www.velomech.ch
Attacker IP Blocks are denied from further access to my Sites!
Just contact me for more Information at: jti@jacob.ch
665 FREE OC Extension-Repositories - from OC v.1.5.x up
on the largest Opencart-Mod Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by xxvirusxx » Mon Mar 04, 2019 12:03 am

For me is much better 2.3.0.2 with SEO code from 3.0.2.0 than 3.0.2.0, 30.3.1 and not all time what is new is good.

My Extensions


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Who is online

Users browsing this forum: No registered users and 7 guests