Post by karapuz » Thu Aug 09, 2018 10:28 am

I just encountered a "major" issue with OC3. When a user made some changes to a template with the theme editor, the extension-modified version of the file is completely ignored by Opencart. Why?! I think ocmod changes have to be applied after the file is tweaked by the administrator.

Is there any known solution for this problem?

User avatar
Newbie

Posts

Joined
Tue Jul 17, 2012 4:59 am


Post by JNeuhoff » Thu Aug 09, 2018 5:45 pm

It's a known issue, you shouldn't use the template editor. If the template changes are part of your web theme, copy the twig file into your theme directory and then modify it there as needed.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Google Tag Manager * Google Rich Snippets * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Johnathan » Thu Aug 09, 2018 10:37 pm

Yeah, it's basically an oversight in OpenCart 3.0 up to this point. Hopefully this is fixed in OpenCart 3.1, I haven't checked the alpha yet.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by JNeuhoff » Thu Aug 16, 2018 3:59 am

It's not fixed in OC 3.1.0.0a1, in fact the theme editor now only works when theme caching is turned on. This is getting more messy.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Google Tag Manager * Google Rich Snippets * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 2 guests