Page 1 of 1

Product tags not working [SOLVED]

Posted: Thu Mar 07, 2013 3:48 am
by vapestore
I've been tagging my products and they show up OK at the bottom of the page.

The issue I have though is that when I click on one tag (and I have several products with the same tag) I get a message that says "There is no product that matches the search criteria."

Any idea how to fix this?

Re: Product tags not working [SOLVED]

Posted: Fri Mar 08, 2013 9:54 pm
by vapestore
I've been investigating on my side too and the very kind module developer Deadcow pointed me in the right direction to fix the issue that --according to the guy who developed my theme (yes, I've also bothered him)-- is an OC bug.

Anyhow...Deadcow wrote me this:
Yeah the theme has wrong URLs, check this one, it's working ... ter_tag=fv

(The one on your site is ... rch&tag=fv)

You need to edit the theme.
SO...I've navigated to public_html/catalog/controller/product.php and found this piece of code that in my case was at line 449 and added filter_ just before the tag on the bottom line.
Now it's all working GREAT.

Thanks to Mat (Deadcow) for helping me figuring it out!!

Code: Select all

$this->data['tags'] = array();
			if ($product_info['tag']) {		
				$tags = explode(',', $product_info['tag']);
				foreach ($tags as $tag) {
					$this->data['tags'][] = array(
						'tag'  => trim($tag),
						'href' => $this->url->link('product/search', 'filter_tag=' . trim($tag))