Post by jadeye » Sun Feb 17, 2013 4:23 am

Hello every1.

I have 2 languages on my shop.

Hebrew is defined as default.

On first upload of the website (clear cache) it start off with Hebrew all right.

English is the second language and is clickable.

But after you switch to ENG U can not change back.

Can anyone point me to the bug that is making this problem???

Thank you all.

Juda.
O0


Check out my site:
http://www.gushpetshop.com

Imagehttp://nwg.co.il/
“Compassion is the basis of morality.”
― Arthur Schopenhauer


New member

Posts

Joined
Sun Jul 15, 2012 12:35 am

Post by Avvici » Tue Feb 19, 2013 12:36 am

Your problem is not a programming issue it's a style issue. You have a z-index malformation that is covering up the click-able area where the two language flags are.

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by jadeye » Tue Feb 19, 2013 4:46 am

Thank you avvici O0

Happy Purim :joker:

So if my css is:
#language {
position: absolute;
top: 45px;
left: 335px;
width: 75px;
color: #999;
line-height: 17px;
}

I tried adding:
z-index: 1;

And it worked.

Any suggestions??

JadeYe

Imagehttp://nwg.co.il/
“Compassion is the basis of morality.”
― Arthur Schopenhauer


New member

Posts

Joined
Sun Jul 15, 2012 12:35 am

Post by Avvici » Tue Feb 19, 2013 7:04 pm

You said it worked, but you want suggestion?

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by jadeye » Wed Feb 20, 2013 6:52 pm

Yes I do.

It works but as far as z-index goes I thought you might have something to say.

Thank you anyways :)

Imagehttp://nwg.co.il/
“Compassion is the basis of morality.”
― Arthur Schopenhauer


New member

Posts

Joined
Sun Jul 15, 2012 12:35 am
Who is online

Users browsing this forum: No registered users and 82 guests