Post by imadam » Wed Jan 13, 2010 10:52 am

i'm using opencart (just trying 1.4 now from 1.3x) and seo urls don't work and never have. i renamed htaccess and changed settings in admin panel. i have checked and i think mod rewrite is installed. what am i doing wrong?

my opencart carpet cleaning woking guildford and Office Cleaning Services in Guildford


Active Member

Posts

Joined
Sun Jan 10, 2010 10:47 pm
Location - Surrey

Post by dangkhoaweb » Wed Jan 13, 2010 11:37 am

imadam wrote:i think mod rewrite is installed
Be SURE not think man

Newbie

Posts

Joined
Wed Jan 13, 2010 11:34 am

Post by imadam » Wed Jan 13, 2010 8:58 pm

i did the below test, came back as though it's ok. not much else i can think to do as i didn't write xampp myself so can only think it's installed and enabled :(

http://www.webune.com/forums/how-to-tes ... d-t40.html

my opencart carpet cleaning woking guildford and Office Cleaning Services in Guildford


Active Member

Posts

Joined
Sun Jan 10, 2010 10:47 pm
Location - Surrey

Post by dannowatts » Fri Jan 15, 2010 11:47 am

imadam wrote:i'm using opencart (just trying 1.4 now from 1.3x) and seo urls don't work and never have. i renamed htaccess and changed settings in admin panel. i have checked and i think mod rewrite is installed. what am i doing wrong?
what happens when you visit the site, when the SEO doesn't work?


rocksteady,
danno~

New member

Posts

Joined
Tue Nov 10, 2009 11:40 am

Post by imadam » Tue Jan 19, 2010 7:37 am

dannowatts wrote: what happens when you visit the site, when the SEO doesn't work?

rocksteady,
danno~
i get an "object not found" page.

my opencart carpet cleaning woking guildford and Office Cleaning Services in Guildford


Active Member

Posts

Joined
Sun Jan 10, 2010 10:47 pm
Location - Surrey

Post by dannowatts » Tue Jan 19, 2010 9:24 am

post up a screenshot.

rocksteady,
danno~

New member

Posts

Joined
Tue Nov 10, 2009 11:40 am

Active Member

Posts

Joined
Sun Jan 10, 2010 10:47 pm
Location - Surrey

Post by OSWorX » Wed Jan 20, 2010 12:23 am

Disable this line in the .htaccess:

Code: Select all

#RewriteBase /
Then it should work (assuming that you have already filled your SEO keywords ;) )

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by zergussino » Thu May 13, 2010 8:04 am

+ one more thing

I was absent-minded enough to spend ~5 mins struggling to fix broken SEO URLs before noticed that .htaccess file is named .htaccess.txt
Don't break your head on the same wall, hehe.

Newbie

Posts

Joined
Wed May 12, 2010 3:56 pm

Post by kevin85 » Wed Jun 16, 2010 11:30 pm

it also happened to our site,i tried to change the seo url and got always an error message: object not found. but you are right zergussino, always check the extension name before you do a lot of debugging. :D
______________
search engine optimization | web solutions

Newbie

Posts

Joined
Wed Jun 16, 2010 11:29 pm

Post by juliarobert » Tue Dec 14, 2010 7:34 pm

May be problem with the site link of your website. Check it on your website. You can also check it from webmaster if have. Broken links of your website will be shown here.

Thanks.

Office Cleaning


Newbie

Posts

Joined
Tue Dec 14, 2010 7:26 pm

Post by jty » Wed Dec 15, 2010 12:34 am

juliarobert wrote:May be problem with the site link of your website.
No, the problem is not the website. The problem is that Julia Robert(s) is spamming her cleaning site.
Tut Tut, Julia. Give up cleaning & spamming and go back to acting

jty
Active Member

Posts

Joined
Sat Aug 30, 2008 8:19 am

Post by peal » Thu Dec 16, 2010 3:22 pm

I have to say that is certainly an utter disappointment to not just you but many of us because such an established organization such as the SEO (Search Engine Optimization) really needs an edge in breaking out and working in open cart which I am afraid they still have not sorted it out yet. I do, however hope that someday I will get to work the SEO URL’s in my Open cart with some kind of a tweak or with a geek!

automating processes


Newbie

Posts

Joined
Thu Dec 16, 2010 3:19 pm

Post by scanreg » Thu Jan 13, 2011 3:13 am

OSWorX wrote:Disable this line in the .htaccess:

Code: Select all

#RewriteBase /
Then it should work (assuming that you have already filled your SEO keywords ;) )
Nice, this worked for me, thanks :)

Active Member

Posts

Joined
Thu May 06, 2010 12:15 am

Post by tinkeringmonkey » Mon Apr 25, 2011 4:27 am

Thank you SO much, scanreg. I was banging my head against the wall trying to get the SEO URls to work. I couldn't figure it out, and no one at my server could figure it out either. Funny how the most frustrating problems have the simplest answer. ;D

store: http://www.tinkeringmonkey.com


Posts

Joined
Mon Apr 25, 2011 4:23 am

Post by hram908 » Sun Jan 27, 2013 3:58 am

#uncomment from httpd.conf below and rename .htaccess.txt to .htaccess

Code: Select all

LoadModule rewrite_module modules/mod_rewrite.so 

Newbie

Posts

Joined
Tue Dec 25, 2012 4:43 am
Who is online

Users browsing this forum: Bing [Bot] and 15 guests