Post by benstokes » Thu Dec 17, 2009 3:09 am

Hi

I have been troling the OpenCart forums for around 2 days now, I downloaded v 1.3.4 insalled everthing A ok.

The problem I am having is configuring SEO url's. My Apache server is enabled to take htaccess instructions.

The code I have in the htaccess file is as follows:

Code: Select all

php_flag register_globals off

php_flag magic_quotes_gpc off

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

RewriteEngine On
RewriteBase / 
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]



# Please ensure register_globals is Off by uncommenting this line
#php_flag register_globals Off

# URL Alias - see install.txt

Options +FollowSymlinks

<IfModule mod_rewrite.c>
RewriteEngine On

# Put your installation directory here:
# If your URL is www.example.com/shop/, use /shop/
# If your URL is www.example.com/, use /
RewriteBase /


#OPENCART REWRITES START
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php
#OPENCART REWRITES END

</IfModule>
I would very much appreciate any help that you can give me.

Thank you

Ben ^-^

Newbie

Posts

Joined
Thu Dec 17, 2009 2:56 am

Post by Xsecrets » Thu Dec 17, 2009 4:10 am

did you turn seo urls on in the admin config? also did you actually set seo keywords for your categories and products?
Are you getting some sort of error?

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by benstokes » Thu Dec 17, 2009 4:26 am

Hi

I have answered your questions

did you turn seo urls on in the admin config? Yes

also did you actually set seo keywords for your categories and products? Yes

Are you getting some sort of error? i'm getting a page not found error

When I set it to SEO URL's the seo url's showed when I ran the mouse over them in the shop, but as soon as I click on the item it goes to a error page - page not found.

Thanks

Newbie

Posts

Joined
Thu Dec 17, 2009 2:56 am

Post by Xsecrets » Thu Dec 17, 2009 6:10 am

if your shop is in a subfolder you will need to change the following line from your .htaccess

Code: Select all

RewriteBase /
to something like

Code: Select all

RewriteBase /store/
and just for grins you have renamed it from .htaccess.txt to .htaccess correct?

Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by benstokes » Thu Dec 17, 2009 7:36 am

Hi

I put all the files from the download into a file called index.php

I have just tried what you recommended but no change.

Thank you

Newbie

Posts

Joined
Thu Dec 17, 2009 2:56 am

Post by Xsecrets » Thu Dec 17, 2009 9:27 am

benstokes wrote:Hi

I put all the files from the download into a file called index.php
???

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by web2works » Thu Dec 17, 2009 8:55 pm

In my .htaccess file I have:

Code: Select all

Options +FollowSymlinks

RewriteEngine On
RewriteBase /cms1/ 
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]
I have installed opencart into a directory /cms1/ as you can see in the RewriteBase. You also need to ensure that you are entering data into the SEO Keywords under the data tab in the product admin area.

A good way to test if your SEO URL is working correctly is by viewing the example products installed with opencart try clicking on the iPod Classic (product 20) does this have the SEO URL you are looking for?

I think 'SEO Keywords' should be made a required field in the admin if you have SEO enabled at a setting.

Quality Opencart Website Design - we don't just tweak a colour or two we build a fully bespoke design for OpenCart tailored for your business and target audience.
View our latest websites at: http://www.web2works.co.uk/portfolio


User avatar
Newbie

Posts

Joined
Wed Nov 04, 2009 7:39 am

Post by benstokes » Thu Dec 17, 2009 9:12 pm

Hi

Thanks for that, I installed the Opencart on directory called index.php :)) I quite new to web design, and think I have totaly confused my server bu naming it this.

I will delete the upload and name it something new like shop maybe ;) Hopefully it will work then.

The thing that was confusing me though is everthing works just fine apart from the SEO which I did check, the links showed up as "short" url's just once you clicked a link it went to an error page - search not found kinda error.

I did do all the SEO fields that are required in the data tab - so i guess it is just down to me naming the route directory index.php.

Thanks guys for your help. . .

I will let you know if the new download - then upload works

Newbie

Posts

Joined
Thu Dec 17, 2009 2:56 am

Post by vipul_vj » Wed Jul 18, 2012 11:20 pm

Thanks mahn,

It helped a lot !! 8) ;D

Newbie

Posts

Joined
Mon Jul 02, 2012 4:44 pm
Who is online

Users browsing this forum: No registered users and 37 guests