Post by Webbo » Fri Oct 19, 2012 2:22 am

Hi
Can anyone help on this mystery?

A PayPal payment notification email come through, but no order notification email, so i logged into the admin, but no order is in the dashboard or abandoned orders or in the mySQL database

the PayPal ID is 202 and geniune

But the last order was ID 200

I made a test order to see if it goes to order 203, but it was 201

This is what I think what happened: I think the customer paid on a guest checkout and the paypal callback failed

I am assuming 'guest checkout details' don't enter into abandoned orders' and the callback didn't register the order with the opencart shop (v.1.5.1.3)

I welcome any other ideas, please ???

New member

Posts

Joined
Sun Oct 10, 2010 12:31 am

Post by postcardcollecting » Fri Oct 19, 2012 2:57 am

I am getting the same type of problem. I am getting guest checkout orders and get the paypal notification but no trace of the order showing up within the dashboard. I don't even get a notice that a sale was made as the owner. If it were not for the paypal payment, I won't know that there was even a order. On top of that, it makes it difficult to make sure, I am dealing with the correct item purchased since there's nothing to go on but paypal info in my paypal account. I am frustrated trying to figure out what's going on. Without any order info to refer back to that's not too good for business and filling the order becomes a tedious task.
The only answer, that I've come up with is to disable guest checkout .... which I hate to do since I do make valid sales with guest checkout
Can anyone help?

http://www.postcardcollecting.com
http://www.aboardnoahsark.com



Posts

Joined
Mon Aug 06, 2012 11:30 pm


Post by overtonis » Sat Oct 20, 2012 3:22 pm

postcard - I am in same situation. Its a mess. The only way we know anything has been purchased is that paypal sends us an email when payment is received. We are getting no emails from opencart after orders place and orders on dashboard has mysteriously stopped for past two days. We have done no updating to the system. Frustrating to say the least because we want to provide speedy excellent customer service.

New member

Posts

Joined
Tue Apr 24, 2012 9:07 am

Post by postcardcollecting » Fri Jan 11, 2013 9:11 am

Hi Overtonis ... Yes, the problem continues to this date ... I got another order today but only knew that I had one because I got a paypal email. I don't get any notices from my own site. I have to go to missing orders, change it to processing and then update the stock one item at a time .... Very tedious ! Today's order had 15 items purchased ... ARGHHHH !
overtonis wrote:postcard - I am in same situation. Its a mess. The only way we know anything has been purchased is that paypal sends us an email when payment is received. We are getting no emails from opencart after orders place and orders on dashboard has mysteriously stopped for past two days. We have done no updating to the system. Frustrating to say the least because we want to provide speedy excellent customer service.

http://www.postcardcollecting.com
http://www.aboardnoahsark.com



Posts

Joined
Mon Aug 06, 2012 11:30 pm


Post by Avvici » Fri Jan 11, 2013 11:14 am

Well, check your MISSING ORDERS. These have an order_staus_id of 0 which means they won't show up in the open cart order list in the admin,. You have to filter the missing. if they are missing then there was probably an issue with the paypal transaction. Or, are you certain these transactions were approved and not just pending or denied?

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by postcardcollecting » Mon Jan 14, 2013 3:46 am

Good Afternoon avvici ... I used to get the notice that I had an order and the stock would update automatically but NO LONGER ... I have some of the same customers that bought, the stock updated and the notices came to me.
If I go into my paypal account, I do see that the order was placed and paid for.
In one of the areas of the support forum someone talked about the IPN ... mine was disabled, I enabled it .....now I have to wait for an order to see if that helps. Does the IPN need to be enabled when using paypal standard?
I followed all suggestions about setting the settings to processing instead of cancelled ..
Is there any definitive help with this issue?
Thanks !
avvici wrote:Well, check your MISSING ORDERS. These have an order_staus_id of 0 which means they won't show up in the open cart order list in the admin,. You have to filter the missing. if they are missing then there was probably an issue with the paypal transaction. Or, are you certain these transactions were approved and not just pending or denied?

http://www.postcardcollecting.com
http://www.aboardnoahsark.com



Posts

Joined
Mon Aug 06, 2012 11:30 pm


Post by Avvici » Mon Jan 14, 2013 3:48 am

No, IPN is already installed. You don't need to do anything on the paypal side. Check ABANDONED orders to see if your orders are there.

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by postcardcollecting » Mon Jan 14, 2013 3:56 am

My orders show up in OpenCart under the missing orders .... The only I know I have an order is due to the email from paypal that I have a payment otherwise I wouldn't know that I do. I then go to OC, filter for missing orders, find the missing order and it then appears as an order for me and >>>>> it then shows up in the customers oder history but not until then. I then must go and update each item in stock. For me that's a huge job since most of my items for sale are unique ... the last order had 15 postcards ... imagine the work I had to do before someone else came along and bought the item that was no longer available?
When you say check abandoned orders, are you referring to paypal or OC ?
avvici wrote:No, IPN is already installed. You don't need to do anything on the paypal side. Check ABANDONED orders to see if your orders are there.

http://www.postcardcollecting.com
http://www.aboardnoahsark.com



Posts

Joined
Mon Aug 06, 2012 11:30 pm


Post by Avvici » Wed Jan 16, 2013 11:32 am

postcardcollecting wrote:My orders show up in OpenCart under the missing orders .... The only I know I have an order is due to the email from paypal that I have a payment otherwise I wouldn't know that I do. I then go to OC, filter for missing orders, find the missing order and it then appears as an order for me and >>>>> it then shows up in the customers oder history but not until then. I then must go and update each item in stock. For me that's a huge job since most of my items for sale are unique ... the last order had 15 postcards ... imagine the work I had to do before someone else came along and bought the item that was no longer available?
When you say check abandoned orders, are you referring to paypal or OC ?
avvici wrote:No, IPN is already installed. You don't need to do anything on the paypal side. Check ABANDONED orders to see if your orders are there.
You are sure that your order_status is set to Complete or Pending from the system>settings as well as the paypal settings?

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by postcardcollecting » Wed Jan 16, 2013 12:04 pm

Nice to hear from you avvici ..
Yes, I checked the settings in admin area; order_status is set to pending.
In the paypal module complete status is set to complete and pending status is set to pending.
I believe you told me also that it was not necessary to enable the IPN URL in my paypal account. Is this true?
I have never had so far any abandoned orders only missing orders.
I only know that I have an order because paypal sends me a payment notification. I do not get OC emails about an order.
I then go into change missing order to processing so that the customer can see the order in their account and then finally to shipped status the day of shipment.
I have just recently starting having this issue with the new updates.
avvici wrote:
postcardcollecting wrote:My orders show up in OpenCart under the missing orders .... The only I know I have an order is due to the email from paypal that I have a payment otherwise I wouldn't know that I do. I then go to OC, filter for missing orders, find the missing order and it then appears as an order for me and >>>>> it then shows up in the customers oder history but not until then. I then must go and update each item in stock. For me that's a huge job since most of my items for sale are unique ... the last order had 15 postcards ... imagine the work I had to do before someone else came along and bought the item that was no longer available?
When you say check abandoned orders, are you referring to paypal or OC ?
avvici wrote:No, IPN is already installed. You don't need to do anything on the paypal side. Check ABANDONED orders to see if your orders are there.
You are sure that your order_status is set to Complete or Pending from the system>settings as well as the paypal settings?

http://www.postcardcollecting.com
http://www.aboardnoahsark.com



Posts

Joined
Mon Aug 06, 2012 11:30 pm


Post by Khal » Mon Jan 28, 2013 11:44 pm

Did you manage to solve this problem? I am having exactly the same issue- I only know I have an order because I receive a paypal email. The order does not register on OC anymore.

This has just started happening today- it was working fine before and i haven't upgraded or changed anything. I didn't have an IPN set on Paypal, (but it was working before without it), but I added this and it still isnt working.

Active Member

Posts

Joined
Thu May 24, 2012 9:24 pm
Location - Teesside, UK

Post by wohrt » Tue Jan 29, 2013 1:45 am

I'm having the same issue.
Orders coming through via PayPal but, going to "Missing Orders" on the Open Cart end.

Using Version 1.4.9.4 for over a year; never had this problem. Today was the first time.
Suggestions?

Newbie

Posts

Joined
Sun May 08, 2011 11:22 pm

Post by JNeuhoff » Tue Jan 29, 2013 1:55 am

wohrt wrote:I'm having the same issue.
Orders coming through via PayPal but, going to "Missing Orders" on the Open Cart end.

Using Version 1.4.9.4 for over a year; never had this problem. Today was the first time.
Suggestions?
This was a problem with PayPal, its service was down this morning, see http://downrightnow.com/paypal .

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Khal » Tue Jan 29, 2013 2:00 am

Thank you for letting me know. I have been frantically trying to find out what's wrong! Will it resolve itself and do you know if it's working now?

https:KhaleejiAbaya.Com
OC 2.0.1.1


Active Member

Posts

Joined
Thu May 24, 2012 9:24 pm
Location - Teesside, UK

New member

Posts

Joined
Sun Jul 01, 2012 3:39 am
Who is online

Users browsing this forum: No registered users and 43 guests