Post by loop » Thu Sep 13, 2012 4:51 pm

Hey guys, anyone
have an idea why the Add to cart button is not working on HTTP just on SSL pages.
SSL is working perfectly. all pages secure except store index (on purpose)
i am not forcing ssl with .htaccess

But when i visit an http page the add to cart buttons stops working. (over https is working perfectly)
Also not working on the default theme.
so its not a theme related.
i am 100% sure the problem is coming from jquery-1.7.1.min.js
catalog/view/javascript/jquery/jquery-1.7.1.min.js

when i remove it from the header the button stops working in https too.

So how to make it work on both http and https ?

any ideas?
thanx

Newbie

Posts

Joined
Thu Sep 13, 2012 4:45 pm

Post by loop » Fri Sep 14, 2012 5:24 am

just updated jquery to 1.8 min
and again button is not working on http ... on https is all fine.. :choke:

on all browsers. ???

Newbie

Posts

Joined
Thu Sep 13, 2012 4:45 pm

Post by zuhenry » Sat Sep 15, 2012 11:25 am

Hello,

Can we have a look at your site, I have read this issue in several posts, and I noticed that those people that complained about this are still having the same issue...

Is this a bug? !!

If anybody else is having issues with the "add to cart" button in the main page of the site please let us know to be sure that we can track why and how this happens...

Thanks

zh

Our latest page: http://www.paginas.in
http://www.macClasificados.com - Encuentra tu Apple PC mas barato, sin intermediarios


Active Member

Posts

Joined
Fri Sep 09, 2011 9:54 pm
Location - Colombia

Post by loop » Sat Sep 15, 2012 10:00 pm

Hey ,
thanx for the reply.

The current site is:
http://pheromonexs.com

try it with and without the https

also its not theme related
as the same problem is also in the default theme too.

Newbie

Posts

Joined
Thu Sep 13, 2012 4:45 pm

Post by kombi » Mon Oct 29, 2012 6:37 am

I seen Add to cart button - not working on HTTP, just on SSL pages on my site as well

New member

Posts

Joined
Thu Sep 06, 2012 5:03 am

Post by philbydevil » Mon Oct 29, 2012 11:26 am

I had this problem but it seemed to just be a cache issue that fixed itself after a day or so. It happened after I moved my store from one host to another.

I heart cmd-f, cmd-c, cmd-v, cmd-z + vQmod.
My favourite page...
v1.5.4.1


User avatar
Active Member

Posts

Joined
Fri Dec 03, 2010 5:20 am

Post by Rainforest » Tue Jan 29, 2013 2:24 am

I'm Having this problem too, any ideas?

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by thedesignparlor » Tue Feb 26, 2013 3:08 am

Since I updated my OpenCart and some of its files, my Add to Cart button doesn't do anything.
I have tried all of the fixes I could find including:
  • making sure the product.tpl file said add and not update
    Making sure my config.php file has www or not (whichever I needed)
    I've been checking my theme files to the new default theme files and so far only the header file needed updating
    and I uninstalled the latest module and reinstalled it
None of these have fixed it. It was working fine earlier today, but I have had to update some files (mostly mail files) and it has stopped working. I don't think that was the problem. I'm thinking there must be some kind of bug.

At first, it would add products and just not pop up the notification to say that it had been added to my cart, but now it isn't adding anything. It seems wonky.

PLEASE HELP!!!!


Posts

Joined
Sat Nov 17, 2012 11:58 pm

Post by Drachyr » Sat Aug 29, 2015 4:44 am

and so it continues... couple of years down the line, and I'm having troubles with my add to cart button too.

To be honest, I'm a little out of my league here, but if anyone's willing and able to help I'd appreciate it so much!

it seems not to work on any of the product pages: novastormdesigns.co.uk

Newbie

Posts

Joined
Sat Aug 29, 2015 4:17 am
Who is online

Users browsing this forum: No registered users and 18 guests