Post by crashby » Tue Sep 11, 2012 8:41 pm

On a website for a client, there is an issue which occurs occasionally that is very concerning and causing them all sorts of accounting and sales problems.

Basically, the customer has a couple of items in their basket, but after check out, although the full order is recorded by Opencart, Paypal shows one of the items missing in its item list (including the corresponding postage prices and VAT for the lower order total).

So basically Opencart shows e.g.

Item 1 - £30
Item 2 - £30
Total £60
Postage £10
VAT £14
Payment total £84

Whereas on Paypal the transaction is showing
Item 1 - £30
Total £30
Postage £5
VAT £7
Payment Total $42

This only happens very rarely, most checkouts go through properly. It has happened with Paypal Standard and Paypall Express (with the purchased add on).

The delivery module is a custom one that I have written that calculates postage based on the value of the total order.

Any help with this would be really appreciated. I can neither recreate it nor see any pattern, other than both orders only had 2 items exactly.

Thanks
Chris

Newbie

Posts

Joined
Mon Jun 20, 2011 6:37 pm

Post by crashby » Wed Sep 12, 2012 9:41 pm

I've managed to reproduce this now. Basically when the user logs in items from a previous cart are added into the shopping basket (this is not very desirable, customers hate it) and then the Paypall Express checkout only passes the newly added items, despite the basket containing items from a previous checkout and despite Opencart order confirmation showing the whole order.

Newbie

Posts

Joined
Mon Jun 20, 2011 6:37 pm

Post by fcwhte625 » Wed Apr 11, 2018 11:02 am

Hi

Would you like to elaborate more on your issue?

You were saying that the cart is containing items from previous checkout?
Means the cart was not cleared completely previous?

Newbie

Posts

Joined
Wed Apr 11, 2018 11:00 am

Post by mihaavgustin » Mon Apr 20, 2020 4:38 pm

Hi,

I have run in the same issue, have you found any working solution?

Newbie

Posts

Joined
Tue Sep 06, 2016 8:31 am


Post by straightlight » Mon Apr 20, 2020 7:47 pm

mihaavgustin wrote:
Mon Apr 20, 2020 4:38 pm
Hi,

I have run in the same issue, have you found any working solution?
Then, you are both not elaborating the reported issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 40 guests