Post by tolinho » Thu May 23, 2013 9:49 pm

After many e-mails to paypal, AT&T and my hosting provider I still have this problem.
Paypal always pointed fingers to AT&T.
My hosting provider always daid, no IPs were blocked.
Today I sent an email to AT&T and in less than 2 hours they replyed back.
The anwser was that they were not blocking any IP.

So what the hell...
I decided to try blueandbell's solution
blueandbell wrote:I finally solved this problem on my install of 1.5.4 tonight following these instructions. If anyone else is still struggling maybe worth a look....

https://sites.google.com/a/kevronent.co ... l-standard
I set up all the changes exept Payment Data Tranfer (PDT) = On (copy Identity Token and paste in OpenCart Paypal configuration area) because my OpenCart Standard Paypal module does not have this option.

I set the options for two different paypal account.
One for my opencart website and one for an other site that is oscommerce.

And gess what :)

Problem solved.
Both received payment, email confirmation of orders, all issues solved.

Conclusion?!
Paypal changed something for sure.
Thanks blueandbell for your post. It saved me and a friend :)

New member

Posts

Joined
Sat Jul 21, 2012 2:01 am

Post by Phone-Wear » Sat Nov 02, 2013 5:35 am

Hi
We have installed fresh open cart version 1.5.6 and have problem with sales not showing up.
Everything works perfect and I can run a sale through cash on delivery and it all works perfect.show up and is all good to go..
When I have Placed several orders through system: using PayPal and Authorize net and Orders both disappear. and Do not show up anywhere ( at least not anywhere I know to look)
I have check everything to the best of my knowledge and I am stumped.

The cart gives processed complete . cart is empty, I receive e-mail conformation from PayPal and Authorize net that We have sales $$ received.
So when I check Admin Sales, Dashboard, etc.. no sales orders to be found.
I have read over all kinds of Posts but with new version 1.5.6 not sure best way to fix.
any help to fix would be very very much appreciated..Please..
the website is www.key-toppers.com
thank you in advance!!
best!

Newbie

Posts

Joined
Wed Oct 30, 2013 5:35 am

Post by Grandstand » Sat Mar 22, 2014 12:50 am

This is actually a very easy fix. All you need to do is goto your settings of your OpenCart Authorize.net mod and enter a MD5 Hash. Copy that go to authorize.net account click on settings next to where you find get API transaction key there is a link to update MD5 Hash. Click on that; paste the MD5 hash you copied from opencart and save.

New member

Posts

Joined
Sat Aug 27, 2011 8:03 am

Post by Hussar » Tue Aug 26, 2014 4:23 am

I have the same problem.

Strange thing is that Test payments from both Paypal and Nochex are fully recorded and the order email is received.

With a Live payment (from both gateways) this is what I get:

1) Cart is emptied - proving that IPN/APC has been processed
2) Sales/orders does not show the new order
3) order_status_Id is 0 (which probably explains '2)')
4) No Order email received
5) History not updated
6) Debug shows status from Paypal as VERIFIED

So, with a Live transaction I guess there is an error somewhere between emptying the cart and the processing of email, order status and history. I've no idea in which order these things will be processed or win which one the problem lies.
If anyone has ideas that would be great.

If someone knows if it's possible to view the return message from Paypal I might be able to investigate the differences. Or if anyone knows how I can insert some debug statements into the php that would help a lott too.

Thank you.

New member

Posts

Joined
Fri Aug 22, 2014 4:51 am

Post by OCdude » Wed Dec 30, 2015 8:24 pm

Guys i found the solution for me ! it is not the server or a bug.

i noticed that the issue started because i disabled FraudLabsPro under settings - fraud.

i now enabled the fraud again and placed a test order and it works good again like before, good luck !

Newbie

Posts

Joined
Tue Apr 21, 2015 7:33 am
Who is online

Users browsing this forum: Bing [Bot], jorem and 13 guests