Post by gail315 » Sun Sep 02, 2012 8:20 am

We just installed Opencart in a directory called STORE and we're getting the WRONG paths:

EXAMPLE:
MyDomain.com/MyDomain.com/store/catalog/view/theme/4%20Favors/template/common/logo.png
see it is repeating the MyDomain.com

My ROOT config:

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http:/partysuppliesshop.com/store/');
define('HTTP_IMAGE', '/store/image/');
define('HTTP_ADMIN', 'http://partysuppliesshop.com/store/admin/');

// HTTPS
define('HTTPS_SERVER', 'http://partysuppliesshop.com/store/');
define('HTTPS_IMAGE', '/store/image/');

// DIR
define('DIR_APPLICATION', '/home/shop/public_html/store/catalog/');
define('DIR_SYSTEM', '/home/shop/public_html/store/system/');
define('DIR_DATABASE', '/home/shop/public_html/store/system/database/');
define('DIR_LANGUAGE', '/home/shop/public_html/store/catalog/language/');
define('DIR_TEMPLATE', '/home/shop/public_html/store/catalog/view/theme/');
define('DIR_CONFIG', '/home/shop/public_html/store/system/config/');
define('DIR_IMAGE', '/home/shop/public_html/store/image/');
define('DIR_CACHE', '/home/shop/public_html/store/system/cache/');
define('DIR_DOWNLOAD', '/home/shop/public_html/store/download/');
define('DIR_LOGS', '/home/shop/public_html/store/system/logs/');


?>
And here is the htaccess

Code: Select all

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 

RewriteBase /store/
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
How do we fix this?

New member

Posts

Joined
Wed Apr 25, 2012 8:25 am

Post by uksitebuilder » Thu Sep 06, 2012 6:09 pm

HTTP_IMAGe and HTTPS_IMAGE both need to have the full URL to the image folder

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by gail315 » Thu Sep 06, 2012 10:35 pm

HTTP_IMAGe and HTTPS_IMAGE both need to have the full URL to the image folder
? Are u sure about that??? I think if you are using multi-store, u don't want to use the full path for SEO to have each store appear to have the images coming from that store.

New member

Posts

Joined
Wed Apr 25, 2012 8:25 am

Post by uksitebuilder » Thu Sep 06, 2012 11:17 pm

PLease try the following in the top part

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http:/partysuppliesshop.com/store/');
define('HTTP_IMAGE', $_SERVER['HTTP_HOST'].'/store/image/');
define('HTTP_ADMIN', 'http://partysuppliesshop.com/store/admin/');

// HTTPS
define('HTTPS_SERVER', 'http://partysuppliesshop.com/store/');
define('HTTPS_IMAGE', $_SERVER['HTTP_HOST'].'/store/image/');
p.s. I removed your database info from the opening post.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by gail315 » Thu Sep 06, 2012 11:21 pm

oh wow - thanks!

New member

Posts

Joined
Wed Apr 25, 2012 8:25 am
Who is online

Users browsing this forum: Bing [Bot] and 51 guests