Post by OC2PS » Sat Jan 02, 2010 6:47 am

Xsecrets wrote:what version are you running.
Not sure which version. Not sure how to check which version. I downloaded and installed in July 2009 and have been running since then. 1.2.9 or 1.3.1 is my best guess
Xsecrets wrote:If it's a new version you must not have uploaded all the files, or you deleted the files, because google sitemap and google base are supposed to be in there on the latest versions.
Maybe I can try uploading a few files? Which files do I need?

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by OC2PS » Sat Jan 02, 2010 7:47 am

Ok, do I download

Code: Select all

/admin/controller/feed/google_sitemap.php
/admin/controller/feed/google_base.php
/admin/view/template/feed/google_sitemap.tpl
/admin/view/template/feed/google_base.tpl
for v 1.3.4

and uploaded to my (a few months) older Opencard installation.

When I not go to Admin > Extenstions > Product Feeds, I see 2 idential entries "Product feeds"
Seems one of them is Google base and the other is Google Sitemaps.

I clicked on Install for each, and both seemed to install without trouble; the status for both is Disabled.

When I click on Edit for either, to Enable them, I get the following error message:

Code: Select all

Error: Could not load language data from feed/google_sitemap!

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Qphoria » Sat Jan 02, 2010 8:13 am

you cant mix files from the newer versions with older versions. You will just have to upgrade first or start fresh

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by OC2PS » Sat Jan 02, 2010 8:20 am

Qphoria wrote:you cant mix files from the newer versions with older versions. You will just have to upgrade first or start fresh
Any way I can lay my hands on the older version's files?

Any way to find out which version I am using?

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by OC2PS » Sat Jan 02, 2010 8:58 am

Found 1.3.1 at

Code: Select all

http://www.opencart.com/forum/viewtopic.php?f=2&t=5613&start=0
Turns out it doesnt have the google sitemap files. Doesn't have any of the above 4 files. Only the following exists

Code: Select all

/admin/controller/feed/googlebase.php_
and it is 0 B

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by OC2PS » Sat Jan 02, 2010 9:43 am

Where in the database is the status of modules saved?
Esp. w.r.t. feeds extensions...

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Qphoria » Sat Jan 02, 2010 2:41 pm

setting table

cart_status
bestseller_status
usps_status
etc

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by OC2PS » Sat Jan 02, 2010 8:49 pm

Thanks Qphoria.

Ok, I made it work. I think (still not sure) that I am using 1.2.9

I uploaded the following pages from 1.3.4 into my older installation:

Code: Select all

/admin/controller/feed/google_sitemap.php
/admin/view/template/feed/google_sitemap.tpl
/admin/language/english/feed/google_sitemap.php
/admin/language/hungarian/feed/google_sitemap.php
(Hungarian language pack is for a very old version - I had to edit it even to make it work with even 1.2.9...so I just copied the google_sitemap.php from EN to HU folder - I use admin in EN anyway)

Next, I had to create a record in table "setting" in the database:
settings_id: selected an arbitrary number
group: feeds
key: google_sitemap_status
value: 1

Last step:
copied global function

Code: Select all

getProducts()
from

Code: Select all

/shop/catalog/model/catalog/product.php
in 1.3.4 to my 1.2.9 file

and voila index.php?route=feed/google_sitemap outputs an XML sitemap. Have submitted in Google webmaster tools Sitemaps, and it has accepted it...shows 414 URLs submitted, though hasn't indexed anything yet.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by OC2PS » Sat Jan 02, 2010 8:52 pm

Oops...I missed telling you about one more file that I added to my old installation from 1.3.4

Code: Select all

/catalog/controller/feed/google_sitemap.php

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Qphoria » Sun Jan 03, 2010 12:42 am

You would likely have had to edit the controller for the way it displayed the tpl as your version uses layout.tpl and the googlebase version doesn't. Unless maybe v132 had googlebase module where it would work for you without changes to the tpl stuff.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by OC2PS » Sun Jan 03, 2010 4:19 am

Hmm....you are probably right - I might have to do that if I were to try google base.

But I have only tried out google sitemap...that's all I needed at the moment. For that there wasn't any need to edit any controllers because the output is not in a template, but just an XML file....

I am not a programmer, and not techie at all, don't understand php etc....so probably won't be able to do the hacking required to use google base.

Unfortunately, I've had so many customizations in my version of opencart, that I don't really plan to upgrade....

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Qphoria » Sun Jan 03, 2010 7:05 am

so then you copied it from 1.3.2 not 1.3.4. you should be ok. The fact that you can load it in the admin is the template i'm talking about.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by OC2PS » Sun Jan 03, 2010 10:44 pm

nope. pretty sure copied from 1.3.4

cant load the pade in admin...when i click on edit google checkout in feeds in admin, i get a blank page. (which i dont care about since i am able to generate the xml sitemap)

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Qphoria » Mon Jan 04, 2010 11:06 am

that is what I was referring to.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: Baidu [Spider] and 46 guests