Post by evanluthra » Fri Jul 06, 2012 3:08 am

i have spent hours crawling the forums working to find a solution for this but i have failed miserably .

i have an OC set up at www.fashionshortlisted.com but the mail refuses to work

i tried with Godadday shared hosting settings first . lead to eroors .

then i tried with gmail apps mail by changing my mxrecords and now theses are the current settings :

http://d.pr/i/Mg7o


BUT i am still getting eroors . the mail just doesnt send itself :/ i dont know why
this is the error on the contact form :http://fashionshortlisted.com/index.php ... on/contact

Code: Select all

Warning: fsockopen() [function.fsockopen]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/content/94/7606394/html/Fshop/system/library/mail.php on line 153Warning: fsockopen() [function.fsockopen]: unable to connect to ssl://smtp.gmail.com :465 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /home/content/94/7606394/html/Fshop/system/library/mail.php on line 153Notice: Error: php_network_getaddresses: getaddrinfo failed: Name or service not known (0) in /home/content/94/7606394/html/Fshop/system/library/mail.php on line 156

i have spent so much time on this and now changing to something else from OC is just sad :(

please help me out .. i am even ready to pay some small fees to someone who gets my mails working for me .
i just use 2 address . hello@faashionshortlisted.com and contact@fashionshortlisted.com

please help me out

Newbie

Posts

Joined
Sun Jul 01, 2012 9:11 pm

Post by jarek79 » Fri Jul 06, 2012 4:55 am

Did you put letter f in front of your email address when you put it in oc???

Jerry

Amazing Gift Boxes - Is an online shop specializing in unique and exclusive hand made gift packaging. Use promo code "code10" to get 10% off and free delivery on orders over £30. | Gift Bags | Gift Boxes


User avatar
New member

Posts

Joined
Tue Jun 05, 2012 10:23 pm


Post by evanluthra » Fri Jul 06, 2012 11:04 am

Yes i did that
see : -fhello@fashionshortlisted.com

my current settings http://d.pr/i/Mg7o

Newbie

Posts

Joined
Sun Jul 01, 2012 9:11 pm

Post by evanluthra » Fri Jul 06, 2012 11:18 am

Look here for the settings that gmail advises me to use :
http://d.pr/i/w7L7

now can someone adivse me please ?
what ports should i use ?
what hosts ?
thanks .

please .

bet yet if someone can do this over teamviewr for me , i can pay you for your time .

Newbie

Posts

Joined
Sun Jul 01, 2012 9:11 pm

Post by evanluthra » Fri Jul 06, 2012 12:32 pm

When i use MAIL instead of SMTP , it shows success in the site , but i dont get any mail , neiter from contact form , neither from forget password and neither from newsletter ..

please help me .

i really need this .
isnt thier a developer i can hire who will do this for me ?
i can do it myself too -just need instreuctions

Newbie

Posts

Joined
Sun Jul 01, 2012 9:11 pm

Post by bigchili » Fri Jul 06, 2012 3:02 pm

Are you using Google Apps for your domain's e-mail?

User avatar
Active Member

Posts

Joined
Wed May 16, 2012 3:00 am


Post by evanluthra » Fri Jul 06, 2012 4:57 pm

Yes . Using google apps for my domain

Newbie

Posts

Joined
Sun Jul 01, 2012 9:11 pm

Post by bigchili » Fri Jul 06, 2012 5:17 pm

Does your SPF record look like this?

v=spf1 a include:_spf.google.com ~all

You mentioned when you used phpMail instead of SMTP you were getting a success message but the e-mails weren't being delivered, which makes me think they are being flagged as Spam and are going to your Spam box. The SPF record above should help to prevent that.

Alternatively, you might want to check with your host if they are blocking some port or don't allow phpMail. GoDaddy isn't exactly the best hosting company...

User avatar
Active Member

Posts

Joined
Wed May 16, 2012 3:00 am


Post by OSWorX » Fri Jul 06, 2012 5:32 pm

Unfortunately the mail.calss of OC is buggy since years.
Also the current version - e.g. adding to many LF where it should not.
Result is, many emails are categorized as Spam, while they are not.

Replacing the mail.class completely with another, solves this and many other problems.
Just get the replacement (use phpMailer) here (vQmod):
http://osworx.net/de/downloads/cat_view ... s/80-tools
and it should work.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by bigchili » Fri Jul 06, 2012 5:43 pm

OSWorX wrote:Unfortunately the mail.calss of OC is buggy since years.
Also the current version - e.g. adding to many LF where it should not.
Result is, many emails are categorized as Spam, while they are not.
That's interesting OSWorX, because I just had someone tell me they weren't getting new customer and new order alerts anymore as well, and I've seen a lot of posts on the forum lately of people who are having the same issues with mail not being sent.

What exactly is causing this? Could you elaborate why the mail.class is "buggy"? Just to satisfy my own curiosity.

User avatar
Active Member

Posts

Joined
Wed May 16, 2012 3:00 am


Post by OSWorX » Fri Jul 06, 2012 7:05 pm

For example, only this line:

Code: Select all

$message .= '--' . $boundary . '--' . $this->newline;
added always 2.5 points to the spam score (SpamAssassin 3.3.1).
And some more because of other reasons like wrong encoding of the subject.

Overall always between 5.6 and 6.2 (limit is set to 5.0) - therefore marked as spam.

With the replacement I have now always -1.9 - and no problems anymore.

In this forum we have and have had many discussions about the mail.class and how to solve.
Daniel tried many things the last years - but it is still buggy.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by evanluthra » Sat Jul 07, 2012 2:49 am

ok i uploaded the files for the vqmod mail thing you told but where are the settings for that ?
and how do i set it up ?

Newbie

Posts

Joined
Sun Jul 01, 2012 9:11 pm

Post by Mike_GoDaddy » Sat Jul 07, 2012 4:28 am

You will not be able to send email via Gmail's servers using Go Daddy hosting. You will have to use our relay server-- relay-hosting.secureserver.net-- on port 25 to send emails. You do not need to specify a username or password with this relay server.

Mike
Go Daddy® Hosting Ambassador


User avatar
Newbie

Posts

Joined
Sat Jul 07, 2012 4:24 am
Location - Scottsdale, AZ

Post by OSWorX » Sat Jul 07, 2012 5:38 am

evanluthra wrote:ok i uploaded the files for the vqmod mail thing you told but where are the settings for that ?
and how do i set it up ?
Settings as usual via Settings > Email (if secure ports are defined, the module will enable automatically the correct protocol SSL/TLS).

Just define there the given godaddy settings.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by evanluthra » Sat Jul 07, 2012 11:29 am

Should I ppost my google apps settings or the settings that godaddy gave me ?
I changed my mx records to google apps now - I don't knnow what they are ...but still . What seettigns to use now ?

And also do I need to fill imn the parsameters ? Like -femail@domain.com ?

Can someone please give the whole settings again ?

Should I smtp or mail ?

Newbie

Posts

Joined
Sun Jul 01, 2012 9:11 pm

Post by Mike_GoDaddy » Mon Jul 09, 2012 8:17 am

As you host on Go Daddy you cannot send via Google.

The Mail Protocol should be Mail.
The Host should be relay-hosting.secureserver.net.
The user and password should be left blank.
Port should be 25.

Mike
Go Daddy® Hosting Ambassador


User avatar
Newbie

Posts

Joined
Sat Jul 07, 2012 4:24 am
Location - Scottsdale, AZ

Post by evanluthra » Mon Jul 09, 2012 9:34 am

Thers a huge delya when I use these settings , I want a fast mail service like other hosts

Newbie

Posts

Joined
Sun Jul 01, 2012 9:11 pm

Post by OSWorX » Mon Jul 09, 2012 1:57 pm

evanluthra wrote:Thers a huge delya when I use these settings , I want a fast mail service like other hosts
Glad to see that it works now.
And for that delay, just use a better provider.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Mike_GoDaddy » Tue Jul 10, 2012 2:33 am

You can provide the headers of a delayed message to our support team and they can review to see if something is wrong or if it is just a normal delay due to a shared resource.

Mike
Go Daddy® Hosting Ambassador


User avatar
Newbie

Posts

Joined
Sat Jul 07, 2012 4:24 am
Location - Scottsdale, AZ

Post by seydelmolina » Thu Feb 07, 2013 5:40 am

Mike_GoDaddy wrote:You will not be able to send email via Gmail's servers using Go Daddy hosting. You will have to use our relay server-- relay-hosting.secureserver.net-- on port 25 to send emails. You do not need to specify a username or password with this relay server.
Holy cow!!!! THIS SOLVE MY PROBLEM

THANKS A LOT!!!!!

Newbie

Posts

Joined
Fri Dec 23, 2011 6:00 am
Who is online

Users browsing this forum: No registered users and 35 guests