Post by yubnub » Thu Jul 05, 2012 6:57 pm

Hi,

I am having an issue where site emails (order confirmation/update etc) are being flagged by gmail as spam.

I have changed the wording on the order success page to inform customers to check their spam folders but it is still causing me and my customers a fair bit of bother.

Is it is simply a case of how google views the mail that decides it is spam? and therefore are there any changes that can be made to the site or content/title of the emails to help them get through?

I have created my own gmail account to try to trouble shoot this - I have pasted below the header from the mail in case it helps.

Code: Select all

Delivered-To: venturesports2887@gmail.com
Received: by 10.64.52.101 with SMTP id s5csp130427ieo;
        Sat, 30 Jun 2012 14:34:27 -0700 (PDT)
Received: by 10.216.65.65 with SMTP id e43mr2644649wed.104.1341092067351;
        Sat, 30 Jun 2012 14:34:27 -0700 (PDT)
Return-Path: <sales@spearfishingstore.co.uk>
Received: from sharpak0.easydservers.com ([78.129.190.124])
        by mx.google.com with ESMTPS id p17si7134620wes.24.2012.06.30.14.34.26
        (version=TLSv1/SSLv3 cipher=OTHER);
        Sat, 30 Jun 2012 14:34:27 -0700 (PDT)
Received-SPF: neutral (google.com: 78.129.190.124 is neither permitted nor denied by best guess record for domain of sales@spearfishingstore.co.uk) client-ip=78.129.190.124;
Authentication-Results: mx.google.com; spf=neutral (google.com: 78.129.190.124 is neither permitted nor denied by best guess record for domain of sales@spearfishingstore.co.uk) smtp.mail=sales@spearfishingstore.co.uk
Received: from www.spearfishingstore.co.uk (unknown [78.129.190.124])
	by sharpak0.easydservers.com (Postfix) with ESMTPA id 02E842B8003
	for <venturesports2887@gmail.com>; Sat, 30 Jun 2012 22:39:33 +0100 (BST)
MIME-Version: 1.0
To: venturesports2887@gmail.com
Subject: Spearfishingstore.co.uk - Thank you for registering
Date: Sat, 30 Jun 2012 21:39:32 +0000
From: =?UTF-8?B?U3BlYXJmaXNoaW5nc3RvcmUuY28udWs=?=<sales@spearfishingstore.co.uk>
Reply-To: Spearfishingstore.co.uk<sales@spearfishingstore.co.uk>
X-Mailer: PHP/5.3.3
Content-Type: multipart/related; boundary="----=_NextPart_24faaded2d5860583d2bbec10e58e897"
Message-Id: <20120630213933.02E842B8003@sharpak0.easydservers.com>

------=_NextPart_24faaded2d5860583d2bbec10e58e897
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 8bit

Welcome and thank you for registering at Spearfishingstore.co.uk!

Your account has now been created and you can log in by using your email address and password by visiting our website or at the following URL:
https://www.spearfishingstore.co.uk/account/login

Upon logging in, you will be able to access other services including reviewing past orders, printing invoices and editing your account information.

Thanks,
Spearfishingstore.co.uk
------=_NextPart_24faaded2d5860583d2bbec10e58e897--
thanks for any help,

regards,

anthony
Last edited by yubnub on Fri Jul 06, 2012 6:21 pm, edited 1 time in total.

New member

Posts

Joined
Mon Nov 28, 2011 1:38 am

Post by Avvici » Fri Jul 06, 2012 12:19 pm

I assume you are using PHP MAIL? The reason why email typically goes to junk mail folders is because of a number of possible reasons:
-bad headers (not specified or incorrect)
-shortage of real text on the page, otherwise all images
-your own personal gmail settings (obviously this doesn't apply to your customers)

I have never had a client complain about Open Cart mail going to junk in Gmail. Is this a consistent problem for you?

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by bigchili » Fri Jul 06, 2012 2:57 pm

Are you using Google Apps for your domain's e-mail?

User avatar
Active Member

Posts

Joined
Wed May 16, 2012 3:00 am


Post by yubnub » Fri Jul 06, 2012 6:20 pm

hi,

**EDIT**

Just discovered that I do not have reverse DNS set up on the domain/IP - i think this may be the reason,

I am getting it enabled now.

When i set the site up i did request the host of my server set this up for me. It looks like they have done this for one domain, but not for this one. (i have 2 opencart sites running under 2 different ip's on the server)

As I have not had any issue yet with the other site/domain (although it only does 1/3rd of the sales) I am guessing this may be the culprit!

**end edit**

I have tried a variety of settings. I have used both the "mail" and the "smtp"setting (under system > settings) . When i tried the SMTP settings I was using my own server. I have also tried a VQ mod that placed a wrapper around the default opencart send mail function. Im not to sure about the VQ mod but thought I would give it a try!

On the whole it is a consistent problem.

With my dummy account I have the site send copies of the site notification mails to it. 75% go straight to spam, although a few do get through.

I am having customers phone/re email me via the contact form as they are not getting confirmations or status updates if I reply with any form of query,

thanks,

and best regards,

anthony

New member

Posts

Joined
Mon Nov 28, 2011 1:38 am

Post by yellow_cake » Mon Jul 30, 2012 7:21 am

bigchili wrote:Are you using Google Apps for your domain's e-mail?
Bigchili, I am using a Google Apps account for my domain email. Even messages from the contact form are going into the spam folder of my Gmail. I have set them as "NOT SPAM" in my Gmail so now it will go normally into the inbox, but I'm not sure how it will be for my customers who use Gmail...

New member

Posts

Joined
Fri Feb 03, 2012 11:28 pm

Post by Tommeke9 » Thu Aug 16, 2012 2:53 am

hello,
I'm having exactly the same problem, all of my opencart-mails are marked as spam in gmail/hotmail.
My domain-mail is configured as google apps user. I'm using opencart 1.5.3.1, and my mail-settings are the standard-settings (php-mail).
How can I solve this??
thanks!!

Newbie

Posts

Joined
Wed Aug 15, 2012 6:55 am

Post by Tommeke9 » Mon Sep 10, 2012 11:06 pm

does somebody has a solution??

Newbie

Posts

Joined
Wed Aug 15, 2012 6:55 am

Post by yubnub » Mon Sep 10, 2012 11:25 pm

ap per my edit to my original post, once the reverse DNS had been set up on the domain the emails all started to go through fine.

I guess in my case that google was flagging them as spam as they could not verify where they were coming from,

regards,

anthony

New member

Posts

Joined
Mon Nov 28, 2011 1:38 am

Post by byens » Tue Feb 10, 2015 11:29 am

Tommeke9 wrote:does somebody has a solution??
setting as mail not smtp and use mailparameter -FYourStoreName , remember not -f but it is -F

open your system/library/mail.php

find

Code: Select all

$header .= 'From: ' . '=?UTF-8?B?' . base64_encode($this->sender) . '?=' . '<' . $this->from . '>' . $this->newline;
or something similar and replace with

Code: Select all

if ($to == 'your@email.com') {  
$header .= 'From: ' . '=?UTF-8?B?' . base64_encode($this->sender) . '?=' . '<' . $this->from . '>' . $this->newline;
} else {
}
change your@email.com with your email adress
because system trying to send as your settingmail, gmail consider it as spam. Make sure Reply-To header still there. Thats what we need actually

Selling Kristik - Jasa Foto Aura - Jual Lingerie - supplier baju anak - jasa seo


Active Member

Posts

Joined
Sat Dec 11, 2010 12:29 pm
Location - Surabaya

Post by west1982 » Sat Oct 10, 2015 6:20 am

trying this !! lets see!

New member

Posts

Joined
Wed Apr 29, 2015 7:31 am

Post by neilforrester » Sat Mar 05, 2016 1:18 pm

I had the same issue and wrote an answer on my blog. This specifically addresses the issue of customer order emails being flagged as spam by gmail and how to fix it.

http://pixelfire.com.au/website-design- ... -correctly

Regards,
Neil.

Newbie

Posts

Joined
Wed Jan 27, 2016 9:49 am
Location - Geelong, Australia
Who is online

Users browsing this forum: No registered users and 51 guests