Post by criyoj » Wed Jun 27, 2012 9:41 am

Hi,

This is what I get when I try to checkout as registered user at the final step (order confirmation):

Notice: Error: Could not load model checkout/extension! in mihosting/public_html/vqmod/vqcache/vq2-system_engine_loader.php on line 51

In guest mode I don't get any error message, but it shows an iframe with the home page inside at confirmation, so strange.

The problem is not caused by any vqmod, I alredy tried.

Thank you for your help :)

Newbie

Posts

Joined
Fri Jun 22, 2012 3:07 am

Post by opcrat » Wed Jun 27, 2012 11:00 am

It looks like something wrong. Their isn't any model called checkout/extension in opencart's default files. Mention more details so that we can help.

Most Useful Extensions || Most Selling Extensions
Opencart Development || Opencart Designing || eCommerce Project

✔ Join more than 5000 Happy Opencart Store Owners enjoying the extensions designed and developed by Opcrat, Opencart Partner.


User avatar
Active Member

Posts

Joined
Wed Dec 21, 2011 6:54 am

Post by criyoj » Thu Jun 28, 2012 5:34 am

I uninstalled vqmod and now I get this message:

Notice: Error: Could not load model checkout/extension! in /public_html/system/engine/loader.php on line 48

I think that's more specific, but I still don't understand.

Newbie

Posts

Joined
Fri Jun 22, 2012 3:07 am

Post by opcrat » Thu Jun 28, 2012 9:04 am

Error trying to say that it's not able find catalog/model/checkout/extension.php. Please check it manually it is there ? By default in opencart their isn't any file called extension.php in model/checkout. I hope you understand the issue now.

Most Useful Extensions || Most Selling Extensions
Opencart Development || Opencart Designing || eCommerce Project

✔ Join more than 5000 Happy Opencart Store Owners enjoying the extensions designed and developed by Opcrat, Opencart Partner.


User avatar
Active Member

Posts

Joined
Wed Dec 21, 2011 6:54 am

Post by criyoj » Thu Jun 28, 2012 10:51 pm

It doesn't exist. And in loader.php on line 48 there is nothing that could help I think :(

Newbie

Posts

Joined
Fri Jun 22, 2012 3:07 am

Post by opcrat » Thu Jun 28, 2012 11:23 pm

You will never find anything in loader.php because that is opencart library and it is used by opencart controllers for loading models, library, helper, etc according requirements. The main issue you have to find is which one of your controller or file trying to load model checkout/extension and why?

Most Useful Extensions || Most Selling Extensions
Opencart Development || Opencart Designing || eCommerce Project

✔ Join more than 5000 Happy Opencart Store Owners enjoying the extensions designed and developed by Opcrat, Opencart Partner.


User avatar
Active Member

Posts

Joined
Wed Dec 21, 2011 6:54 am

Post by criyoj » Mon Jul 02, 2012 3:14 am

If I give you my passwords for FTP and Admin, could you check it out?

It's a big favor, I know

Newbie

Posts

Joined
Fri Jun 22, 2012 3:07 am

Post by straightlight » Mon Jul 02, 2012 4:19 am

Which OC version are you using and since this error occurs from the VQMod report, which contribution did you installed in order to obtain this error message result ? Additionally, since you uninstalled VQMod, did you also uninstalled the related contribution / extension ?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by criyoj » Mon Jul 02, 2012 8:29 am

I just installed 1.5.3.1, never updated. I don't know in what moment this started to happen, because just now I'm doing checkout tests (I haven't released the store to the public yet).

And VQmod is not the problem, because I uninstalled it and I got this different message:
Notice: Error: Could not load model checkout/extension! in /public_html/system/engine/loader.php on line 48

Some idea that how could I figure out wich extension is causing the problem? I tried uninstalling everything I've downloaded, but I still have no answers

Newbie

Posts

Joined
Fri Jun 22, 2012 3:07 am

Post by straightlight » Mon Jul 02, 2012 9:51 am

Since you don't know in what moment this error event may occur after uninstalling, the best option would be to search with textcrawler software (free) so knowing under which file the:

Code: Select all

$this->load->model('checkout/extension');
would be initiated. Originally coded from OC's core files, there are no such extension model that exists and especially not during checkout so this error message definitely has to be about an installed contribution.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by criyoj » Wed Jul 04, 2012 2:03 am

Great! I found this in 2 files:

catalog/controller/checkout/confirm.php
catalog/controller/checkout/guest_step_3.php


Should I just remove this command? Or do I need to do something else :)

Newbie

Posts

Joined
Fri Jun 22, 2012 3:07 am

Post by monavb » Mon Feb 25, 2013 7:25 pm

I got same error on confirmation step.

Anybody have any solution???

Please reply me.
Really :choke:

Newbie

Posts

Joined
Fri Feb 22, 2013 9:09 pm

Post by straightlight » Wed Feb 27, 2013 9:14 am

Depending on which OC version you might be using, you may of course comment out those two criteria rather than deleting them then test the results on the store-front end seeing if this error message would come back, initially.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 43 guests