Post by a2z » Mon Jun 25, 2012 11:16 pm

I see a lot of threads about search not being accurate in opencart for older versions. I see no threads about the version 1.5.2.1 or 1.5.3.1. Are the problem with search presenting inaccurate results resolved?

I have a store with around 2500 products and when I search with just 1 word, I get accurate results with the products containing this word in their title. But if I search with 3 words, I get all the products which contain any one of the word and there is no ranking. So if I searched for "Mens Leather Jacket", the actual item I am looking for will be somewhere in the second or third page even though I have only 2 or 3 products which match the string.

Any one has a solution for this in 1.5.3.1?

a2z
New member

Posts

Joined
Tue May 01, 2012 9:43 am

Post by tdaubs » Tue Jun 26, 2012 1:44 am

Can we get a url?

Image
Opencart Support . Opencart Galaxy . Buy Me a Coffee?


User avatar
Active Member

Posts

Joined
Fri Apr 08, 2011 4:51 am
Location - Southern California

Post by Johnathan » Tue Jun 26, 2012 6:47 am

All 1.5.1.x - 1.5.3.x searches use any of the words to return products, so it's not very accurate. It's why I wrote Smart Search.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by haowind » Sun Sep 09, 2012 3:04 pm

Smart search is not really helpful to the problem.

For example, i have product 15MM DIAMETER KEY RING, 20MM DIAMETER RING, and more similar names.
If I search 15mm ring, the search results will still show all products with 15mm or ring inside their names.

This is a big problem!!

There is a solution for 1.5.1.3 to change OR to AND, but its not work for 1.5.3.1.

http://www.haowind.com
Haowind is a professional manufacturer for plastic craftworks, piggy banks, bath ducks, mini compasses and promotional gifts.


Newbie

Posts

Joined
Sun Sep 09, 2012 2:46 pm
Location - China
Who is online

Users browsing this forum: Bing [Bot] and 12 guests