Post by xlam » Tue Jun 19, 2012 11:54 pm

hello,
i have problen with my opencart website, problem is can't login to admin website. i have upload new admin folder from opencart installation source but still same.


please help me, ASAP:(

Many thanks for your help
Last edited by florinsith on Tue Apr 02, 2013 8:53 am, edited 2 times in total.
Reason: delete sensitive data

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by florinsith » Wed Jun 20, 2012 12:20 am

What do you mean by 'cant log into admin' ? are you getting some error or you just forgot your password.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by xlam » Wed Jun 20, 2012 12:33 am

florinsith wrote:What do you mean by 'cant log into admin' ? are you getting some error or you just forgot your password.
thank you for your quick reply
i have get blank on admin login page http://fixprint.net/admin , page not found. i check in cpanel folder /admin is already, and i have new upload but still same.

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by florinsith » Wed Jun 20, 2012 2:04 am

maybe is because of some vqmod or extension you installed recently. trace everything you did before this problem occur.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by xlam » Wed Jun 20, 2012 7:04 pm

florinsith wrote:maybe is because of some vqmod or extension you installed recently. trace everything you did before this problem occur.
the last i installed seo tag module, but all files related on it i have deleted..but still same.

and i try delete vqmod folder but still same:(

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by xlam » Fri Jun 22, 2012 12:08 am

anybody help me please? i can't do anything for my web now:(

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by panyanata » Fri Jun 22, 2012 12:28 am

Fella,

It seems that:

1. your folders have not been properly uploaded to your server or are in the wrong directory. If I go to http://fixprint.net/admin there's a webpage and not the admin page.

2. I think the config.php file you posted above is your root directory config.php file. You should also check your admin/config.php file to make sure the details in it are pointing to the correct directories on your server.

Hope the above helps.

If you have moment, please check out my extensions:
Related Products: Flex
Manufacturer/Brand Module


New member

Posts

Joined
Tue May 22, 2012 9:07 pm

Post by xlam » Fri Jun 22, 2012 10:34 am

Hello Fella,
1. folder admin is already, this is my screenshoot (attach)
2. this my admin/config.php code

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://fixprint.net/admin/');
define('HTTP_CATALOG', 'http://fixprint.net/');
define('HTTP_IMAGE', 'http://fixprint.net/image/');

// HTTPS
define('HTTPS_SERVER', 'http://fixprint.net/admin/');
define('HTTPS_IMAGE', 'http://fixprint.net/image/');

// DIR
define('DIR_APPLICATION', '/home/xlam/public_html/fixprint.net/admin/');
define('DIR_SYSTEM', '/home/xlam/public_html/fixprint.net/system/');
define('DIR_DATABASE', '/home/xlam/public_html/fixprint.net/system/database/');
define('DIR_LANGUAGE', '/home/xlam/public_html/fixprint.net/admin/language/');
define('DIR_TEMPLATE', '/home/xlam/public_html/fixprint.net/admin/view/template/');
define('DIR_CONFIG', '/home/xlam/public_html/fixprint.net/system/config/');
define('DIR_IMAGE', '/home/xlam/public_html/fixprint.net/image/');
define('DIR_CACHE', '/home/xlam/public_html/fixprint.net/system/cache/');
define('DIR_DOWNLOAD', '/home/xlam/public_html/fixprint.net/download/');
define('DIR_LOGS', '/home/xlam/public_html/fixprint.net/system/logs/');
define('DIR_CATALOG', '/home/xlam/public_html/fixprint.net/catalog/');

// DB
define('DB_DRIVER', 'mysql');
define('DB_HOSTNAME', 'localhost');
define('DB_USERNAME', '#####');
define('DB_PASSWORD', '#####');
define('DB_DATABASE', '#####');
define('DB_PREFIX', '');
?>
many thanks for your help

Attachments

admin.jpg

admin.jpg (141.46 KiB) Viewed 6941 times


Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by panyanata » Fri Jun 22, 2012 11:28 am

Hello Fella,

You're welcome.

1. First things, first - if your "installx" folder is the Opencart install folder but renamed, please delete it NOW.

Upon completion of the Opencart installation the system advises you to remove it. Deleting the install folder is normal procedure for all web cart applications and is a standard security measure. You don't need the install folder after installation.

Just in case I wasn't clear - please delete it NOW. ;D

2. If the 2 config.php files you have posted above are the ones from (a) your root directory and (b) your admin/ folder, then the problem is likely to be with these.

Your 2 config.php files are the same. They shouldn't be.

If you have tested your site on a local computer or test domain, look at the two config.php files there and see where the differences are (or just update them with your real site's details). Make sure the correct config.php file is in the root directory and in the "admin" folder.

3. I cannot see from your screenshot (the bottom is cut off) whether you have the other files required in the root directory. Eg. index.php and php.ini files. Again, you can check this against your local computer or test domain installation. Make sure you have these other files in the root directory.

Let me know how it goes.

If you have moment, please check out my extensions:
Related Products: Flex
Manufacturer/Brand Module


New member

Posts

Joined
Tue May 22, 2012 9:07 pm

Post by florinsith » Fri Jun 22, 2012 3:00 pm

Try disabling the seo urls. If by renaming the .htaccess back to .htaccess.txt its not enough, I will send you instructions to disable it in db.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by xlam » Sat Jun 23, 2012 12:46 am

Hello florinsith,
i have renamed .htaccess to htaccess.txt and get error

Code: Select all

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@fixprint.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at fixprint.net Port 80

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by xlam » Sat Jun 23, 2012 12:56 am

Hello panyanata,

1. I have deleted installx folder but still error. FYI, my site has been running for six month with no problem with admin before

2. I have check config.php, and i think is different, here is the codes
admin/confin.php

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://fixprint.net/admin/');
define('HTTP_CATALOG', 'http://fixprint.net/');
define('HTTP_IMAGE', 'http://fixprint.net/image/');

// HTTPS
define('HTTPS_SERVER', 'http://fixprint.net/admin/');
define('HTTPS_IMAGE', 'http://fixprint.net/image/');

// DIR
define('DIR_APPLICATION', '/home/xlam/public_html/fixprint.net/admin/');
define('DIR_SYSTEM', '/home/xlam/public_html/fixprint.net/system/');
define('DIR_DATABASE', '/home/xlam/public_html/fixprint.net/system/database/');
define('DIR_LANGUAGE', '/home/xlam/public_html/fixprint.net/admin/language/');
define('DIR_TEMPLATE', '/home/xlam/public_html/fixprint.net/admin/view/template/');
define('DIR_CONFIG', '/home/xlam/public_html/fixprint.net/system/config/');
define('DIR_IMAGE', '/home/xlam/public_html/fixprint.net/image/');
define('DIR_CACHE', '/home/xlam/public_html/fixprint.net/system/cache/');
define('DIR_DOWNLOAD', '/home/xlam/public_html/fixprint.net/download/');
define('DIR_LOGS', '/home/xlam/public_html/fixprint.net/system/logs/');
define('DIR_CATALOG', '/home/xlam/public_html/fixprint.net/catalog/');
config.php on root

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://fixprint.net/');
define('HTTP_IMAGE', 'http://fixprint.net/image/');
define('HTTP_ADMIN', 'http://fixprint.net/admin/');

// HTTPS
define('HTTPS_SERVER', 'http://fixprint.net/');
define('HTTPS_IMAGE', 'http://fixprint.net/image/');

// DIR
define('DIR_APPLICATION', '/home/xlam/public_html/fixprint.net/catalog/');
define('DIR_SYSTEM', '/home/xlam/public_html/fixprint.net/system/');
define('DIR_DATABASE', '/home/xlam/public_html/fixprint.net/system/database/');
define('DIR_LANGUAGE', '/home/xlam/public_html/fixprint.net/catalog/language/');
define('DIR_TEMPLATE', '/home/xlam/public_html/fixprint.net/catalog/view/theme/');
define('DIR_CONFIG', '/home/xlam/public_html/fixprint.net/system/config/');
define('DIR_IMAGE', '/home/xlam/public_html/fixprint.net/image/');
define('DIR_CACHE', '/home/xlam/public_html/fixprint.net/system/cache/');
define('DIR_DOWNLOAD', '/home/xlam/public_html/fixprint.net/download/');
define('DIR_LOGS', '/home/xlam/public_html/fixprint.net/system/logs/');
3. this is screenshoot for my root folder http://www.freeimagehosting.net/yqyex

Thank you for your support

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by florinsith » Sat Jun 23, 2012 1:51 am

Ok, after you renamed the htaccess, access your store's database trough phpmyadmin, brows the setting table, find the config_seo_url row, edit it and set the value field 0.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by xlam » Sat Jun 23, 2012 8:32 pm

florinsith wrote:Ok, after you renamed the htaccess, access your store's database trough phpmyadmin, brows the setting table, find the config_seo_url row, edit it and set the value field 0.
i have been edit store database, and now my SEO has disable. i try login admin folder but same error "Internal Server Error"

thank you

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by straightlight » Sat Jun 23, 2012 9:19 pm

More information about this error may be available in the server error log.
What does it state on your server error log from your cPanel / Plesk regarding this error ?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by xlam » Sun Jun 24, 2012 12:21 am

Hello Straightlight,
You are great.....
My site is working now,
i saw error log on cpanel and this message
[Sat Jun 23 11:16:46 2012] [error] [client 180.246.251.87] File does not exist: /home/xlam/public_html/fixprint.net/500.shtml
[Sat Jun 23 11:16:46 2012] [error] [client 180.246.251.87] SoftException in Application.cpp:601: Directory "/home/xlam/public_html/fixprint.net/admin" is writeable by group
and i looking permission on folder admin is 777, i set to 755 is working well now!!
:)

many thank for all people help me..
to panyanata, florinsith, straightlight you are the best ;D

Baju Muslim Baju Pria Baju Anak Baju Korea Sparepart Printer Baju Muslim JNE Surabaya


New member

Posts

Joined
Sun Dec 25, 2011 2:58 pm

Post by panyanata » Sun Jun 24, 2012 12:22 pm

Hello Xlam,

You're welcome - we're here to help. And it's good to hear that your problem was fixed.

Just for completeness, the advice to remove the "install" folder wasn't related to fixing your problem. And it wouldn't have affected the operation of your site as such, as you said. But its removal is an important step you should take immediately after installation or an upgrade. If you'd like a fuller explanation, just do a quick search on the forum or OC site, where I'm sure the topic is covered already.

Good luck with your site!

If you have moment, please check out my extensions:
Related Products: Flex
Manufacturer/Brand Module


New member

Posts

Joined
Tue May 22, 2012 9:07 pm

Post by zara0 » Wed Mar 27, 2013 4:25 am

I had the same problem on a Hostgator server. Make sure all folders are chmod 755 and files within are chmod 644. This fixed my admin page :)

Newbie

Posts

Joined
Sun Mar 24, 2013 9:04 am
Who is online

Users browsing this forum: No registered users and 46 guests