Post by mcleano99 » Mon May 14, 2012 7:00 pm

Hi,

I would appreciate any help i can get trying to get my site to work with the seo urls. I have been on this forum trying different bits'n'pieces as there are similar posts but i just cannot get this to work. I am tearing my hair out.

My Opencart install is in the root (public_html). I have enabled the SEO URLs in the System->settings->Server.

I checked with my host (Arvixe) to make sure the apache module mod-rewrite was installed and they were.

vqmod is installed

My htaccess file is found in the top level directory and renamed .htaccess. I have tried commenting out the following:

Options FollowSymlinks

Options -Indexes

At the moment it is the default htaccess.txt file with the extension deleted to be htaccess.

All my top level catagories have the 'seo keyword' filled in with either - or _ instead of spaces. When i try the site it gives me 404 errors. It is as if the pages are not there. The error is:

Not Found

The requested URL /bob_ross_canvas was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

It is as if the software is not creating the page? I am not a programer so its hard for me to get my head round it and i am pulling my hair out. Any advice or help would be VERY much appreciated before i am bald. I would be willing to pay at this point to get it running.

The site is http://www.happy-painting.com

Thanks in advance for any advice, as i say it will be appreciated.

Newbie

Posts

Joined
Mon May 14, 2012 6:38 pm

Post by florinsith » Mon May 14, 2012 7:02 pm

its renamed .htaccess. ? if yes, it has to be .htaccess only, without the second dot.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by mcleano99 » Mon May 14, 2012 7:17 pm

I cannot thank you enough. That one small dot just changed my life. I have spent literally hours and hours trying to get this working.

THANK YOU!

Just out of interest is there a reason there is no file extension at the end ie .htm/.html

Newbie

Posts

Joined
Mon May 14, 2012 6:38 pm

Post by victorj » Mon May 14, 2012 10:33 pm

mcleano99 wrote:THANK YOU!

Just out of interest is there a reason there is no file extension at the end ie .htm/.html
Server protection without extension it is not possible to laod file from outside of server.

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Eigen productie en snelle levering.
https://123-deurrubbers.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by mux » Thu Jun 07, 2012 7:25 pm

Hi All.

I am still having this problem. Any other idea if i have any problem????

Thanks in advance

mux
Newbie

Posts

Joined
Thu Jun 07, 2012 7:23 pm

Post by mux » Thu Jun 07, 2012 7:33 pm

Oh.... I have done. Thanks guys.... your discussion was helpful to me

mux
Newbie

Posts

Joined
Thu Jun 07, 2012 7:23 pm

Post by jimmyharwood » Tue Aug 28, 2012 11:00 pm

I am having the same problem, my SEO url is also getting 404 in Google, for example
http://scootssuitsandboots.com/ben-sher ... et-red.php when fetched by Google is coming not found, but the link is active, the crawl stats are dropping at an alarming speed, any body knows why - I think I may have to get rid of the SEO option.

Cheers

Jimmy

New member

Posts

Joined
Thu Dec 29, 2011 12:55 am

Post by ALandi » Mon Oct 15, 2012 12:29 am

Hi guys.

I've followed all the steps possible to make SEO URL work, but it is not cooperating with my. It is still returning 404 error when I navigate the site.

Facts:
1. I'm using 1.5.3.1. version.
2. My host ARVIXE confirms SEO URL's apache module has mod-rewrite active.
3. I have set and saved YES on Setting > Server > Use SEO URL's:
4. All products and categories have its Seo Url set on its Data tab.
5. .htaccess can be found on folders: (inside brackets and italic bellow you can see each file's contents).

/public_html/.htaccess
(EMPTY)

/public_html/vqmod/.htaccess
(# Prevent Directoy listing
Options -Indexes)


/public_html/__MACOSX/vqmod/._.hatchess
(����Mac OS X ���� ���2�������������������������������������������������ATTR���������������M����������������������M��com.apple.quarantine�q/0002;50669fb1;Safari;59431808-138B-46E4-A6A2-59AA32B0C5DB|com.apple.Safari�)

/public_html/__MACOSX/admin/view/javascript/ckeditor/._.htaccess
(����Mac OS X ���� ���2�������������������������������������������������ATTR���������������M����������������������M��com.apple.quarantine�q/0002;50669faf;Safari;59431808-138B-46E4-A6A2-59AA32B0C5DB|com.apple.Safari�)

/public_html/admin/view/javascript/ckeditor/.htaccess
(#
# Copyright (c) 2003-2012, CKSource - Frederico Knabben. All rights reserved.
# For licensing, see LICENSE.html or http://ckeditor.com/license
#

#
# On some specific Linux installations you could face problems with Firefox.
# It could give you errors when loading the editor saying that some illegal
# characters were found (three strange chars in the beginning of the file).
# This could happen if you map the .js or .css files to PHP, for example.
#
# Those characters are the Byte Order Mask (BOM) of the Unicode encoded files.
# All FCKeditor files are Unicode encoded.
#

AddType application/x-javascript .js
AddType text/css .css

#
# If PHP is mapped to handle XML files, you could have some issues. The
# following will disable it.
#

AddType text/xml .xml)


Anyone have any clue on what to do to make it work???
Thanks guys.

Newbie

Posts

Joined
Tue Jun 05, 2012 3:49 pm

Post by ALandi » Mon Oct 15, 2012 12:49 am

Post bellow worked partially for me.

http://forum.opencart.com/viewtopic.php ... eo#p349060

I've pasted the lines below into my .htaccess files.

# SEO URL Settings
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

However, it only works for products, categories and Information. Being more clear, SEO works only with pages I can access and edit in ADMIN. The ones I do not have access to in ADMIN such as HOME, BRANDS, SPECIAL, CONTACT US, SITE MAP, etc, I'm not able to change it for SEO Url.

Anyone found out how to change it to SEO Urls???

Newbie

Posts

Joined
Tue Jun 05, 2012 3:49 pm

Post by Axansh » Mon Oct 15, 2012 6:33 pm

Hi,

We have developed an extension for SEO - to make it easy for seller.

This module helps you with optimizing the url's of all your website pages , categories , products , manufacturers , information pages .

you can also optimize the titles , meta tag keywords , meta tag descriptions of all the links , categories , products , manufacturers , information pages .

If you add new links or catalog data - they can be optimised as well .

All optimizations can be done for multiple languages .

Image names can also be optimized .

For fast results , less data entry - you can use auto generate facility

Thanks and Best Regards,
Axansh Sheth

Our Opencart Module
All in ONE SEO |
Multi-purpose pop |
Restaurant theme |
Store time save module


User avatar
Active Member

Posts

Joined
Mon Feb 06, 2012 3:07 pm

Post by dpinney » Thu Jun 05, 2014 7:42 pm

florinsith wrote:its renamed .htaccess. ? if yes, it has to be .htaccess only, without the second dot.

WELL THIS DOES NOT WORK FOR ME I REMOVED THE SECOND DOT AFTER HTACESS AND I STILL GET 404 PAGE

Newbie

Posts

Joined
Thu Jun 05, 2014 7:33 pm

Post by dpinney » Thu Jun 05, 2014 7:46 pm

its renamed .htaccess. ? if yes, it has to be .htaccess only, without the second dot.

I tried this also, removed the second dot at end of htacess to no avail i still get a 404

Newbie

Posts

Joined
Thu Jun 05, 2014 7:33 pm

Post by markuswest » Thu Oct 30, 2014 10:32 pm

Hi,

I also struggled and got it working, what I did is:

I copied the htaccess.txt to my computer via FileZilla

on my computer I opened the htaccess.txt file with the windows notepad program

from here: http://www.sitefixit.com/files/opencart/htaccess.txt
I copy & pasted the info into the htaccess.txt file and saved

I uploaded the htaccess.txt back to the server, in the root directory then

I renamed the file from "htaccess.txt" to ".htaccess"
Note: make sure its not ".htaccess." that second "." will cause errors

I have seen if you save the "htaccess.txt" file with notepad++ the info looks like a paragraph and that caused errors on my server.

for reference the original htaccess.txt file:
# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

--
South Africa, Johannesburg GMT +2


User avatar
New member

Posts

Joined
Wed May 29, 2013 4:22 am
Location - South Africa, Pretoria
Who is online

Users browsing this forum: No registered users and 56 guests