Post by Wallimann » Thu Mar 08, 2012 1:37 am

I'm experimenting a very frustrating problem and can't seem to figure out the cause...
I sell downloads only and some downloads in my customers account are duplicated or missing.

This issue only happens in the customer download page.
If I look at the customer's order, every downloadable product appears correctly.

Any help would be very appreciated!

Guitar Backing Tracks and Video Lessons at http://www.guitarplayback.com


New member

Posts

Joined
Fri Oct 29, 2010 1:38 am
Location - Colorado

Post by merry » Thu Mar 08, 2012 9:43 am

Wallimann wrote:I'm experimenting a very frustrating problem and can't seem to figure out the cause...
I sell downloads only and some downloads in my customers account are duplicated or missing.

This issue only happens in the customer download page.
If I look at the customer's order, every downloadable product appears correctly.

Any help would be very appreciated!
Wallimann, I too sell a lot of downloads and have a lot of experience with them. I just need some more information to be able to help... without knowing a thing, I'd have to guess the customers are having a caching issue with their browsers. This is not just an OpenCart downloads issue, anybody who deals with downloads will have to occasionally tell a customer how to clear their cache.

You might also try asking the customers who have problems what browser, OS etc. that they are on... try to see if there is a pattern. Again I doubt that this is an OpenCart issue.

Good Luck,
Merry

Most answers are from my OpenCart 1.5 User Manual CURRENT TO 1.5.5.1 and includes free updates.
FREE HELP! 60-page user guide with OpenCart Admin Menu Cheatsheet, Install Guide & 30 Minute QuickStart Guide: http://showmeguides.com/


User avatar
Active Member

Posts

Joined
Thu Dec 09, 2010 12:51 am
Location - Mexico and sometimes Texas

Post by Wallimann » Thu Mar 08, 2012 11:00 pm

Thanks for the quick response...
I don't think it's a cache issue as I logged in to some of the customers accounts to try myself and can verify the issue...

This seems to happen with items that have multiple downloads associated with them...
Here are a few strange things that are probably all related:

The order of appearance of the downloads for a same product change each time a customer logs out and back in..
The duplicate and missing downloads don't happen for all customers...

Very strange!

Guitar Backing Tracks and Video Lessons at http://www.guitarplayback.com


New member

Posts

Joined
Fri Oct 29, 2010 1:38 am
Location - Colorado

Post by alber99 » Tue Oct 13, 2015 8:38 am

Having same problem with OC 2.0.3. Has there been any solution to this?

New member

Posts

Joined
Sun Apr 08, 2012 9:14 am

Post by alber99 » Sat Oct 31, 2015 8:16 am

Hmmm not much feedback in the forum lately, so in the meantime I've discovered a very simple, partial solution.

Go into Admin > System > Settings > Option > Default Items Per Page (Catalog). Change the number to a high enough number that all downloads show on the same page.

What seems to be happening is, on each page load the downloads re-sort randomly and so the order keeps changing from page to page - making it seem like there are missing downloads. So if you force everything to load on the same page you'll see that they are all there. But each time you reload the page they will re-shuffle (sort) again, but as long as they are on the same page you'll find them all there. At least that's how it works on my site.

I've simply upped the number to 200 and it seems to load fine without slowdown. However this also effects the product thumbnail listings on the front end - but it does not seem to slow my page load.

Maybe someone else has a solution to the random resorting ?

New member

Posts

Joined
Sun Apr 08, 2012 9:14 am
Who is online

Users browsing this forum: No registered users and 16 guests