Post by storm-cloud » Wed Feb 22, 2012 1:25 pm

I am looking to setup Wholesale pricing and at the moment I experimented with setting up a "Discount" price for the "Default" customer group. I figured if I can get the discounted price to show up here, then just change Discount so that it only applies to the Wholesale Customer Group, the pricing should then only apply to Wholesale customers.

Problem is I set the price on the "Discount" tab and the price stays the same.

I am viewing the site as a guest and the default Customer Group is "Default" but the price still stays as original full price.

Note: I am running OpenCart v1.5.1.3.1 have vQmod v2.1.5 installed and the Price Option Update (Redux) extension installed.

Note: The "Special" option seems to work but then I get prices crossed out showing both on the site and on the admin catalog page. I would prefer if possible to simply show different prices when a customer is logged in under the Wholesale Customer Group.

Any ideas? I would be truly thankful if anyone can point me in the right direction.
Last edited by storm-cloud on Mon Feb 27, 2012 1:23 am, edited 1 time in total.

Active Member

Posts

Joined
Wed Feb 22, 2012 8:07 am

Post by storm-cloud » Thu Feb 23, 2012 4:23 pm

No ideas why this standard included feature is not functioning?

Just to clarify for product discount to work:

1) I edit a product and click on the discount tab.
2) I enter a price, assign a Customer Group (in this case default) and click save.
3) Any customers in the assigned customer group viewing the site (in this case all customers as default is being used) will see the discounted prices.

If the above is correct, this is not working.
Last edited by storm-cloud on Sun Feb 26, 2012 12:24 pm, edited 1 time in total.

Active Member

Posts

Joined
Wed Feb 22, 2012 8:07 am

Post by storm-cloud » Sun Feb 26, 2012 12:23 pm

I don't mean to keep bumping this thread but surely this option should just work?

Perhaps I have configured this incorrectly... I would sincerely appreciate help on this, as this is an important feature for us as we do have Wholesale Customers.

Active Member

Posts

Joined
Wed Feb 22, 2012 8:07 am

Post by 2112 » Wed Feb 29, 2012 1:39 am

I am having the same problem but I get nothing when I try to add - discount/image/attribute to a product that was already entered and has a couple discounts already. Nothing pops up. This just started happening out of the blue. I get the yellow triangle at the bottom of IE8 saying done but with errors.

Did you get any answers? I posted help and no one seems to have an answer.

Newbie

Posts

Joined
Thu Feb 09, 2012 6:23 am

Post by storm-cloud » Thu Mar 01, 2012 4:40 pm

2112 wrote:Did you get any answers? I posted help and no one seems to have an answer.
No, not yet. I don't get any errors... I just enter a product discount, go back and view the site and the full price still shows...? Don't know what could be wrong.

Active Member

Posts

Joined
Wed Feb 22, 2012 8:07 am

Post by Qphoria » Fri Mar 02, 2012 3:24 am

storm-cloud wrote:No ideas why this standard included feature is not functioning?

Just to clarify for product discount to work:

1) I edit a product and click on the discount tab.
2) I enter a price, assign a Customer Group (in this case default) and click save.
3) Any customers in the assigned customer group viewing the site (in this case all customers as default is being used) will see the discounted prices.

If the above is correct, this is not working.
Well default is the "normal" price which also shows for guests. I'm not sure using default in the discount tab will work right. Try setting the customer as wholesale and add the discount as wholesale and see if that works.

There are no known issues with this functionality.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by storm-cloud » Sun Mar 04, 2012 10:51 am

Thank you Qphoria,

I tried this with the Wholesale group instead...

Now when adding an item to the cart logged in as a Wholesale Customer, the discount works and is applied correctly. However, the price does not change on the actual website. It is only after a product is added to the Cart that the discount is applied.

Is this normal behavior?

Edit: I also just noticed that if I assign a quantity to the product discount, then it stops working and reverts back to normal price. Should this be submitted as a bug?

Active Member

Posts

Joined
Wed Feb 22, 2012 8:07 am

Post by strobes » Wed Mar 14, 2012 12:37 am

I am having the exact same problem as above....

the customers coemto the site and see whatever is set as the default price.. when they log in they should see the pricing for their own group but they dont, they see the default pricing for the site

Once they have added items to the shopping cart and go into the cart they can then see the prices have changed

surely the prices should change on the main site? they sholdnt have to add things into the shopping cart before they can see the true price.... it would certainly put me off if i saw something was priced too high

any help would be much appreciated

cheers

steve

New member

Posts

Joined
Fri Sep 02, 2011 7:13 pm

Post by strobes » Fri Mar 16, 2012 9:25 pm

Can anyone help with this... Its the only problem i have with my site and its putting my discount customers off buying as they can see the higher price and are assuming this is what they will have to pay :(

any help would be very much appreciated!

New member

Posts

Joined
Fri Sep 02, 2011 7:13 pm

Post by Qphoria » Fri Mar 16, 2012 10:13 pm

This is video demo of a fresh install of 1.5.1.3, showing what you are claiming doesnt work:
http://screencast.com/t/bs7bYGKwG
As you can see it is working perfectly.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by strobes » Fri Mar 16, 2012 11:18 pm

Thanks very much for the video, i now see what i was doing wrong.. I had priority as zero.. silly mistake but infuriating when you look past it

Thanks again for taking the time to show me... much appreciated

Steve

New member

Posts

Joined
Fri Sep 02, 2011 7:13 pm

Post by sportyhabits » Fri Oct 05, 2012 2:53 pm

Hi All, I am having the same problem. My localhost works fine but on webserver hosting it is not working. Any help is appreciated. I even checked for priority too (it is not zero), tried other browsers too, cleared cache ...

Newbie

Posts

Joined
Sat Jun 09, 2012 3:21 pm

Post by sportyhabits » Fri Oct 05, 2012 3:18 pm

It looks to be a bug .... it doesn't work if I have "special" price - works if I remove it.

I would prefer that I show MRP of product, using special show my selling price. And on top of it give quantity discount.

http://www.sportyhabits.com/yonex-carbo ... 8strung%29

Any help/advice is appreciated.

thanks
SportyHabits

Newbie

Posts

Joined
Sat Jun 09, 2012 3:21 pm

Post by storm-cloud » Sun Nov 04, 2012 3:51 pm

Please excuse me for digging up such an old thread but I decided to look into this again.

I have just found out exactly where the issue lies (with OpenCart v1.5.1.3 at least, possibly still present in later releases).

Yes Q, your video does indeed show the product discount working. However, this was due to you setting the quantity as 1.

For even more odd behaviour, when leaving the quantity blank, the discount does not show on the category or product pages but is still applied when adding an item to the cart. However, setting the quantity to 2 or greater causes the discount function to no longer work.

Further to this, the quantity set in the discount tab seems to be ignored. When purchasing a quantity of 2 or more, checkout is still permitted even though quantity was previously set as 1 in the discount tab. However, further testing here shows that the quantity set in the standard data tab is obeyed as I did attempt to purchase greater than this quantity and this was not permitted.

Any suggestions on how to rectify this issue?

Active Member

Posts

Joined
Wed Feb 22, 2012 8:07 am

Post by czorny » Wed Nov 14, 2012 10:59 am

Yes, I want to confirm, that discount feature does NOT work, no matter what. I've added a discount for 6 pcs of certain item, but no discount is being counted. I've tried some options and looks like discounts and specials do not work together.

For example, I have a permanent discount (Special tab) plus a discount for certain quantity of the same item (Discount tab). When special is active, discount don't count. If I remove special, discount will work.

Well, this one IS a bug, since special price and quantity discount must NOT cross. At least, when quantity in discount is higher than 1.

New member

Posts

Joined
Sat Sep 08, 2012 2:37 am

Post by netstrada » Fri Jul 26, 2013 9:52 am

Yes, the "SPECIAL" must be turned off otherwise "DISCOUNT" will not work at all.Fixed , thanks :drunk:

Newbie

Posts

Joined
Fri Jan 04, 2013 2:40 pm

Post by bruno05 » Tue Aug 13, 2013 2:11 pm

This is definitely a bug. This is a huge and normal feature where most people will have a special price from the MSRP and to get more sales they will want to give quantity discount. I consider this a basic feature of a good shopping cart. Example of how this would work...Main price 100, Special price 75 so it would show 100 crossed out and 75 as the price. When you go to details, it does show the discount price if you buy 5 (my example as 5 quantity and 60 as the price). So all that works.

Where it fails is when I add product to cart, it still shows special price and not the discounted price no matter what quantity I add above 5.

So saying 'fixed' does not cut it. Appreciate if you classify this as a bug and attempt to fix it . I am using the 1.5.5.1 and this is still an issue.

Newbie

Posts

Joined
Tue Aug 13, 2013 2:07 pm

Post by angienithya » Wed Nov 13, 2013 2:52 pm

Thanks for the guide on this!! Worked for me well....

Newbie

Posts

Joined
Fri Oct 25, 2013 10:34 pm

Post by taraksias » Thu Nov 28, 2013 8:36 am

im using 1.5.4.1 and its working for me. The thing is that when i set the start date to todays date it doesnt work, but when i set it to yesterdays date it works properly.

so to recap, it works like this:

group: default
quantity: 1
priority: 1
price: the final amount of the product after discount
date start: yesterdays date
date end: at least tomorrows date

the great thing is that you can add multiple discounts per product like this

(for quantity one the price is 5)
group: default
quantity: 1
priority: 1
price: 5
date start: yesterdays date
date end: at least tomorrows date

(for quantity 3 the price is 4 each)
group: default
quantity: 3
priority: 1
price: 4
date start: yesterdays date
date end: at least tomorrows date

(for quantity 5 the price is 3 each)
group: default
quantity: 5
priority: 1
price: 3
date start: yesterdays date
date end: at least tomorrows date

and with that way you can have a combination of discounts per quantity for the same product :)

Thank you to the developers of OpenCart!

Newbie

Posts

Joined
Thu Jul 11, 2013 9:39 am

Post by deeve007 » Thu Oct 16, 2014 3:01 am

The issue is that the "priority" must be set to one. Which is NOT really very logical, and no wonder many are having this problem (I did to and found this thread, thankfully).

Zava Design | Naked Chronicles


New member

Posts

Joined
Mon Sep 27, 2010 8:05 pm

Who is online

Users browsing this forum: No registered users and 56 guests