Post by rob_ln » Wed Feb 01, 2012 3:22 am

Ok, I've been trying to set up my store mail now for like 3 hours.
I'm from the dashboard to System -> Settings, then I click edit next to my store name,
from there i go to the mail tab and set
Mail Protocol: "Mail"
Mail parameters : "myemail@gmail.com" (I've tried all my emails)
Everything else is blank up to
SMTP Port: 25
SMTP Timeout: 5

and i set new Account alert email to yes.

whenever i create an order to test it out, I receive no emails neither in my store email nor in the email i set as the customer's.
It doesn't work with the contact us form neither.

What am I doing wrong? I've searched all over the forum (a lot of ppl seem to have the same problem) and there is no answer to this question.

Please help

Newbie

Posts

Joined
Wed Feb 01, 2012 3:13 am

Post by OpenCart Addons » Wed Feb 01, 2012 3:34 am

There's a possibility that your host provider has blocked the php mail protocol.

You can try setting up an SMTP connection.

If you have CPanel, go to email accounts,
Select the dropdown list beside the email you want to use, and select "Configure Email Client"

Find the values under "Manual Settings". From here you can find the required values for an SMTP email connection:
Mail Protocol: <SMTP>
SMTP Host: <Incoming Mail Server>
SMTP Username: <Mail Server Username>
SMTP Password: <Your Password>

Joel.

Canada's Leading Expert In OpenCart Development & Certified OpenCart Development Partner Image


User avatar
Active Member

Posts

Joined
Thu Nov 24, 2011 10:51 am
Location - Canada

Post by rob_ln » Wed Feb 01, 2012 3:53 am

I have ipage hosting my site..
What do you mean by Cpanel? is that in opencart?

Newbie

Posts

Joined
Wed Feb 01, 2012 3:13 am

Post by rob_ln » Wed Feb 01, 2012 4:06 am

Ok I figured out what I was doing wrong. In the Mail parameters you have to include -f before your email address... It works fine now. I overlooked it.

Newbie

Posts

Joined
Wed Feb 01, 2012 3:13 am

Post by cmrogm » Fri Mar 09, 2012 7:26 am

Hi,
Can you please explain what you did to get it to work? I can't get any of my emails...

Newbie

Posts

Joined
Wed Feb 29, 2012 12:21 am

Post by richhelen » Fri Mar 09, 2012 9:45 am

ImageYou can try setting up an SMTP connection.

Newbie

Posts

Joined
Thu Mar 01, 2012 9:16 am

Post by panlogistics » Tue Mar 20, 2012 7:20 am

thanks for the -f took me 3 hours lucky for this post wouldn't of worked it out for days.

Newbie

Posts

Joined
Tue Mar 20, 2012 7:18 am

Post by mahesh.sherkar » Tue Jan 29, 2013 9:06 pm

We can use Gmail SMTP settings to send mail in opencart.
Go to System -> Settings -> Mail tab

Select Mail Protocol: SMTP

SMTP Host: ssl://smtp.gmail.com

SMTP Username: your gmail username

SMTP Password: your gmail password

SMTP Port: 465


Image


Best Regards,
Mahesh Sherkar
http://Mahesh-Sherkar.com

User avatar

Posts

Joined
Fri Jan 25, 2013 2:26 pm
Location - Pune

Post by blurb » Wed Jan 30, 2013 5:32 am

rob_ln wrote:Ok, I've been trying to set up my store mail now for like 3 hours.
I'm from the dashboard to System -> Settings, then I click edit next to my store name,
from there i go to the mail tab and set
Mail Protocol: "Mail"
Mail parameters : "myemail@gmail.com" (I've tried all my emails)
Everything else is blank up to
SMTP Port: 25
SMTP Timeout: 5

and i set new Account alert email to yes.

whenever i create an order to test it out, I receive no emails neither in my store email nor in the email i set as the customer's.
It doesn't work with the contact us form neither.

What am I doing wrong? I've searched all over the forum (a lot of ppl seem to have the same problem) and there is no answer to this question.

Please help
Go to: Settings > Edit > General - enter your email address

Then click on: Mail - SMTP Host and type in 'Localhost'

It should work straight out of the box as they say

Have a great day everyone :)


User avatar
New member

Posts

Joined
Fri Jan 11, 2013 3:52 pm
Location - New Zealand

Post by blurb » Wed Jan 30, 2013 5:36 am

mahesh.sherkar wrote:We can use Gmail SMTP settings to send mail in opencart.
Go to System -> Settings -> Mail tab

Select Mail Protocol: SMTP

SMTP Host: ssl://smtp.gmail.com

SMTP Username: your gmail username

SMTP Password: your gmail password

SMTP Port: 465


Image


Best Regards,
Mahesh Sherkar
http://Mahesh-Sherkar.com
Using a 3rd party mail service, with respect, merely downgrades ones shop as most spammers and scammers use them.

Using your princible email address in your shop emails shows status ... in my opinion.

Have a great day everyone :)


User avatar
New member

Posts

Joined
Fri Jan 11, 2013 3:52 pm
Location - New Zealand

Post by fers1970 » Fri Feb 08, 2013 4:00 am

mahesh.sherkar wrote:We can use Gmail SMTP settings to send mail in opencart.
Go to System -> Settings -> Mail tab

Select Mail Protocol: SMTP

SMTP Host: ssl://smtp.gmail.com

SMTP Username: your gmail username

SMTP Password: your gmail password

SMTP Port: 465


Image


Best Regards,
Mahesh Sherkar
http://Mahesh-Sherkar.com
Hi, this worked great for me...thanks!!

Newbie

Posts

Joined
Sat Jan 26, 2013 3:59 am

Post by arieltobey » Mon Feb 11, 2013 10:38 am

yup
worked for me too! - no point in using the domain email if it doesn't work :/

Newbie

Posts

Joined
Mon Feb 11, 2013 7:57 am

Post by kapees » Tue Nov 26, 2013 12:45 am

Doesn't work for me, and I received email form google "suspicious sign in prevented"

Newbie

Posts

Joined
Tue Nov 26, 2013 12:43 am

Post by kapees » Tue Nov 26, 2013 5:54 am

Damn... it's doesn't work for me, I think google is blocking my server or something like that

Newbie

Posts

Joined
Tue Nov 26, 2013 12:43 am

Post by filiciapicken » Fri Jan 24, 2014 9:32 am

I just tried all the settings described here, and nothing worked for me. I cannot allow the public to use my store till I can get this email problem fixed. Right now no customers or myself receive order notifications

Newbie

Posts

Joined
Thu Jan 23, 2014 10:52 am

Post by andresyazahra » Wed Feb 05, 2014 1:05 pm

I have the same problem,,,,but now i have fixed it
just change your password in your host (example:gmail.com)and give the permission to the application,,and tell them that was you who tried to send the email.....
(sorry for the bad English ;) )

Newbie

Posts

Joined
Wed Feb 05, 2014 1:00 pm

Post by nuski » Sun Mar 16, 2014 9:55 pm

Hi, this works for me...

Mail Protocal: Mail

Main Parameters: -fmyemail@gmail.com (you have to add "-f" without quotes. Eg: if your email address is yourmail@gmail.com, you should put it like -fyourmail@gmail.com)

SMTP Port: 25

SMTP Time: 5

New order alert: Yes

New acct alert: Yes

My host iPage
OpenCart version 1.5.5.6

Newbie

Posts

Joined
Tue Mar 11, 2014 12:37 pm

Post by bizzebee » Sat Aug 16, 2014 12:12 pm

Can anyone confirm if this worked? I entered the following, under mail and I'm using 1.5.6.4:

Mail Protocol: Mail
Mail Perametors: -fmyemail@myisp.com
Nothing in any other field until
SMTP Port: 25
SMTP Time: 5
New order alert: Yes
New acct alert: Yes

I have verified with my ISP that port 25 is NOT blocked and the aforementioned STILL does not work.....no emails work from contact us form, or anything....please advise if a solution was found and/or where to find it. Thanks

User avatar
New member

Posts

Joined
Sun Feb 20, 2011 9:54 pm

Post by Cue4cheap » Sat Aug 16, 2014 9:55 pm

bizzebee wrote:Can anyone confirm if this worked? I entered the following, under mail and I'm using 1.5.6.4:

Mail Protocol: Mail
Mail Perametors: -fmyemail@myisp.com
Nothing in any other field until
SMTP Port: 25
SMTP Time: 5
New order alert: Yes
New acct alert: Yes

I have verified with my ISP that port 25 is NOT blocked and the aforementioned STILL does not work.....no emails work from contact us form, or anything....please advise if a solution was found and/or where to find it. Thanks
If you are choosing MAIL for your protocol then filling in all that your a doing it wrong.... Choose SMTP.

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by bizzebee » Sat Aug 16, 2014 10:25 pm

Thank you but the issue was resolved previously. It seems there was a coding issue that has now been fixed. I am very grateful for your input tho and hope it can help others as well. You guys are awesome!

User avatar
New member

Posts

Joined
Sun Feb 20, 2011 9:54 pm
Who is online

Users browsing this forum: No registered users and 66 guests