Post by zeevy » Tue Jul 21, 2009 8:28 pm

Hi,
I am using resent version of opencart v1.3.0
emails using smtp are not working, the page says "Your message has been successfully sent!" but no mails are received.

i can able to use smtp successfully using pear package.
the bellow code works perfectly, and my server runs on SSL.
is there any thing i have to change in opencart

thanks
<?php
require_once "Mail.php";

$from = "Sandra Sender <user@domain.com>";
$to = "Customer <customer@domain.com>";
$subject = "Hi!";
$body = "Hi,\n\nHow are you?";

$host = "ssl://somehost.com";
$port = "portno";
$username = "storekeeper@domaincart.com";
$password = "password";

$headers = array ('From' => $from,
'To' => $to,
'Subject' => $subject);
$smtp = Mail::factory('smtp',
array ('host' => $host,
'port' => $port,
'auth' => true,
'username' => $username,
'password' => $password));

$mail = $smtp->send($to, $headers, $body);

if (PEAR::isError($mail)) {
echo("<p>" . $mail->getMessage() . "</p>");
} else {
echo("<p>Message successfully sent!</p>");
}
?>

New member

Posts

Joined
Tue Jul 21, 2009 8:08 pm

Post by Daniel » Tue Jul 21, 2009 8:34 pm

what is the address of the mail server?

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by motoridder » Wed Jul 22, 2009 4:16 am

After adding the SMTP details (login, e-mail etc.), the menu button isn't allowing me to acces the 'mass' e-mail sending to customers. Daniel why's that? Can you help me please?

I get an error like: Permission denied!

Newbie

Posts

Joined
Mon Jul 16, 2007 1:46 pm

Post by Daniel » Wed Jul 22, 2009 4:43 am

i'm not sure i should go to this fully or not. there are many different ways a mail server can be configured. they may not allow mass mailings.

when using pear did you do a mass mail?

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by zeevy » Wed Jul 22, 2009 1:26 pm

Daniel wrote:what is the address of the mail server?
it is.

Outgoing Mail Server: (SSL) linux.securehostdns.com (server requires authentication) port 465

New member

Posts

Joined
Tue Jul 21, 2009 8:08 pm

Post by readyman » Wed Jul 22, 2009 2:57 pm

I just had this issue with another PHP form mailer when sending email in the format "Customer <customer@domain.com>" - I got a success message everytime, but a filter of some sort was not actually sending the email.
I fixed the problem by entering the email address in the $to field.

Try mailing using only the email address instead, to see if it's the same problem.
eg.
WRONG - $to = "Customer <customer@domain.com>";
RIGHT - $to = "customer@domain.com";

http://www.alreadymade.com
Follow me on twitter.com/alreadymade


User avatar
Global Moderator

Posts

Joined
Wed May 20, 2009 5:16 am
Location - Sydney

Post by zeevy » Wed Jul 22, 2009 3:15 pm

readyman wrote:I just had this issue with another PHP form mailer when sending email in the format "Customer <customer@domain.com>" - I got a success message everytime, but a filter of some sort was not actually sending the email.
I fixed the problem by entering the email address in the $to field.

Try mailing using only the email address instead, to see if it's the same problem.
eg.
WRONG - $to = "Customer <customer@domain.com>";
RIGHT - $to = "customer@domain.com";

how can i change this in opencart

New member

Posts

Joined
Tue Jul 21, 2009 8:08 pm

Post by zeevy » Thu Jul 23, 2009 1:05 pm

zeevy wrote:
Daniel wrote:what is the address of the mail server?
it is.

Outgoing Mail Server: (SSL) linux.securehostdns.com (server requires authentication) port 465
any solution for this problem ?

thanks

New member

Posts

Joined
Tue Jul 21, 2009 8:08 pm

Post by zeevy » Mon Jul 27, 2009 3:00 pm

Daniel wrote:what is the address of the mail server?
it is.

Outgoing Mail Server: (SSL) linux.securehostdns.com (server requires authentication) port 465

any solutions please.

New member

Posts

Joined
Tue Jul 21, 2009 8:08 pm

Post by zeevy » Wed Jul 29, 2009 3:28 pm

smtp over ssl is working fine in presta shop is there any way to use that class

thanks

gv

New member

Posts

Joined
Tue Jul 21, 2009 8:08 pm

Post by plastio » Wed Jul 29, 2009 6:25 pm

Hi Daniel,
What do you say about integrating the phpmailer package within opencart,
since the broute force solution of smtp not seems to wait for server replies
and only perform successive fputs I guess that most mail server will reject that
kind of session even with minimum security defaults.

I have successfully integrated the phpmailer in my opencart website
and mails seems to propogate well using my smtp server (with authentication).

TX

Newbie

Posts

Joined
Fri Jul 24, 2009 11:20 pm

Post by Daniel » Wed Jul 29, 2009 7:21 pm

you get to choose your own port in the admin!

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by zeevy » Thu Jul 30, 2009 6:23 pm

plastio wrote:Hi Daniel,
What do you say about integrating the phpmailer package within opencart,
since the broute force solution of smtp not seems to wait for server replies
and only perform successive fputs I guess that most mail server will reject that
kind of session even with minimum security defaults.

I have successfully integrated the phpmailer in my opencart website
and mails seems to propogate well using my smtp server (with authentication).

TX
Can tell me how use phpmailer in opencart

thanks

New member

Posts

Joined
Tue Jul 21, 2009 8:08 pm

Post by Daniel » Thu Jul 30, 2009 7:55 pm

plastio wrote:Hi Daniel,
What do you say about integrating the phpmailer package within opencart,
since the broute force solution of smtp not seems to wait for server replies
and only perform successive fputs I guess that most mail server will reject that
kind of session even with minimum security defaults.

I have successfully integrated the phpmailer in my opencart website
and mails seems to propogate well using my smtp server (with authentication).

TX

I prefer to use opencarts class because its smaller and uses one class to do everything. Its I better I just fix the current one.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: No registered users and 13 guests