Post by capt_midnight » Fri Jan 06, 2012 11:58 pm

Hi,

I've installed OpenCart and really like the features and options, but it seems to be lacking a SEF URL from something like this:

/index.php?route=extension/extension/info&extension_id=9999

to something like this:

/category/apple/accessories.html

Is this possible? Is there a module that I can buy to make it work this way with SEF URLs?

Thanks,
Shane

Newbie

Posts

Joined
Fri Jan 06, 2012 11:25 pm

Post by d7a7z7e7d » Sat Jan 07, 2012 12:09 am

All you have to do is rename the ".htaccess.txt" file in your document root to ".htaccess" and then turn on SEO Urls in the admin "System > Settings > Edit > Server > Use SEO URLs". Then, you'll notice each category and product has an SEO Keyword field that you can use to define what the friendly URL should look like. There are even extensions that will auto-populate these fields by slugifying your product or category names.

Image
OpenCart Extensions, Technical Support & Custom Development | Have I helped you?


User avatar
Active Member

Posts

Joined
Fri Sep 17, 2010 5:51 am
Location - USA

Post by capt_midnight » Sat Jan 07, 2012 4:56 am

Oooo.. perfect.. I missed that. I had already copied the .htaccess, but turning that feature "on" was missing.

Thanks again for the quick response!

Newbie

Posts

Joined
Fri Jan 06, 2012 11:25 pm

Post by Gorilla » Thu Apr 05, 2012 10:58 am

I just tried this i renamed the file
.htaccess.txt
to
.htaccess
but right after i do that i get a
Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500
em i missing something and it doesn't make a difference if i set-up the sef url from the setting first as soon as i rename the file i'm screwed

mike = http://www.gorillagear.ca


New member

Posts

Joined
Fri Jun 25, 2010 7:14 am

Post by Johnathan » Thu Apr 05, 2012 11:36 am

That probably means your .htaccess file has bad rewrites. Re-upload the .htaccess file for your version of OpenCart.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by Gorilla » Thu Apr 05, 2012 12:04 pm

Once this was commented out i'm good to go

Code: Select all

#Options +FollowSymlinks

# Prevent Directoy listing 
#Options -Indexes
i'm a trial and error type guy so do i need this stuff i commented out?

mike = http://www.gorillagear.ca


New member

Posts

Joined
Fri Jun 25, 2010 7:14 am

Post by syednayab » Tue Jun 19, 2012 6:06 pm

Hi

i renamed the Htacess file and enabled SEO Url but no luck ,

Life is a Gift! and it offers us the privilege, opportunity, and responsibility to give something back by becoming more......


New member

Posts

Joined
Tue Nov 01, 2011 8:03 pm
Location - Mumbai India

Post by syednayab » Fri Jun 22, 2012 6:19 pm

Johnathan wrote:That probably means your .htaccess file has bad rewrites. Re-upload the .htaccess file for your version of OpenCart.

Thanks it worked

Life is a Gift! and it offers us the privilege, opportunity, and responsibility to give something back by becoming more......


New member

Posts

Joined
Tue Nov 01, 2011 8:03 pm
Location - Mumbai India

Post by Jtc-uk » Mon Jan 28, 2013 12:43 am

so i have done just about everything i could find, changed the htaccess file name checked the SEO in the admin, entered the SEO words in with -, re-uploaded the htaccess file and renamed it again, but still nothing, the URL's are changing but i keep getting ERROR 404- PAGE NOT FOUND?

Any suggestions?

New member

Posts

Joined
Sat Jan 19, 2013 5:20 am

Post by Axansh » Tue Jan 29, 2013 3:27 pm

HI,

Just backup your .htaccess file and and upload this code.

# SEO URL Settings
RewriteEngine On
RewriteBase /Your_sub_directory_name/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

Hope it works.

Thanks and Best Regards,
Axansh Sheth

Our Opencart Module
All in ONE SEO |
Multi-purpose pop |
Restaurant theme |
Store time save module


User avatar
Active Member

Posts

Joined
Mon Feb 06, 2012 3:07 pm

Post by Jtc-uk » Sun Feb 03, 2013 11:31 pm

nope still nothing, opencart say talk to hostgator, hostgator say talk to opencart, i'm at a loose end keep looking over the files and i cannot see anything that may be effecting it, but i am a noob and i'm no were near a code genius. it is probably something very simple that i have not seen, but this has been a problem for around 2 weeks now and I'm on the verge of giving up on it, but then it will annoy me every time i go to my webpage.

New member

Posts

Joined
Sat Jan 19, 2013 5:20 am

Post by Jtc-uk » Thu Feb 07, 2013 1:43 am

ok solved the SEO problem except for one thing, everything else is working fine except when i click the home page i get the 404 message again??

New member

Posts

Joined
Sat Jan 19, 2013 5:20 am

Post by Jtc-uk » Thu Feb 07, 2013 3:26 am

problem solved

New member

Posts

Joined
Sat Jan 19, 2013 5:20 am

Post by sputnik-1 » Wed Aug 21, 2013 4:58 am

That worked fine for me TY! I had .htaccess in my root folder and just had to enable this in the admin section under server :)

User avatar
New member

Posts

Joined
Sun Apr 28, 2013 5:01 am
Who is online

Users browsing this forum: No registered users and 10 guests