Post by jon22 » Tue Jul 14, 2009 1:09 am

getting this error, not on the homepage but its on all other pages.

Notice: Undefined index: description in /home/xxx/public_html/mysite.com/catalog/controller/product/category.php on line 52

Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/mysite.com/catalog/controller/product/category.php:52) in /home/xxx/public_html/mysite.com/system/library/response.php on line 65

The code on line 52 in catalog/controller/product/category.php is as follows.

$this->data['description'] = html_entity_decode($category_info['description']);

any problems here?(this line of code is not in the previous version can i remove it?
____________________________________________________________________________

Ive just noticed in the admin area i can't edit any products. when click save i get this screen:

Error: Unknown column 'keyword' in 'field list'
Error No: 1054
UPDATE product SET model = '612585960978', keyword = 'car signs', image = '230x230.898.thanks_4_parking_so_close.jpg', quantity = '4', stock_status_id = '7', date_available = '2009-06-15', manufacturer_id = '0', shipping = '1', price = '2.99', sort_order = '0', weight = '0.5', weight_class_id = '1', status = '1', tax_class_id = '0', date_modified = NOW() WHERE product_id = '74'

ive followed all the correct procedure for the upgrade - this is a nightmare
appreciate a speedy response if anyone knows how to fix. thanks all.

JME Web Design


User avatar
New member

Posts

Joined
Thu May 28, 2009 5:44 pm


Post by gavin m » Tue Jul 14, 2009 7:28 pm

I had the same thing when I upgraded.

I fixed but, but all I did was:

back up my database
Delete my database
back up files with chages etc
backed up images folder
Deleted site
uploaded new site
created new database
browsed to site and installed as normal
Went into PHP and 'EMPTIED' all the tables in the database (I was having trouble importing my data back in, and this was caused by duplicat entries)
overwrote the images folder with mine
merged all custom changes back into the required files.

It took about three attempts to get it to work....

I also found that by doing it this way, you don't end up with a dreaded hybrid site of your products and all the demo stuff on there.

Active Member

Posts

Joined
Thu Jun 04, 2009 3:23 pm

Post by jon22 » Fri Jul 17, 2009 4:30 am

wow thats more work than an original install. I gave it a few attempts but the way i see it is if its this much hassle for an upgrade its really too unstable for me, there weren't a lot of changes so no doubt another upgrade will be along soon and i don't want to go throught this again really. i know where i am with html / css now really but php? um not quite yet! thanks for the reply anyway

JME Web Design


User avatar
New member

Posts

Joined
Thu May 28, 2009 5:44 pm


Post by Daniel » Fri Jul 17, 2009 7:19 am

first what version are you upgrading from?


it seems you have update everything then restored the db using phpmyadmin or soemthing.

this is wrong because it will overwrite the new tables with the new field names.

there where instructions to upgrade in the last version.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: No registered users and 15 guests