Page 1 of 1

Product Not Found!

Posted: Fri Dec 02, 2011 4:46 am
by trev.pope
Hi,

I have an issue with Opencart 1.5.1.3, when trying to view some products I get 'Product Not Found' screen. I am using SEO URL's which is working fine with most products, but there are some where the front end just cannot find the product.

I've checked the settings for the problem products in the admin area and can find nothing unusual.

This is the URL it cannot find:

/Dog/Dog-Health-Hygiene-Grooming/Dog-Dental/Petosan-Toothpaste-for-Dogs-Poultry-Flavour

If I remove just one letter off the end in the SEO Keyword, eg the 'r' to be left with:

/Dog/Dog-Health-Hygiene-Grooming/Dog-Dental/Petosan-Toothpaste-for-Dogs-Poultry-Flavou

The front end can find the product, this led me to believe that there was a character limit that I was crossing, but with another product that works fine I can have a huge URL and still works fine.

I have a number of products like above that the Opencart front end just doesn't seem to find and I cant find a pattern as to why this would be so that I can fix it.

Has anyone else had any kind of issue like this that may know what is going on?

Many thanks

Re: Product Not Found!

Posted: Fri Dec 02, 2011 7:25 am
by jcsmithy

Code: Select all

/Dog/Dog-Health-Hygiene-Grooming/Dog-Dental/Petosan-Toothpaste-for-Dogs-Poultry-Flavour
So that is the actual keyword you are assigning for a product? or do you mean this is the keywords used in the front end when combined with the category keywords too?

Re: Product Not Found!

Posted: Fri Dec 02, 2011 6:15 pm
by trev.pope
Dog
Dog-Health-Hygiene-Grooming
Dog-Dental

Are the categories that the following product falls under

Petosan-Toothpaste-for-Dogs-Poultry-Flavour

Last night I thought, could it be the hyphens, so I removed the hyphen between Poultry and Flavour and then added a huge amount of letters after Flavour to ensure that there wasn't a character limit and to try and prove that the hyphens are the issue, so my SEO Keyword for the product name ended up being

Petosan-Toothpaste-for-Dogs-PoultryFlavourssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss

It worked perfectly, so there's definately no issue with the number of characters, it would appear that too many hyphens and there is an issue.

Does anyone know why this would be?

Many thanks

Re: Product Not Found!

Posted: Fri Dec 02, 2011 7:03 pm
by trev.pope
Issue resolved. I have an automated script which populates our database with products from our suppliers, the script also automates the building of SEO Keywords from the name of the product, there are duplicate entries being inserted for some products, where there are duplicate entries the Opencart engine can't find the product