Page 1 of 1

The contact us form is not working

Posted: Wed Nov 16, 2011 7:19 pm
by kingsbathroom
Hello,

Our customer complaint about our service so we knew our contact us form is not working. I just check with system-setting -mail. Everything seems normal, because we do receive the emails regarding new orders and new customer registrations. Everyone has any ideas?

Thank you

Re: The contact us form is not working

Posted: Wed Nov 16, 2011 10:09 pm
by jefrey1983
did you try contacting yourself? you must not assume it is broken unless you tried it yourself

Re: The contact us form is not working

Posted: Thu Nov 17, 2011 12:20 am
by uksitebuilder
It could be that your server prohibits mail being sent from an address that is not in your domain.

So you get notifications because they come from your email address

However, for contact form, the from address is set as the sender/customer and this may be being blocked.

Please (a) try sending yourself an email from a webservice email like gmail or hotmail to see if you receive it

Then (b) send yourself an email from your domain email address

If you get (a) but not (b), contact your host to see if they have some form of blocking in place.

Re: The contact us form is not working

Posted: Fri Nov 18, 2011 7:08 pm
by kingsbathroom
Hello,
we have tried ourselves quite a few times. Still not working, any further suggestions please.

Thank you

Re: The contact us form is not working

Posted: Fri Nov 18, 2011 7:13 pm
by uksitebuilder
a link might help ?

Also what are your mail settings in the system mail tab ?