Post by easicook » Thu Nov 10, 2011 9:43 pm

using version: 1.5.1.3.1

On checkout i'm getting one of the below errors, the payment goes through but the item remains in the shopping basket also it isin't visible in the order history to see hwat has been ordered

Undefined index: payment_address_id ...... checkout/payment.php on line 11
Undefined index: shipping_address_id ...... checkout/shipping.php on line 11

Newbie

Posts

Joined
Fri Sep 30, 2011 5:15 pm

Post by kristoz » Wed Dec 07, 2011 6:40 am

I'm getting in error log also PHP Notice: Undefined index: payment_address_id in /catalog/controller/checkout/payment.php on line 11

Does anyone has solution how to fix it...

New member

Posts

Joined
Sun Sep 25, 2011 9:53 pm

Post by straightlight » Wed Dec 07, 2011 6:44 am

In catalog/controller/checkout/payment.php file,

find:

Code: Select all

if ($this->customer->isLogged()) {
replace with:

Code: Select all

if ($this->customer->isLogged() && isset($this->session->data['payment_address_id'])) {
This should correct the problem.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by alaskaberries » Wed Feb 08, 2012 5:55 am

Hi,
using version 1.5.1.3 with default theme
I did this and cleared my error log. I am still experiencing this same error with new orders. What else could it be?

User avatar
New member

Posts

Joined
Sun Nov 27, 2011 12:31 am

Post by straightlight » Fri Feb 10, 2012 7:24 am

Have you installed any payment module contributions ? If so and if you disabled them and try the default checkout with another payment module as a test order, does this error message still persists ?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by alaskaberries » Fri Feb 10, 2012 9:55 am

I am using the Paypal Standard module that came with 1.5.1.3 The only other extension I have added is a multi flat rate shipping module.

User avatar
New member

Posts

Joined
Sun Nov 27, 2011 12:31 am

Post by straightlight » Fri Feb 10, 2012 11:28 am

If you disable the multi flat rate shipping module and process a test order again, will the same error persists ?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by alaskaberries » Sat Feb 11, 2012 2:08 am

I disabled the multi flat rate shipping module and ran a credit card through. There were no errors.

I really need the multi rate shipping module and even though it shows errors, it is working. I have had sucessful transactions.
What would be the best course of action?

User avatar
New member

Posts

Joined
Sun Nov 27, 2011 12:31 am

Post by straightlight » Sat Feb 11, 2012 2:11 am

The best course of action would be to communicate with the author of the commercial contribution in order to fix this specific problem.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 43 guests