Post by Dubblicious » Mon Nov 07, 2011 9:49 am

A friend of mine did a test buy with PayPal to see how the cart is working. When Opencart sent the order confirmation email, attached was a file, no file type just a bunch of letters and numbers, this is what the file was called
1bb87d41d15fe27b500a4bfcde01bb0e

Anyone know what this is ? ???

User avatar
New member

Posts

Joined
Tue Jun 14, 2011 2:35 pm

Post by Avvici » Mon Nov 07, 2011 11:20 am

What email provider are you using?

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by Dubblicious » Mon Nov 07, 2011 12:50 pm

avvici wrote:What email provider are you using?
Webmail through my server, why would that matter ? It was Opencart that attached the file. The size of the file is 6.26 KB

User avatar
New member

Posts

Joined
Tue Jun 14, 2011 2:35 pm

Post by yooperkiwi » Thu Feb 02, 2012 3:46 am

I had the same thing happen. A 13kb file is attached to the order confirmation e-mail. The file is called 80bbf90a17494eead76af9279bc0f413. I am using godaddy webmail. In the Opencart admin, settings, mail, I have selected just "Mail" and not "SMPT".

Any advice on this? I don't know what the attachment is or how to open it, but I would love to get rid of it!

Thanks!

Newbie

Posts

Joined
Thu Feb 02, 2012 3:43 am

Post by dkjoy » Thu Feb 02, 2012 12:17 pm

I was able to download and open the attachement. For me, it was the image of my store's logo.

Is there a way to have the file re-named? As it is, with the name being so long and a mixt of numbers and letters, customers might be suspicious of the file.

Newbie

Posts

Joined
Sun Sep 25, 2011 12:48 am

Post by yooperkiwi » Fri Feb 03, 2012 10:56 pm

I wasn't able to open it. I have seen messages on here about a fix for store logo not being attached, so I'll try that in the next day or so to see if that solves the problem.

Newbie

Posts

Joined
Thu Feb 02, 2012 3:43 am

Post by Dubblicious » Sat Feb 04, 2012 3:14 am

yooperkiwi wrote:I wasn't able to open it. I have seen messages on here about a fix for store logo not being attached, so I'll try that in the next day or so to see if that solves the problem.
can you post your results and any links ? Thanks :D

User avatar
New member

Posts

Joined
Tue Jun 14, 2011 2:35 pm

Post by hamburgler » Sat Feb 04, 2012 7:47 am

This can happen if you remove your store's logo from the template file. If you don't want to include an attached logo you can comment out the following code on line ~435 of catalog/model/checkout/order.php

Code: Select all

$mail->addAttachment(DIR_IMAGE . $this->config->get('config_logo'), md5(basename($this->config->get('config_logo'))));
Working in 1.5.1.3

Newbie

Posts

Joined
Fri Dec 09, 2011 6:04 am

Post by dkjoy » Wed Feb 08, 2012 12:30 am

Is there a way to rename the file? I like having the logo appear as part of the email. Thanks in advance for any help!

Newbie

Posts

Joined
Sun Sep 25, 2011 12:48 am

Post by Avvici » Tue Feb 21, 2012 6:15 pm

Do what he said and comment out that line. As you can see, it's addAttachment which you don't need.

Just include your logo as an image in the template file. Easy Peasy.

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by musashi » Sat Mar 17, 2012 8:05 am

in addition to removing the line mentioned earlier

catalog/model/checkout/order.php
line 233:

Code: Select all

$template->data['logo'] = 'cid:' . md5(basename($this->config->get('config_logo')));
change to:

Code: Select all

$template->data['logo'] = $order_info['store_url'].'image/data/IMAGENAME';
'image/data/IMAGENAME' may be different depending on the location of your logo.

Newbie

Posts

Joined
Sat Mar 17, 2012 7:59 am
Who is online

Users browsing this forum: No registered users and 39 guests